<!doctype html><!--[if IE 8]><html class="no-js lt-ie10 lt-ie9" lang="en"><![endif]--><!--[if IE 9]><html class="no-js lt-ie10" lang="en"><![endif]--><!--[if gt IE 10]><!--><html class="no-js" lang="en" ><!--<![endif]--><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/js/partner/show_ads.js"></script><title>Packers Podcast: Fantasy drafting the Packers' roster</title><meta content="text/html; charset=UTF-8" name="Content-Type" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1044.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","queueTime":0,"licenseKey":"b7ac0e2ada","agent":"","transactionName":"NARUbRdVVhdSBk0MWQ1OcEwLV0wNXAsWFkIME19cFhpODVYSSl9FFw5EQA==","applicationID":"53380547","errorBeacon":"bam.nr-data.net","applicationTime":1206}</script><meta name="google" content="notranslate"><meta name="apple-itunes-app" content="app-id=908833573"><meta name="description" content="In Wednesday&#39;s podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers&#39; roster. Find out whose team is better."><link rel="canonical" href="http://www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/"><meta property="fb:app_id" content="249896938457153"/><meta property="og:site_name" content="Packers News" /><meta name="ROBOTS" content="NOODP, NOYDIR" /><meta property="og:image" content="https://www.gannett-cdn.com/-mm-/3fef733aef5db3b32cca5383db7758bed2e7a1d1/c=0-111-500-393&r=x803&c=1600x800/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg"/><meta property="og:image:width" content="1600"/><meta property="og:image:height" content="800"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://www.gannett-cdn.com/-mm-/3fef733aef5db3b32cca5383db7758bed2e7a1d1/c=0-111-500-393&r=x803&c=1600x800/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg"/><meta property="og:image" content="https://www.gannett-cdn.com/GDContent/applogos/packersnews.png"/><meta name="twitter:site" content="@PGpackersnews" /><meta name="twitter:creator" content="@PGpackersnews" /><meta name="twitter:title" content="Packers Podcast: Cohen and Silverstein fantasy draft the Packers' roster" /><meta name="twitter:description" content="In Wednesday&#39;s podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers&#39; roster. Find out whose team is better." /><meta property="og:title" content="Packers Podcast: Cohen and Silverstein fantasy draft the Packers' roster"/><meta property="og:description" class="speakable-description" content="In Wednesday&#39;s podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers&#39; roster. Find out whose team is better."/><meta property="og:url" content="http://www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/"><meta property="og:type" content="article"/><meta name="news_keywords" content="Green Bay Packers, Packers Podcast, Michael Cohen, Bob McGinn, Tom Silverstein, training camp" /><meta property="article:author" content="https://www.facebook.com/jsosports" /><script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "headline": "Packers Podcast: Cohen and Silverstein fantasy draft the Packers' roster",
        "description": "In Wednesday&#39;s podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers&#39; roster. Find out whose team is better.",
        "url": "http://www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "http://www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/"
        },
        "thumbnailUrl": "https://www.gannett-cdn.com/-mm-/f580058649151898501e6af952893fc7e32f5503/c=0-0-500-500&r=x153&c=150x150/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg",
        "image": {
            "@type": "ImageObject",
            "url": "https://www.gannett-cdn.com/-mm-/3fef733aef5db3b32cca5383db7758bed2e7a1d1/c=0-111-500-393&r=x803&c=1600x800/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg",
            "height": 800,
            "width": 1600
        },
        "dateCreated": "2017-08-30T09:30:05.118Z",
        "dateModified": "2017-08-30T09:30:05.118Z",
        "datePublished": "2017-08-30T09:30:05.118Z",
        "articleSection": "sports",
        "publisher": {
            "@type": "Organization",
            "name": "Packers News",
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.gannett-cdn.com/sites/packersnews/images/site-nav-logo@2x.png",
                "height": 80,
                "width": 297
            }
        },
        "author": ["Michael Cohen"],
        "keywords": ["Section:sports:nfl","Type:story","Green Bay Packers","Packers Podcast","Michael Cohen","Bob McGinn","Tom Silverstein","training camp"]
        
    }
    </script><meta name="viewport" content="width=1070" /><link rel="shortcut icon" href="https://www.gannett-cdn.com/sites/packersnews/images/favicon.png"><!--[if gt IE 9]><!--><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/main_modern.min.css"><link data-identifier="sports" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/sports-logos.min.css"><!--<![endif]--><!--[if IE 9]><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/dynamic.min.css"><link data-identifier="sports" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/sports-logos.min.css"><![endif]--><!--[if IE 8]><link data-identifier="main" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/dynamic.min.css"><link data-identifier="sports" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-2776.0/css/bundles/sports-logos.min.css"><![endif]--><link rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/css/print.css" media="print"><!--[if gt IE 8]><!--><style>
        .sponsor-story-theme-bg, .sponsor-story-theme-bg-hover:hover, .site-nav-span.site-nav-sponsor-story-span.site-nav-active-span, .noimage .headline-asset-item-tile.headline-asset-item-sponsor-story-tile, .parent-label.sponsor-story { background-color: rgb(0, 0, 0) !important; } .card-suspender-color.sponsor-story { background: rgb(0, 0, 0) !important; } .headline-asset-item-tile.headline-asset-item-sponsor-story-tile { background-color: rgb(0, 0, 0); background-color: rgba(0,0,0,0.5); } .listview .noimage .headline-asset-item-tile.headline-asset-item-sponsor-story-tile, .listview .headline-asset-item-tile.headline-asset-item-sponsor-story-tile, .listview .hgpm-link.sponsor-story-theme-bg-hover, .listview .hgpm-link.sponsor-story-theme-border-hover:hover { background-color: transparent !important; background-color: rgba(0,0,0,0) !important; } .sponsor-story-theme-color, .hgpm-list-text .sponsor-story-theme-color .theme-bg-ssts-label, .hgpm-list-text .hgpm-section > .sponsor-story-theme-color, .blog-asset-double-wide.sponsor-story-theme-color .presto-h1, .blog-asset-double-wide.sponsor-story-theme-color .presto-h2, .blog-asset-double-wide.sponsor-story-theme-color .presto-h3, .blog-asset-double-wide.sponsor-story-theme-color .presto-h4, .blog-asset-double-wide.sponsor-story-theme-color .presto-h5, .blog-asset-double-wide.sponsor-story-theme-color .presto-h6, .sponsor-story-theme-color > .shbfm-subnav-link:hover, .sponsor-story-theme-color > .shbfm-subnav-link.is-selected, .sponsor-story-theme-color .inline-share-count-blog { color: rgb(0, 0, 0); } .blog-asset-double-wide.sponsor-story-theme-color blockquote { border-color: rgb(0, 0, 0); } .footer > nav > .fronts > section.sponsor-story h6 { border-color: rgb(0, 0, 0) !important; } .hero-list-item .hero-list-anchor { font-size: 12px !important; }


    </style><!--<![endif]--><!--[if lt IE 9]><link rel="stylesheet" href="/services/css/configs.css"><![endif]--><style></style><!--[if lt IE 9]><script src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/js/libs/html5shiv-printshiv.js"></script><script src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/js/libs/respond/respond.min.js"></script><![endif]--><script type="text/javascript">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</script></head><body class=" site-theme-dark-green" ><header data-fixed="false" data-open="true" data-default-fixed="false" data-default-open="true" class=" site-header "><div class="site-header-inner-wrap "><div class="site-masthead"><a class="site-masthead-logo-link logo-link" data-ht="Headerpackersnews Headerlogoexpanded" href="/" ><img class="site-masthead-logo-img" src="https://www.gannett-cdn.com/sites/packersnews/images/site-masthead-logo@2x.png" height="80" alt="Packers News"></a><div class="site-masthead-search-wrap"><form class="site-masthead-search-form ui-ajax-form" action="/search/" method="get" data-mapping="<%= q %>/"><div class="site-masthead-search-input-wrap ui-form-field-container"><input class="site-masthead-search-form-input ui-text-input" data-clearable="true" type="text" name="q" autocomplete="off" placeholder="Search"><div class="site-masthead-search-btn site-masthead-search-btn-div" data-ht="Headersearchbutton"></div></div><input class="site-masthead-search-btn submit" type="submit" value="Search"><span class="site-masthead-search-close-btn" data-uotrack="Headersearchclosebutton"></span><div class="site-masthead-subscribe-wrap site-masthead-subscribe-wrap-visible"><a href="https://subscribe.packersnews.com/?onSuccessRedirectURL=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss&amp;gps-source=CPHPPRIMARY" class="userAuth-redirect site-masthead-subscribe-link" data-ht="Headersubscribecallout" target="_blank"><span class="site-masthead-subscribe-primary-text">SUBSCRIBE NOW</span><span class="site-masthead-subscribe-secondary-text">to get full access</span></a></div><div class="site-masthead-special-offers-ad partner-placement"></div></form></div></div><nav class="site-nav"><ul class="site-nav-list"><li class="site-nav-item site-nav-end-item site-nav-logo-item"><a class="site-nav-link site-nav-logo-link" data-ht="Headerlogocollapsed" href="/"  ><img class="site-nav-logo-img " src="https://www.gannett-cdn.com/sites/packersnews/images/site-nav-logo@2x.png" height="40" alt="Packers News"></a></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-end-item site-nav-first-primary-item site-nav-text-item site-nav-home-item site-nav-module site-nav-home-module" id="module-position-QONj6CF_qwM"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-end-link site-nav-first-primary-link site-nav-text-link site-nav-home-link" href="/" data-ht="Headerhome"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-first-primary-span site-nav-text-span home-theme-bg-hover dark-green-theme-bg-hover site-nav-home-span">Home</span><span class="site-nav-theme-border home-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-text-item site-nav-columns-item site-nav-module site-nav-columns-module" id="module-position-QONj6CFp38Y"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-text-link site-nav-columns-link" href="/columns/" data-ht="Headercolumns"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-text-span columns-theme-bg-hover dark-green-theme-bg-hover site-nav-columns-span"> Columns</span><span class="site-nav-theme-border columns-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-text-item site-nav-chat-item site-nav-module site-nav-chat-module" id="module-position-QONj6CF3khw"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-text-link site-nav-chat-link" href="/chat/" data-ht="Headerchat"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-text-span chat-theme-bg-hover dark-green-theme-bg-hover site-nav-chat-span">Chat</span><span class="site-nav-theme-border chat-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-text-item site-nav-fans-item site-nav-module site-nav-fans-module" id="module-position-QONj6CEzyDw"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-text-link site-nav-fans-link" href="/fans/" data-ht="Headerfans"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-text-span fans-theme-bg-hover dark-green-theme-bg-hover site-nav-fans-span"> Fans</span><span class="site-nav-theme-border fans-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-text-item site-nav-roster-item site-nav-module site-nav-roster-module" id="module-position-QONj6CEZpeA"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-external-text-link site-nav-text-link site-nav-roster-link" href="http://content.packersnews.com/packersnews/roster/roster.php" data-ht="Headerroster" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-text-span roster-theme-bg-hover dark-green-theme-bg-hover site-nav-roster-span">Roster</span><span class="site-nav-theme-border roster-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-text-item site-nav-greenbaypressgazette-item site-nav-module site-nav-greenbaypressgazette-module" id="module-position-QONj6CEGZuU"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-external-text-link site-nav-text-link site-nav-greenbaypressgazette-link" href="http://www.greenbaypressgazette.com" data-ht="Headergreenbaypressgazette" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-text-span greenbaypressgazette-theme-bg-hover dark-green-theme-bg-hover site-nav-greenbaypressgazette-span">GREEN BAY PRESS-GAZETTE</span><span class="site-nav-theme-border greenbaypressgazette-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-text-item site-nav-milwaukeejournalsentinel-item site-nav-module site-nav-milwaukeejournalsentinel-module" id="module-position-QONj6CFLBl8"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-external-text-link site-nav-text-link site-nav-milwaukeejournalsentinel-link" href="http://www.jsonline.com" data-ht="Headermilwaukeejournalsentinel" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-text-span milwaukeejournalsentinel-theme-bg-hover dark-green-theme-bg-hover site-nav-milwaukeejournalsentinel-span">MILWAUKEE JOURNAL SENTINEL</span><span class="site-nav-theme-border milwaukeejournalsentinel-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-end-item site-nav-last-primary-item site-nav-icon-item site-nav-media-item site-nav-module site-nav-media-module" id="module-position-QONj6CFazmw"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-end-link site-nav-last-primary-link site-nav-icon-link site-nav-media-link" href="/media/latest/home/" data-ht="Headermedia"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-last-primary-span site-nav-icon-span media-theme-bg-hover dark-green-theme-bg-hover site-nav-media-span">Media</span><span class="site-nav-theme-border media-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-more-item site-nav-text-item site-nav-module site-nav-text-module" id="module-position-"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-more-link site-nav-text-link" href="" data-ht="Headertext"><div class="site-nav-span-wrap site-nav-more-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-more-span site-nav-text-span">More</span></div></a><div class="site-nav-dropdown site-nav-more-dropdown site-nav-more-dropdown-1col"><div class="site-nav-dropdown-inner-wrap site-nav-more-dropdown-inner-wrap"><ul class="site-nav-more-dropdown-list site-nav-more-dropdown-list-1col"><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/" data-ht="Headermorehome">Home</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/columns/" data-ht="Headermorecolumns"> Columns</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/chat/" data-ht="Headermorechat">Chat</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/fans/" data-ht="Headermorefans"> Fans</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://content.packersnews.com/packersnews/roster/roster.php" data-ht="Headermoreroster">Roster</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://www.greenbaypressgazette.com" data-ht="Headermoregreenbaypressgazette">GREEN BAY PRESS-GAZETTE</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://www.jsonline.com" data-ht="Headermoremilwaukeejournalsentinel">MILWAUKEE JOURNAL SENTINEL</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/media/latest/home/" data-ht="Headermoremedia">Media</a></li></ul></div></div></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-spacer-item site-nav-spacer-item site-nav-module site-nav-spacer-module" id="module-position-"><span class="site-nav-inner-wrap"></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-secondary-item site-nav-end-item site-nav-first-secondary-item site-nav-icon-item site-nav-firefly-item site-nav-module site-nav-firefly-module" id="module-position-QONj6CGfCQo"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-end-link site-nav-first-secondary-link site-nav-external-icon-link site-nav-icon-link site-nav-firefly-link" href="http://account.packersnews.com" data-ht="Headerfirefly" target="_blank"><div class="site-nav-span-wrap site-nav-icon-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-first-secondary-span site-nav-icon-span firefly-theme-bg-hover dark-green-theme-bg-hover site-nav-firefly-span">Firefly</span></div><span class="site-nav-theme-border firefly-theme-bg dark-green-theme-bg" ></span></a><div class="site-nav-dropdown site-nav-firefly-dropdown"><div class="site-nav-firefly-dropdown-section ff-greetings"><p class="site-nav-firefly-dropdown-text ">Hi <span class="site-nav-firefly-user-display-name"></span></p></div><div class="site-nav-firefly-dropdown-section ff-login"><p class="site-nav-firefly-dropdown-text ">Already a subscriber?</p><a class="ui-chunky-btn secondary ff ff-login-btn firefly-signin-btn userAuth-redirect" rel="nofollow" data-ht="HeaderUserAuthLogin" data-user-account="firefly" href="https://login.packersnews.com/PPAN-GUP/authenticate/?success-url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss&cancel-url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss">Log in</a></div><div class="site-nav-firefly-dropdown-section ff-subscribe"><p class="site-nav-firefly-dropdown-text ">Subscribe today for full access on your desktop, tablet, and mobile device.</p><a class="ui-chunky-btn ff subscribe-btn firefly-subscribe-btn userAuth-redirect" href="https://subscribe.packersnews.com/?onSuccessRedirectURL=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss&gps-source=CPHPACCOUNT">Subscribe Now</a></div><div class="site-nav-firefly-dropdown-section ff-activate"><p class="site-nav-firefly-dropdown-text ">Already a print edition subscriber, but don't have a login?</p><a class="ff activate-btn firefly-activate-btn userActivate-redirect" data-user-account="firefly" href="https://subscribe.packersnews.com/account-lookup/&requested-state=create-account">Activate your digital access.</a></div><div class="site-nav-firefly-dropdown-section ff-account"><p class="site-nav-firefly-dropdown-text ">Manage your account settings.</p><a class="ui-chunky-btn ff subscribe-btn firefly-subscribe-btn" data-user-account="firefly" href="https://account.packersnews.com/">My Account</a></div><div class="site-nav-firefly-dropdown-section ff-enewspaper"><p class="site-nav-firefly-dropdown-text "><a class="ff" data-user-account="firefly" href="https://account.packersnews.com/enewspaper/" target="_blank">View the E-Newspaper</a></p></div><div class="site-nav-firefly-dropdown-section ff-newsletters"><p class="site-nav-firefly-dropdown-text "><a class="ff" data-user-account="firefly" href="https://account.packersnews.com/newsletters/" target="_self">Manage your Newsletters</a></p></div><div class="site-nav-firefly-dropdown-section ff-logout"><p class="site-nav-firefly-dropdown-text "><a class="ff-logout-btn userAuth-redirect" data-ht="HeaderUserAuthLogout" href="https://user.packersnews.com/PPAN-GUP/user/logout/?return-url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss">Log Out</a></p></div></div></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-secondary-item site-nav-icon-item site-nav-search-item site-nav-module site-nav-search-module" id="module-position-QONj6CGsBck"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-icon-link site-nav-search-link" href="/search/" data-ht="Headersearch"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-icon-span search-theme-bg-hover dark-green-theme-bg-hover site-nav-search-span">Search</span><span class="site-nav-theme-border search-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-secondary-item site-nav-end-item site-nav-last-secondary-item site-nav-icon-item site-nav-social-item site-nav-module site-nav-social-module" id="module-position-QONj6CGuptE"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-theme-dark-green site-nav-end-link site-nav-last-secondary-link site-nav-external-icon-link site-nav-icon-link site-nav-social-link" href="http://static.packersnews.com/social-media/" data-ht="Headersocial" target="_blank"><div class="site-nav-span-wrap site-nav-icon-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-last-secondary-span site-nav-icon-span social-theme-bg-hover dark-green-theme-bg-hover site-nav-social-span">Social</span></div><span class="site-nav-theme-border social-theme-bg dark-green-theme-bg" ></span></a><div class="site-nav-dropdown site-nav-social-module-dropdown"><div class="social-dropdown-item facebook"><iframe src="//www.facebook.com/plugins/like.php?href=https%3A//www.facebook.com/packersnews&amp;width=450&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=true&amp;send=true&amp;appId=249896938457153" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:135px;" allowTransparency="true"></iframe></div><div class="social-dropdown-item twitter"><div class="twitter-follow"><a class="twitter-follow-label" href="https://twitter.com/intent/user?screen_name=PGpackersnews" target="_blank">Follow</a></div></div></div></span></li></ul></nav><div class="bnm-container"></div></div><script type="json/headermodules" class="headermodules headermodules-primary">{ "js_modules": [{"layoutType": "NAV_MODULES", "position": "QONj6CF_qwM", "oembedtype": null, "name": "link", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CFp38Y", "oembedtype": null, "name": "link", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CF3khw", "oembedtype": null, "name": "link", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CEzyDw", "oembedtype": null, "name": "link", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CEZpeA", "oembedtype": null, "name": "link", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CEGZuU", "oembedtype": null, "name": "link", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CFLBl8", "oembedtype": null, "name": "link", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CFazmw", "oembedtype": null, "name": "link", "options": null}] }</script><script type="json/headermodules" class="headermodules headermodules-secondary">{ "js_modules": [{"layoutType": "NAV_MODULES", "position": "QONj6CGuptE", "oembedtype": null, "name": "site-nav-social-module", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CGsBck", "oembedtype": null, "name": "link", "options": null}, {"layoutType": "NAV_MODULES", "position": "QONj6CGfCQo", "oembedtype": null, "name": "site-nav-firefly-module", "options": null}] }</script></header><div id="overlay"><div class="partner-placement partner-gravity-ad partner-gravity-ad-"><div class="partner-scroll"><div class="partner-scroll-circle"><div class="circle-half left-half"><div class="scroll-circle"></div></div><div class="circle-half right-half"><div class="scroll-circle"></div></div><p class="partner-scroll-number"></p></div><p class="partner-scroll-message">Get the news</p><a class="partner-scroll-login">Log In or Subscribe to skip</a></div><div class="partner-login-overlay"><div class="partner-login-modal"><a class="partner-login-modal-close"></a><div class="partner-login-modal-section ff-login"><p class="partner-login-modal-firefly-text">Already a subscriber?</p><a class="ui-chunky-btn secondary ff ff-login-btn firefly-signin-btn userAuth-redirect" rel="nofollow"
                       data-ht="HeaderUserAuthLogin" data-user-account="firefly" href="https://account.packersnews.com/login/?onSuccessRedirectURL=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss">Log in</a></div><div class="partner-login-modal-section ff-subscribe"><p class="partner-login-modal-firefly-text">Subscribe today for full access on your desktop, tablet, and mobile device.</p><a class="ui-chunky-btn ff subscribe-btn firefly-subscribe-btn userAuth-redirect" href="https://subscribe.packersnews.com/?onSuccessRedirectURL=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss&amp;gps-source=CPHPACCOUNT">Subscribe Now</a></div><div class="partner-login-modal-section ff-activate"><p class="partner-login-modal-firefly-text">Already a subscriber, but don't have a login?</p><a class="ff activate-btn firefly-activate-btn userAuth-redirect"
                     data-user-account="firefly" href="https://subscribe.packersnews.com/account-lookup/?onSuccessRedirectURL=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss&requested-state=create-account">Activate your digital access.</a></div></div><div class="ui-film show"></div></div></div><div class="transition-wrap" ><div class="partner-placement partner-overlay-top-ad"></div><div class="partner-placement partner-sponsor-logo"></div><article class="asset story clearfix" ><div class="close-wrap"><a href="#" class="close close-overlay" data-ht="modalclose"></a></div><div class="utility-bar-wrap"><div class="utility-bar"><div class="util-bar-primary-modules"><div class="util-bar-module util-bar-module-share"><div
                    class="util-bar-btn util-bar-btn-facebook util-bar-btn-share"
                    data-module-name="utility-bar-module-share"
                    data-module-section="share"
                    data-uotrack="UtilityBarFacebookBtn"></div><a
                    class="util-bar-btn util-bar-btn-twitter"
                    data-module-name="share-twitter"
                    data-popup-width="550"
                    data-popup-height="450"
                    data-uotrack="UtilityBarTwitterLink"
                    href="https://twitter.com/intent/tweet?url=http%3A//pck.rs/2wRG8rM&amp;text=Packers%20Podcast%3A%20Cohen%20and%20Silverstein%20fantasy%20draft%20the%20Packers%27%20roster&amp;via=PGpackersnews"
                    target="_blank" data-popup
                    rel="nofollow"></a><a class="util-bar-btn util-bar-btn-linkedin"
                    data-share-method="linkedin"
                    data-popup-width="600"
                    data-popup-height="455"
                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                    href="http://www.linkedin.com/shareArticle?url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/&amp;mini=true"
                    target="_blank" data-popup
                    rel="nofollow"></a><div
                    class="util-bar-btn util-bar-btn-email js-share-email-btn"
                    data-module-name="utility-bar-module-share"
                    data-module-section="email"
                    data-uotrack="UtilityBarEmailBtn"></div><div class="util-bar-flyout util-bar-flyout-share"><div class="util-bar-flyout-pane util-bar-flyout-pane-share scrollable-content"><div class="util-bar-flyout-heading util-bar-flyout-heading-share"><h6 class="util-bar-flyout-title util-bar-flyout-title-share">Share This Story!</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-share">Let friends in your social network know what you are reading about</p></div><div class="util-bar-flyout-nav util-bar-flyout-nav-share"><span class="util-bar-flyout-nav-btn-wrap"><span
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook active"
                                    data-share-method="facebook"
                                    data-uotrack="UtilityBarFlyoutFacebookBtn"
                                >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><span
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-email"
                                        data-share-method="email"
                                        data-uotrack="UtilityBarFlyoutEmailBtn"
                                    >Email</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter"
                                    data-share-method="twitter"
                                    data-popup-width="550"
                                    data-popup-height="450"
                                    data-uotrack="UtilityBarFlyoutTwitterLink"
                                    href="https://twitter.com/intent/tweet?url=http%3A//pck.rs/2wRG8rM&amp;text=Packers%20Podcast%3A%20Cohen%20and%20Silverstein%20fantasy%20draft%20the%20Packers%27%20roster&amp;via=PGpackersnews"
                                    target="_blank" data-popup
                                >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus"
                                    data-share-method="googleplus"
                                    data-popup-width="500"
                                    data-popup-height="500"
                                    data-uotrack="UtilityBarFlyoutGooglePlusLink"
                                    href="//plus.google.com/share?url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/"
                                    target="_blank" data-popup
                                >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin"
                                    data-share-method="linkedin"
                                    data-popup-width="600"
                                    data-popup-height="455"
                                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                                    href="http://www.linkedin.com/shareArticle?url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/&amp;mini=true"
                                    target="_blank" data-popup
                                >LinkedIn</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                        href="//www.pinterest.com/pin/create/button/?url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/&media=https://www.gannett-cdn.com/-mm-/3fef733aef5db3b32cca5383db7758bed2e7a1d1/c=0-111-500-393&r=x803&c=1600x800/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg&description=In Wednesday's podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers' roster. Find out whose team is better."
                                        data-pin-do="buttonPin"
                                        data-pin-config="above"
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-pinterest"
                                        data-share-method="pinterest"
                                        data-popup-width="600"
                                        data-popup-height="455"
                                        data-uotrack="UtilityBarFlyoutPinterestLink"
                                        target="_blank" data-popup
                                        >Pinterest</a></span></div><div class="util-bar-share-summary"><img class="util-bar-share-summary-image" height="60" width="60" data-src="https://www.gannett-cdn.com/-mm-/75c82d22b809678906607dd462a43541ff9ca62f/c=0-0-500-500&r=x63&c=60x60/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg" alt="" /><h4 class="util-bar-share-summary-title">Packers Podcast: Cohen and Silverstein fantasy draft the Packers' roster</h4><p class="util-bar-share-summary-description">In Wednesday's podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers' roster. Find out whose team is better.</p></div><div class="util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
                                    class="util-bar-share-message-facebook"
                                    data-link="http://www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/"
                                    data-image="https://www.gannett-cdn.com/-mm-/3fef733aef5db3b32cca5383db7758bed2e7a1d1/c=0-111-500-393&r=x803&c=1600x800/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg"
                                    data-title="Packers Podcast: Cohen and Silverstein fantasy draft the Packers' roster"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/images/indicators/facebook-loading.gif" alt="Loading&hellip;"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="share-email-container js-share-email-container"><div class="share-email-form-container js-share-email-form-container"><form action="/services/mail/v3/send/" method="post" class="share-email-form js-share-email-form"><input type="hidden" name="email_type" value="share_email" class="share-email-form-input "><input type="hidden" name="share_title" value="Packers Podcast: Cohen and Silverstein fantasy draft the Packers' roster" class="share-email-form-input"><input type="text" name="your_name" class="email-to optional share-email-form-input ui-text-input" placeholder="Your Name"><input type="text" name="from" class="email-to required share-email-form-input ui-text-input "
                       placeholder="Your Email"><input type="text" name="to" class="email-from required share-email-form-input ui-text-input "
                       placeholder="Your Friend's Email"><textarea class="email-message share-email-form-textarea js-share-email-form-textarea ui-textarea " name="message"
                          placeholder="Message (optional)">Packers Podcast: Cohen and Silverstein fantasy draft the Packers' roster &#13;&#13;In Wednesday's podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers' roster. Find out whose team is better.  &#13;&#13;Check out this story on packersnews.com: http://pck.rs/2wRG8rM</textarea><script type='text/javascript'>
                            var RecaptchaOptions = {
                                theme: 'custom',
                                custom_theme_widget: 'util-bar-recaptcha-widget'
                            };
                        </script><div class="email-form-recaptcha-widget-container js-email-form-recaptcha-widget"></div><script type="text/template" id="recaptcha_widget"><div class="recaptcha_widget email-form-recaptcha-widget"><div id="recaptcha_image" class="recaptcha_image"></div><div class="recaptcha_only_if_incorrect_sol">
                                    Incorrect please try again
                                </div><input type="text" id="recaptcha_response_field" name="recaptcha_response_field" placeholder="Enter the words above" class="share-email-form-input  ui-text-input "><noscript>
                                    {# <iframe src="https://api.recaptcha.net/noscript?k=6Lf7fuESAAAAAJ3_KMIDbkQySsEE0vMkLXUkq4eY"
                                        height="300" width="500" frameborder="0"></iframe> #}
                                        <textarea class="required" name="recaptcha_challenge_field" rows="3" cols="40"></textarea><input type="hidden" name="recaptcha_response_field" value="manual_challenge" class=""></noscript></div><div class="recaptcha_option_list"><div class="recaptcha_option" data-option="reload"><span class="recaptcha_option_sprite recaptcha_new"></span> Try Another
                            </div><div class="recaptcha_option recaptcha_only_if_image" data-option="audio"><span class="recaptcha_option_sprite recaptcha_audio"></span> Audio CAPTCHA
                            </div><div class="recaptcha_option recaptcha_only_if_audio" data-option="image"><span class="recaptcha_option_sprite recaptcha_audio"></span> Image CAPTCHA
                            </div><div class="recaptcha_option" data-option="help"><span class="recaptcha_option_sprite recaptcha_help"></span> Help
                            </div></div></script><noscript>
                            {#
                            <iframe src="https://api.recaptcha.net/noscript?k=6Lf7fuESAAAAAJ3_KMIDbkQySsEE0vMkLXUkq4eY"
                                    height="300" width="500" frameborder="0"></iframe>
                            #}
                        </noscript><div class="email-form-buttons share-email-form-buttons"><span class="ui-chunky-btn secondary icon cancel share-email-form-cancel-btn js-share-email-cancel-btn">Cancel</span><span class="ui-chunky-btn icon send share-email-form-send-btn js-share-email-send-btn">Send</span></div></form></div><div class="share-email-success-pane js-share-email-form-success-pane"><h4 class="share-email-success-pane-title">Sent!</h4><p class="share-email-success-pane-description">A link has been sent to your friend's email address.</p></div></div></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="util-bar-flyout-close-ribbon"></div></div></div><div class="util-bar-module util-bar-module-comments"><div
                        class="util-bar-btn util-bar-btn-comments"
                        data-uotrack="UtilityBarCommentsBtn"
                        data-module-name="utility-bar-module-comments"></div><div class="util-bar-flyout util-bar-flyout-comments"><div class="util-bar-flyout-heading util-bar-flyout-heading-comments"><h6 class="util-bar-flyout-title util-bar-flyout-title-comments">Join the Conversation</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-comments">To find out more about Facebook commenting please read the <a href="http://static.packersnews.com/conversation-guidelines/">Conversation Guidelines and FAQs</a></p></div><div class="util-bar-comments-wrap"><div class="util-bar-scroll-wrap util-bar-scroll-wrap-comments  "><div class="facebook-comments-plugin-wrap scrollable-content"><div class="fb-comments" data-href="http://www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/" data-posts="20" data-width="400"></div></div></div></div><div class="util-bar-flyout-close-ribbon"></div></div></div><div class="util-bar-module util-bar-module-firefly"><div
                        class="util-bar-btn util-bar-btn-firefly"
                        data-uotrack="UtilityBarFireflyBtn"
                        data-module-name="utility-bar-module-firefly"></div><div class="util-bar-flyout util-bar-flyout-firefly"><div class="util-bar-flyout-firefly-inner-wrap"><p class="util-bar-flyout-firefly-title" ></p><script type="json/ubfmtitle" class="ubfmtitle">
                                ""
                            </script><div class="util-bar-flyout-firefly-ad hidden"></div><a href="https://subscribe.packersnews.com/?onSuccessRedirectURL=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss&amp;gps-source=CPHPACCKEY" class="ui-chunky-btn util-bar-flyout-firefly-subscribe-btn userAuth-redirect">Subscribe Today</a><!--<p class="util-bar-flyout-firefly-subscribe-meta">Full access starting at $1MM/month</p>--><div class="util-bar-flyout-firefly-auth-wrap"><a href="https://login.packersnews.com/PPAN-GUP/authenticate/?success-url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss&cancel-url=http%3A//www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/%3Ffrom%3Dglobal%26hootPostID%3Dc883d33075d7525372b6c964ef7cdf29%253Fsrc%253Drss" class="util-bar-flyout-firefly-sign-in-link userAuth-redirect" data-track-label="fireflyflyoutlogin">Log In</a><p class="util-bar-flyout-firefly-activate-description">Subscribed, but don't have a login?</p><a href="https://subscribe.packersnews.com/account-lookup/&requested-state=create-account" class="util-bar-flyout-firefly-activate-link userActivate-redirect" data-track-label="fireflyflyoutactivatedigitalsubscription">Activate your digital access.</a></div></div><div class="util-bar-flyout-close-ribbon"></div></div></div></div><div class="util-bar-secondary-modules"><div class="util-bar-module util-bar-module-print"><div
                        class="util-bar-btn util-bar-btn-print"
                        data-uotrack="UtilityBarPrintBtn"
                        data-module-name="utility-bar-module-print"></div></div></div></div></div><section id="module-position-QONngkbPtnc" class="storytopbar-bucket asset-nav-bar-module story-asset-nav-bar-module"></section><section id="module-position-QONngkaS-3M" class="storytopbar-bucket story-headline-module story-story-headline-module"><h1 class="asset-headline speakable-headline" itemprop="headline">Packers Podcast: Cohen and Silverstein fantasy draft the Packers&#39; roster</h1></section><section id="module-position-QONngkaISGY" class="storytopbar-bucket story-byline-module story-story-byline-module"><div class="asset-metabar"><span class="asset-metabar-author asset-metabar-item"><a rel="author" href="http://www.packersnews.com/staff/10051410/michael-cohen/">Michael Cohen</a>, Milwaukee Journal Sentinel</span><span class="asset-metabar-time asset-metabar-item nobyline">
            Published 4:30 a.m. CT Aug. 30, 2017
        </span></div></section><section id="module-position-QONngkayEXo" class="storytopbar-bucket piano-module story-piano-module"></section><section id="module-position-QONngkbnNlY" class="storytopbar-bucket bounce-exchange-module story-bounce-exchange-module"></section><section id="module-position-QONngkbSS3M" class="storytopbar-bucket google-survey-module story-google-survey-module"></section><div class="asset-double-wide double-wide p402_premium" role="main" itemprop="articleBody"><div id="module-position-QONng0A9Vys" class="story-asset story-metadata-asset"><div class="article-metadata-wrap"><section id="module-position-QONngz-nCIA" class="storymetadata-bucket expandable-photo-module story-expandable-photo-module"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="single-photo expandable-collapsed"><div class="image-wrap"><img class="expand-img-horiz" itemprop="url" src="https://www.gannett-cdn.com/-mm-/0c298d040b255b93ba0915633af7a7d551b6db9c/c=0-23-500-399&amp;r=x404&amp;c=534x401/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg" alt="Michael Cohen" data-mycapture-src="http://www.gannett-cdn.com/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg" data-mycapture-sm-src="http://www.gannett-cdn.com/-mm-/c711c85d58e411988f13438d0dec93db9715f141/r=400x400/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg" /><span class="toggle"></span><meta itemprop="name" content="Michael Cohen" /></div><p class="image-credit-wrap"><span class="js-caption-wrapper"><span class="cutline js-caption">PackersNews.com and Journal Sentinel beat writer Michael Cohen</span><meta itemprop="copyrightHolder" content="" /><span class="credit">(Photo: File photo)</span></span></p></aside></section></div></div><div id="module-position-QONng0A9bJs" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-top"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=http%3A//pck.rs/2wRG8rM&amp;text=Packers%20Podcast%3A%20Cohen%20and%20Silverstein%20fantasy%20draft%20the%20Packers%27%20roster&amp;via=PGpackersnews"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=http%3A//pck.rs/2wRG8rM&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments"></span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div><p class='speakable-p-1 p-text'>In Wednesday's podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers' roster. Tune in to find out whose team is better.</p><p class='speakable-p-2 p-text'>Download <a href="https://audioboom.com/posts/6251981-8-30-17-packers-fantasy-draft-by-cohen-and-silverstein.mp3"><strong>the mp3 file here</strong></a>, listen to <strong><a href="https://audioboom.com/posts/6251981-8-30-17-packers-fantasy-draft-by-cohen-and-silverstein">the stream here</a></strong> or below, or subscribe to it <a href="https://itunes.apple.com/us/podcast/packers-podcast-bob-mcginn/id518355845?mt=2"><strong>in the iTunes store</strong></a>, on <a href="http://www.stitcher.com/podcast/milwaukee-journal-sentinel/packers-podcast-with-bob-mcginn-and-tyler-dunne"><strong>Stitcher</strong></a> or via <a href="http://www.jsonline.com/rss/?id=143684556&path=/sports/packers"><strong>the RSS feed</strong></a>.</p><div id="module-position-QONng0Bs-zg" class="story-asset oembed-asset"><div class="story-oembed-wrap "><div 
        class="js-oembed story-oembed story-oembed- story-oembed-type-"
        data-oembed-type=""
        data-oembed-provider=""><style>
.oembed-frame {
 width: 100%;
 height: 100%;
 margin: 0;
 border: 0;
 }
</style><div class="oembed-frame"><iframe width="100%" height="300" style="background-color:transparent; display:block; padding: 0; max-width: 700px;" frameborder="0" allowtransparency="allowtransparency" scrolling="no" src="//embeds.audioboom.com/posts/6251981-8-30-17-packers-fantasy-draft-by-cohen-and-silverstein/embed/v4?eid=AQAAAN4hplnNZV8A" title="audioBoom player"></iframe></div></div></div></div><p class='p-text'>&nbsp;</p></div><aside class="story-right-rail"><section id="module-position-QONngz5X7Fw" class="storyrightrail-bucket poster-ad-asset-module story-poster-ad-asset-module"><div class="partner-placement partner-asset-right-ad"></div></section><section id="module-position-QONngz42x0w" class="storyrightrail-bucket taboola-poster-asset-module story-taboola-poster-asset-module"><div id="taboola-abp-right-rail-thumbnails"></div></section><section id="module-position-QONngz55txA" class="storyrightrail-bucket poster-ad-asset2-module story-poster-ad-asset2-module"><div class="partner-asset-right-ad-2"><div class="poster-scroll"><div class="partner-placement poster-scroll-ad"></div></div></div></section></aside><section id="module-position-QONngz4N0IM" class="storybottombar-bucket taboola-related-module story-taboola-related-module"><div class="more more-stories-wrap"><div class="more-stories-content"><div id="js-taboola-wrapper"><div id="taboola-grid-3x3"></div><div id="taboola-organic-grid-3x3"></div><div id="taboola-short-article-2x5"></div><div id="taboola-organic-short-article-2x5"></div><div id="taboola-grid-sports-3x3"></div><div id="taboola-organic-grid-sports-3x3"></div></div></div></div><div class="clearfix"></div></section><section id="module-position-QONngz4hWcE" class="storybottombar-bucket leaderboard-ad-module story-leaderboard-ad-module"><div class="partner-placement asset-leaderboard-btf-ad leaderboard-ad common-ad-styling"></div></section><!-- comscorekw=sports --><script type="json/pageinfo" class="pageinfo">
{"seokeywords": "Green Bay Packers, Packers Podcast, Michael Cohen, Bob McGinn, Tom Silverstein, training camp", "asset_status": "published", "published_date": "2017-08-30T09:30:05.118Z", "longitude": "", "description": "In Wednesday's podcast, Michael Cohen and Tom Silverstein conduct a fantasy draft of the Green Bay Packers' roster. Find out whose team is better.", "assetid": 615137001, "series": "", "shortheadline": "Podcast: Fantasy drafting the Packers' roster", "topic": "packers-podcast,american-football,sport,green-bay-packers,nfl-draft", "content_protection_state": "metered", "share_text": "", "section_name": "sports", "priority_asset": "none", "speakable_enabled": false, "robots_noindex_follow": false, "share_imgs": {"shareThumb": "https://www.gannett-cdn.com/-mm-/75c82d22b809678906607dd462a43541ff9ca62f/c=0-0-500-500&r=x63&c=60x60/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg", "200x200_1_1": "https://www.gannett-cdn.com/-mm-/67ad47a6cf0a37c6ee875958a57823e663d3e725/c=0-0-500-500&r=x203&c=200x200/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg", "json_logo": "https://www.gannett-cdn.com/sites/packersnews/images/site-nav-logo@2x.png", "150x150_1_1": "https://www.gannett-cdn.com/-mm-/f580058649151898501e6af952893fc7e32f5503/c=0-0-500-500&r=x153&c=150x150/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg", "site_logo": "https://www.gannett-cdn.com/GDContent/applogos/packersnews.png", "shareImage": "https://www.gannett-cdn.com/-mm-/3fef733aef5db3b32cca5383db7758bed2e7a1d1/c=0-111-500-393&r=x803&c=1600x800/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg", "fbShareImage": "https://www.gannett-cdn.com/-mm-/3fef733aef5db3b32cca5383db7758bed2e7a1d1/c=0-111-500-393&r=x803&c=1600x800/local/-/media/2016/09/11/WIGroup/PackersNews/636092021520298042-Michael-Cohen.jpg", "og_height": 800, "og_width": 1600}, "comma_ssts": "sports,nfl,packers", "sponsored_series": false, "canonical": "http://www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/", "basePageType": "story", "texttype": "story", "commentsenabled": "true", "byline": "Michael Cohen", "contenttype": "story pages", "parsleykeywords": ["Green Bay Packers", "Packers Podcast", "Michael Cohen", "Bob McGinn", "Tom Silverstein", "training camp"], "headline": "Packers Podcast: Cohen and Silverstein fantasy draft the Packers' roster", "ssts": "sports/nfl/packers", "sponsorname": "", "sponsor_story": false, "share_url": "http://pck.rs/2wRG8rM", "full_url": "http://www.packersnews.com/story/sports/nfl/packers/2017/08/30/packers-podcast-cohen-and-silverstein-fantasy-draft-packers-roster/615137001/", "web-template": "none", "abtests": [], "noadvertising": false, "blogname": "", "seotitle": "Packers Podcast: Fantasy drafting the Packers' roster", "videoincluded": "no", "cst": "sports/football/nfl", "latitude": "", "js_modules": [{"layoutType": "STORYTOPBAR", "position": "QONngkbPtnc", "oembedtype": null, "name": "asset-nav-bar", "options": null}, {"layoutType": "STORYTOPBAR", "position": "QONngkaS-3M", "oembedtype": null, "name": "story-headline", "options": null}, {"layoutType": "STORYTOPBAR", "position": "QONngkaISGY", "oembedtype": null, "name": "story-byline", "options": null}, {"layoutType": "STORYTOPBAR", "position": "QONngkayEXo", "oembedtype": null, "name": "piano", "options": null}, {"layoutType": "STORYTOPBAR", "position": "QONngkbnNlY", "oembedtype": null, "name": "bounce-exchange", "options": null}, {"layoutType": "STORYTOPBAR", "position": "QONngkbSS3M", "oembedtype": null, "name": "google-survey", "options": null}, {"layoutType": "STORYRIGHTRAIL", "position": "QONngz5X7Fw", "oembedtype": null, "name": "poster-ad-asset", "options": null}, {"layoutType": "STORYRIGHTRAIL", "position": "QONngz42x0w", "oembedtype": null, "name": "taboola-poster-asset", "options": null}, {"layoutType": "STORYRIGHTRAIL", "position": "QONngz55txA", "oembedtype": null, "name": "poster-ad-asset2", "options": null}, {"layoutType": "STORYBOTTOMBAR", "position": "QONngz4N0IM", "oembedtype": null, "name": "taboola-related", "options": null}, {"layoutType": "STORYBOTTOMBAR", "position": "QONngz4hWcE", "oembedtype": null, "name": "leaderboard-ad", "options": null}, {"layoutType": "STORYMETADATA", "position": "QONngz-nCIA", "oembedtype": null, "name": "expandable-photo", "options": null}, {"layoutType": "storyasset", "position": "QONng0A9Vys", "oembedtype": null, "name": "story-metadata", "options": null}, {"layoutType": "storyasset", "position": "QONng0A9bJs", "oembedtype": null, "name": "inline-share-tools", "options": null}, {"layoutType": "storyasset", "position": "QONng0Bs-zg", "oembedtype": null, "name": "oembed", "options": null}], "taxonomykeywords": "Packers Podcast,American football,sport,Green Bay Packers,NFL draft", "excludeTransitionAd": false}
</script></article></div><div class="arrows overlay-arrows"><script type="text/template" id="overlay-arrow-wrap"><% if (disabled) { %><a class="overlay-content-arrows overlay-arrows-<%= dir %>-wrap <%= disabled %>" data-ht="articlearrow<%= dir %>"></a><% }else{ %><a class="overlay-content-arrows overlay-content-arrows-<%= dir %>-wrap <%= disabled %>" href="<%= links %>" data-ht="articlearrow<%= dir %>"><div class="overlay-arrow-<%= dir %> overlay-arrows-anchor"><div class="overlay-arrows-<%= dir %>-anchor-image"></div></div></a><% } %></script></div><div class="partner-overlay"><div class="partner-placement"><a href="#" class="partner-close partner-overlay-close"></a></div><div class="ui-film show"></div></div></div><div id="overlay-film" class="ui-film show"></div><div id="ad-staging"></div><script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/js/libs/peanutbutterjellytime/peanutbutterjellytime.min.js"></script><!--[if lt IE 9]><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/jsb/main_legacy.min.js"></script><![endif]--><!--[if gt IE 8]><!--><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-2776.0/jsb/main.min.js"></script><!--<![endif]--><div id="fb-root"></div><script src="https://www.gannett-cdn.com/appservices/gidgits-js/gidgits.min.js" id="gidgits-script"></script><script type="text/javascript">
        var mainAd = document.createElement('div');
        mainAd.id = 'main_ad';
        mainAd.style.cssText = 'height:1px; width:1px; overflow:auto;position: absolute;left: -999em;';
        document.body.appendChild(mainAd);
        var blockPosition = document.getElementById('main_ad');
        if(blockPosition && blockPosition.offsetHeight == 1) {
            window.adsEnabled = true;
        }
    </script></body></html>
