<!doctype html><!--[if IE 8]><html class="no-js lt-ie10 lt-ie9" lang="en"><![endif]--><!--[if IE 9]><html class="no-js lt-ie10" lang="en"><![endif]--><!--[if gt IE 10]><!--><html class="no-js" lang="en" ><!--<![endif]--><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/js/partner/show_ads.js"></script><title>Green Bay Packers waste no time signing draft pick Darnell Savage</title><meta content="text/html; charset=UTF-8" name="Content-Type" /><script type="text/javascript">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</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","queueTime":0,"licenseKey":"b7ac0e2ada","agent":"","transactionName":"NARUbRdVVhdSBk0MWQ1OcEwLV0wNXAsWFkIME19cFhpODVYSSl9FFw5EQA==","applicationID":"53380547","errorBeacon":"bam.nr-data.net","applicationTime":2201}</script><meta name="google" content="notranslate"><meta name="apple-itunes-app" content="app-id=908833573"><meta name="description" content="The Packers became the first team in the NFL to sign a first-round draft choice Thursday, inking safety Darnell Savage to a four-year deal."><link rel="canonical" href="https://www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/"><link rel="amphtml" href="https://amp.packersnews.com/amp/3656619002" /><meta property="fb:app_id" content="249896938457153"/><meta property="fb:pages" content="6271782579,6566864515,6581478870,7197664863,7850621533,8031989578,9812439851,10482066215,11277320498,13642915529,13652355666,14073085963,16511263815,17540977705,18884137648,19125738813,23332504801,25003338948,31185662683,36808884697,37412800032,41044579289,42128399297,43612894510,46050757230,47020221001,47692649063,48490808881,48958576760,48976713989,49060990988,49607602899,49680588265,49896855793,50095226239,50978409031,52929678682,54660221594,55529405081,56434454301,56732457944,62464848082,62811590881,63475094632,63475094632,63582312713,65299040658,66049156099,66281684861,68903794473,69357466992,70423731350,70657021294,71807382333,72088679443,72139486384,73736978810,74475819815,76240820015,76276576343,77475586904,79333461561,79437403137,80117331717,80335432797,81086717085,81320873283,81668556783,81917682064,82415033847,83300095936,83563566820,87171906471,87448932499,87448932499,88584644204,90329609573,94480694479,94700656192,95712466848,95926318753,97657252278,99020906334,100825602361,101112717264,103261740968,103678546758,104331357951,104935809704,105714200321,105814368912,105878288262,106644919984,107327575587,108555442934,109146355881,109686244216,109793107867,110252103235,110404119877,110527555449,115611960606,115967868757,117907407522,118427210363,121866005065,122786733297,124755637015,125551044242,126226324691,129236178055,132159529312,132779306963,133049345480,134076752154,134394490084,136737914809,138770030135,141962110815,146089950343,148668982786,152774630192,153308622465,158094820767,164935760159,168684165430,173007618420,182922701188,188894693348,189867939238,190632318566,201996980631,227627281180,231239152914,242752084180,250325640686,264717798098,274620738925,275678631915,312966181232,314817944972,319611510288,323213251787,329923389135,338437548341,347221378913,362300531934,363363051861,371547464003,385926141498,427414745045,488720200095,100855786673970,105233922869839,105347532857165,105550656158763,106451856091222,106819879363130,107117249323169,108029922557289,108981615791456,109280192597421,109280192597421,109652569058713,110311752340743,110471702456365,110743725611909,110936258937026,111203872270080,112875149052352,113056925415668,113544088682099,113819202011100,115535341805950,115612465136194,117941352212869,119027288135308,119794264705307,119941731380546,120356424669462,121160355264720,121227371225765,121242251236815,121422567927897,124075397608772,124307640925620,124528254305153,127729820590459,128075747844406,129752560371732,130211193676772,130407246974813,130934216964240,136941796341905,137098406340114,137341919636249,137698179626815,137935586280481,138064052876960,138170199553897,140615052641118,140616965982144,141822679203700,142195472502819,143851392316295,145525478832716,146112055409819,146137498764266,146315142126130,146798045922062,147760805252234,148251148521543,149641051719383,152527031492851,152785861474173,153525871324757,154425934607982,154443518023678,155874144456588,156345381090801,157305941529632,157456661011568,158095147555989,159385590790009,160735830621443,161639923860040,165912253479205,167334979948476,167487199962004,169254356561132,169571899725267,169908223021026,176115302489104,176983469019018,177037772444433,177938742707529,180004588791896,183850168300771,183882195384562,184094471609920,184741935370451,185457134911754,187466604613310,187899791275353,190953458083653,192069610842446,196267627213508,197490563626275,205576782811630,207319989616043,209524799494208,212808112063652,220757414638542,222348701505747,224163964346315,225067797622802,225571757789261,225618707473378,231988790171331,235484153604672,236655713446291,236665340121443,241091022598958,243031846042424,251228454889939,261119230567728,263714980315631,279914708715884,281030418652036,281331052320274,285377081517877,288382484929799,288570077828603,295018040526596,297522096960113,305068052985746,307826419595702,310942265948388,315461641910509,315942225236045,315942225236045,320453738073595,321223331243188,327249521057460,330565860307724,332382433821098,334297859927211,339575256116022,351359635259904,353404615129492,368424599844024,373087836097009,399493863726488,401783903349050,405292372992577,410195352524708,412113499123835,420941268096348,421255071314156,422375144525783,426754640812333,438452439879553,458808827485318,469694573429026,471891632935599,477690595750196,480464022311783,487732368292520,510151039081225,535045576657973,535551216797440,556150611109468,562348203875693,566432520196581,569900189687627,581529871999163,592673674105043,593739520831583,611437275717153,637561026326153,642020402627050,677476185677499,686958778091339,704313986314492,717947288315597,756473301219510,757336147711096,813218208713830,850378298431411,872296879526971,877111212410602,911836215623184,917342785050040,927427260614748,945986872102221,1561238324154800,1822461518079800,1889753241275160,1003311406396687,1007667299356254,1095671673874517,1111939365618797,1170250869768985,1199725526840512,1203830176364044,1224613924286312,1244424538911767,1260369167415906,1282648301845288,1413320388972813,1422299337837954,1425793144356745,1432665186743737,1443524575938047,1473996709497771,1504884589584087,1525148737812812,1526198127405784,1583851541911383,1588113081458198,1596218533974035,1602646926431957,1603698749645413,1621466394844549,1627621717510471,1667234726635829,1725861847686522,1747180218844657,1759005871036426,1774393409526131,1797367867256626,1847787168808886,1878073225844519,1946209538938897,1972936962947967,2047091012096533" ><meta property="og:site_name" content="Packers News" /><meta name="ROBOTS" content="NOODP, NOYDIR" /><meta property="og:image" content="https://www.gannett-cdn.com/presto/2019/04/26/PPAN/f834a202-f257-4528-875d-d784b0c16e99-USATSI_11252469.jpg?crop=5567,3131,x0,y0&width=3200&height=1680&fit=bounds"/><meta property="og:image:width" content="3200"/><meta property="og:image:height" content="1680"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://www.gannett-cdn.com/presto/2019/04/26/PPAN/f834a202-f257-4528-875d-d784b0c16e99-USATSI_11252469.jpg?crop=5567,3131,x0,y0&width=1600&height=800&fit=bounds"/><meta name="twitter:site" content="@PGpackersnews" /><meta name="twitter:creator" content="@PGpackersnews" /><meta name="twitter:title" content="Packers waste no time getting first-round safety Darnell Savage on board" /><meta name="twitter:description" content="The Packers became the first team in the NFL to sign a first-round draft choice Thursday, inking safety Darnell Savage to a four-year deal." /><meta property="og:title" content="Packers waste no time getting first-round safety Darnell Savage on board"/><meta property="og:description" class="speakable-description" content="The Packers became the first team in the NFL to sign a first-round draft choice Thursday, inking safety Darnell Savage to a four-year deal."/><meta property="og:url" content="https://www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/"><meta property="og:type" content="article"/><meta property="article:author" content="https://www.facebook.com/jsosports" /><script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "headline": "Packers waste no time getting first-round safety Darnell Savage on board",
        "description": "The Packers became the first team in the NFL to sign a first-round draft choice Thursday, inking safety Darnell Savage to a four-year deal.",
        "url": "https://www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/?utm_source=google&utm_medium=amp&utm_campaign=speakable",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/"
        },
        "thumbnailUrl": "https://www.gannett-cdn.com/presto/2019/04/26/PPAN/f834a202-f257-4528-875d-d784b0c16e99-USATSI_11252469.jpg?crop=3712,3712,x1407,y0&width=150&height=150&fit=bounds",
        "image": {
            "@type": "ImageObject",
            "url": "https://www.gannett-cdn.com/presto/2019/04/26/PPAN/f834a202-f257-4528-875d-d784b0c16e99-USATSI_11252469.jpg?crop=5567,3131,x0,y0&width=1600&height=800&fit=bounds",
            "height": 800,
            "width": 1600
        },
        "dateCreated": "2019-05-02T23:17:24.613Z",
        "dateModified": "2019-05-02T23:17:24.613Z",
        "datePublished": "2019-05-02T23:17:24.613Z",
        "articleSection": "sports",
        "publisher": {
            "@type": "Organization",
            "name": "Packers News",
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.gannett-cdn.com/sites/packersnews/images/site-nav-logo@2x.png",
                "height": 80,
                "width": 297
            }
        },
        "author": ["Tom Silverstein"],
        "keywords": ["Section:sports:nfl","Type:story"]
        
    }
    </script><meta name="viewport" content="width=1070" /><link rel="shortcut icon" href="https://www.gannett-cdn.com/sites/packersnews/images/favicon.png"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_Rg.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_Bd.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_SBd.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/gannettIcons/gannett-icons.woff" as="font" type="font/woff" crossorigin="anonymous"><!--[if gt IE 9]><!--><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/main_modern.min.css"><link data-identifier="sports" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/sports-logos.min.css"><!--<![endif]--><!--[if IE 9]><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/dynamic.min.css"><link data-identifier="sports" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/sports-logos.min.css"><![endif]--><!--[if IE 8]><link data-identifier="main" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/dynamic.min.css"><link data-identifier="sports" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/sports.min.css"><link data-identifier="sports-logos" rel="stylesheet" href="/uxstatic/packersnews/uscp-web-static-4509.26.0/css/bundles/sports-logos.min.css"><![endif]--><link rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/css/print.css" media="print"><!--[if gt IE 8]><!--><style>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</style><!--<![endif]--><!--[if lt IE 9]><link rel="stylesheet" href="/services/css/configs.css"><![endif]--><style></style><!--[if lt IE 9]><script src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/js/libs/html5shiv-printshiv.js"></script><script src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/js/libs/respond/respond.min.js"></script><![endif]--><script type="text/javascript">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</script></head><body class=" site-theme-dark-green body-dr-styling" ><header data-fixed="false" data-open="true" data-default-fixed="false" data-default-open="true" class=" site-header header-light "><div class="site-header-inner-wrap "><div class="partner-nanobar"><div class="partner-placement partner-nanobar-ad" data-ad-placement="consumer_sales-nano_bar" data-ad-sizes="[[1025,80], 'fluid']"></div></div><div class="site-masthead"><a class="site-masthead-logo-link logo-link" data-ht="Headerpackersnews Headerlogoexpanded" href="/" ><img class="site-masthead-logo-img" src="https://www.gannett-cdn.com/sites/packersnews/images/site-masthead-logo-dark@2x.png" height="80" alt="Packers News"></a><div class="site-masthead-search-wrap"><form class="site-masthead-search-form ui-ajax-form" action="/search/" method="get" data-mapping="<%= q %>/"><div class="site-masthead-subscribe-wrap site-masthead-subscribe-wrap-visible"><a href="https://offers.packersnews.com/digitaloffers?gps-source=CPHPPRIMARY&amp;utm_medium=ONSITE&amp;utm_content=CPHPPRIMARY&amp;utm_source=CPHPPRIMARY" class="userAuth-redirect site-masthead-subscribe-link" data-ht="Headersubscribecallout" target="_blank"><span class="site-masthead-subscribe-primary-text">SUBSCRIBE NOW</span><span class="site-masthead-subscribe-secondary-text">for full access</span></a></div><div class="site-masthead-special-offers-ad partner-placement" data-ad-placement="consumer_sales-masthead" data-ad-sizes="[[122,50]]"></div></form></div></div><nav class="site-nav"><ul class="site-nav-list site-nav-list-packersnews more-link-variant"><li class="site-nav-item site-nav-end-item site-nav-logo-item"><a class="site-nav-link site-nav-logo-link" data-ht="Headerlogocollapsed" href="/"  ><img class="site-nav-logo-img " src="https://www.gannett-cdn.com/sites/packersnews/images/site-nav-logo-dark@2x.png" height="40" alt="Packers News"></a></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-end-item site-nav-first-primary-item site-nav-text-item site-nav-home-item site-nav-module site-nav-home-module" id="module-position-Rwd3iS_4Nn0"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-end-link site-nav-first-primary-link site-nav-text-link site-nav-home-link" href="/" data-ht="Headerhome"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-first-primary-span site-nav-text-span site-nav-home-span">Home</span><span class="site-nav-theme-border home-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-text-item site-nav-fans-item site-nav-module site-nav-fans-module" id="module-position-Rwd3iS-Ksw0"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-text-link site-nav-fans-link" href="/fans/" data-ht="Headerfans"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-text-span site-nav-fans-span"> Fans</span><span class="site-nav-theme-border fans-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-icon-item site-nav-media-item site-nav-module site-nav-media-module" id="module-position-Rwd3iS_7QbU"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-icon-link site-nav-media-link" href="/media/latest/home/" data-ht="Headermedia"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-icon-span site-nav-media-span">Media</span><span class="site-nav-theme-border media-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-text-item site-nav-greenbaypressgazette-item site-nav-module site-nav-greenbaypressgazette-module" id="module-position-Rwd3iS_Fo-8"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-external-text-link site-nav-text-link site-nav-greenbaypressgazette-link" href="http://www.greenbaypressgazette.com" data-ht="Headergreenbaypressgazette" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-text-span site-nav-greenbaypressgazette-span">GREEN BAY PRESS-GAZETTE</span><span class="site-nav-theme-border greenbaypressgazette-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-end-item site-nav-last-primary-item site-nav-text-item site-nav-milwaukeejournalsentinel-item site-nav-module site-nav-milwaukeejournalsentinel-module" id="module-position-Rwd3iS_u8Jg"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-end-link site-nav-last-primary-link site-nav-external-text-link site-nav-text-link site-nav-milwaukeejournalsentinel-link" href="http://www.jsonline.com" data-ht="Headermilwaukeejournalsentinel" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-last-primary-span site-nav-text-span site-nav-milwaukeejournalsentinel-span">MILWAUKEE JOURNAL SENTINEL</span><span class="site-nav-theme-border milwaukeejournalsentinel-theme-bg dark-green-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-more-item site-nav-text-item site-nav-module site-nav-text-module" id="module-position-"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-more-link site-nav-text-link" href="" data-ht="Headertext"><div class="site-nav-span-wrap site-nav-more-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-more-span site-nav-text-span">More<span class="site-nav-more-arrow"></span></span></div></a><div class="site-nav-dropdown site-nav-more-dropdown site-nav-more-dropdown-1col"><div class="site-nav-dropdown-inner-wrap site-nav-more-dropdown-inner-wrap"><ul class="site-nav-more-dropdown-list site-nav-more-dropdown-list-1col"><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/" data-ht="Headermorehome">Home</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/fans/" data-ht="Headermorefans"> Fans</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/media/latest/home/" data-ht="Headermoremedia">Media</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://www.greenbaypressgazette.com" data-ht="Headermoregreenbaypressgazette">GREEN BAY PRESS-GAZETTE</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://www.jsonline.com" data-ht="Headermoremilwaukeejournalsentinel">MILWAUKEE JOURNAL SENTINEL</a></li></ul></div></div></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-midway-item site-nav-end-item site-nav-first-midway-item site-nav-end-item site-nav-last-midway-item site-nav-icon-item site-nav-search-item site-nav-module site-nav-search-module" id="module-position-Rwd3iS8abL4"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-end-link site-nav-first-midway-link site-nav-end-link site-nav-last-midway-link site-nav-icon-link site-nav-search-link" href="" data-ht="Headersearch"><div class="site-nav-span-wrap site-nav-icon-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-first-midway-span site-nav-end-span site-nav-last-midway-span site-nav-icon-span site-nav-search-span">Search</span></div><span class="site-nav-theme-border search-theme-bg dark-green-theme-bg" ></span></a><div class="site-nav-dropdown site-nav-search-dropdown"><div class="site-nav-dropdown-inner-wrap site-nav-search-dropdown-inner-wrap"><form class="site-masthead-search-form ui-ajax-form" action="/search/" method="get" data-mapping="<%= q %>/"><input class="site-masthead-search-form-input" data-clearable="true" type="text" name="q" autocomplete="off" placeholder="Search"><button class="site-masthead-search-form-submit" type="submit" value=""></button></form></div></div></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-primary-item site-nav-spacer-item site-nav-spacer-item site-nav-module site-nav-spacer-module" id="module-position-"><span class="site-nav-inner-wrap"></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-secondary-item site-nav-end-item site-nav-first-secondary-item site-nav-subscribe-alt-item site-nav-subscribe-alt-item site-nav-module site-nav-subscribe-alt-module" id="module-position-Rwd3iS-0Zs0"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-end-link site-nav-first-secondary-link site-nav-external-subscribe-alt-link site-nav-subscribe-alt-link site-nav-subscribe-alt-link" href="https://offers.packersnews.com/specialoffer?gps-source=CPNAVBARBBB" data-ht="Headersubscribe-alt" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-first-secondary-span site-nav-subscribe-alt-span site-nav-subscribe-alt-span">Subscribe</span><span class="site-nav-subscribe-alt-bg subscribe-alt-bg-packersnews"></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-green site-nav-secondary-item site-nav-end-item site-nav-last-secondary-item site-nav-salutation-item site-nav-salutation-item site-nav-module site-nav-salutation-module" id="module-position-Rwd3iS_YjC8"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-packersnews site-nav-link-theme-dark-green site-nav-end-link site-nav-last-secondary-link site-nav-salutation-link site-nav-salutation-link" href="" data-ht="Headersalutation"><div class="site-nav-span-wrap site-nav-salutation-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-green site-nav-end-span site-nav-last-secondary-span site-nav-salutation-span site-nav-salutation-span">salutation</span></div><span class="salutation-nav-arrow"></span></a><div class="site-nav-dropdown snsm-dropdown"><div class="snsm-wrap snsm-wrap-packersnews"><ul class="snsm-links"><li><a class="snsm-link snsm-link-view-account" href="https://account.packersnews.com/"><span class="snsm-link-text">View Your Account</span></a></li><li data-hoverDropdown="e-edition print"><a class="snsm-link snsm-link-eedition" href="https://user.packersnews.com/user/enewspaper"><span class="snsm-link-text">Today's e-Edition</span></a></li><li data-hoverDropdown="!print"><a class="snsm-link snsm-link-newsletters" href="//profile.packersnews.com/newsletters/manage"><span class="snsm-link-text">Newsletters</span></a></li><li data-hoverDropdown="print"><a class="snsm-link snsm-link-pay-bill" href="https://account.packersnews.com/pay"><span class="snsm-link-text">Pay Your Bill</span></a></li><li data-hoverDropdown="print"><a class="snsm-link snsm-link-delivery-issues" href="https://account.packersnews.com/delivery-issue"><span class="snsm-link-text">Report Delivery Issues</span></a></li><li data-hoverDropdown="print"><a class="snsm-link snsm-link-stop-restart" href="https://account.packersnews.com/delivery-temporary-stop"><span class="snsm-link-text">Temporary Stop/Restart</span></a></li><li><a class="snsm-link snsm-link-help" href="//help.packersnews.com"><span class="snsm-link-text">Help and Support</span></a></li><li><a class="snsm-link snsm-link-sign-out hidden" href="https://user.packersnews.com/PPAN-GUP/user/logout/?return-url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/"><span class="snsm-link-text">Sign Out</span></a></li></ul><div class="snsm-sign-in"><div class="snsm-section"><p class="snsm-text">Have an existing account?</p><a class="snsm-btn snsm-link-sign-in" rel="nofollow" data-ht="HeaderUserAuthLogin" data-user-account="firefly" href="https://login.packersnews.com/PPAN-GUP/authenticate/?success-url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&cancel-url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/"><span class="snsm-btn-text">Sign In</span></a></div><div class="snsm-section"><p class="snsm-text">Already have a subscription?</p><a class="snsm-btn snsm-link-activate" href="https://cm.packersnews.com/account-activation/">Activate Your Account</a></div><div class="snsm-section"><p class="snsm-text snsm-text-register">Don't have an account?</p><a class="snsm-register" href="https://login.packersnews.com/authenticate?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux"><span class="snsm-register-text">Create One</span></a></div></div></div></div></span></li></ul></nav><div class="bnm-container"></div></div><script type="json/headermodules" class="headermodules headermodules-primary">{ "js_modules": [{"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "Rwd3iS_4Nn0", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "Rwd3iS-Ksw0", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "Rwd3iS_7QbU", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "Rwd3iS_Fo-8", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "Rwd3iS_u8Jg", "options": null, "oembedprovider": null}] }</script><script type="json/headermodules" class="headermodules headermodules-post-primary">{ "js_modules": [{"name": "site-nav-search-module", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "Rwd3iS8abL4", "options": null, "oembedprovider": null}] }</script><script type="json/headermodules" class="headermodules headermodules-secondary">{ "js_modules": [{"name": "site-nav-salutation-module", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "Rwd3iS_YjC8", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "Rwd3iS-0Zs0", "options": null, "oembedprovider": null}] }</script></header><div id="overlay"><div class="partner-placement partner-gravity-ad partner-gravity-ad-"><div class="gravity-viewable" id="gravity-viewable"></div><div class="partner-scroll"><div class="partner-scroll-circle"></div><p class="partner-scroll-message">Get the news</p></div></div><div class="transition-wrap" ><div class="partner-placement partner-overlay-top-ad partner-has-min-height" style="min-height:250px" data-ad-placement="high_impact" data-ad-sizes="[[970,250],[728,90]]"></div><div class="partner-placement partner-sponsor-logo" data-ad-placement="sponsor_logo" data-ad-sizes="[[800, 40]]"></div><article class="asset story clearfix" ><div class="close-wrap"><a href="#" class="close close-overlay" data-ht="modalclose"></a></div><div class="utility-bar-wrap"><div class="utility-bar"><div class="util-bar-primary-modules"><div class="util-bar-module util-bar-module-share"><div
                    class="util-bar-btn util-bar-btn-facebook util-bar-btn-share"
                    data-module-name="utility-bar-module-share"
                    data-module-section="share"
                    data-uotrack="UtilityBarFacebookBtn"></div><a
                    class="util-bar-btn util-bar-btn-twitter"
                    data-module-name="share-twitter"
                    data-popup-width="550"
                    data-popup-height="450"
                    data-uotrack="UtilityBarTwitterLink"
                    href="https://twitter.com/intent/tweet?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&amp;text=Packers%20waste%20no%20time%20getting%20first-round%20safety%20Darnell%20Savage%20on%20board&amp;via=PGpackersnews"
                    target="_blank" data-popup
                    rel="nofollow"></a><a class="util-bar-btn util-bar-btn-linkedin"
                    data-share-method="linkedin"
                    data-popup-width="600"
                    data-popup-height="455"
                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                    href="http://www.linkedin.com/shareArticle?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&amp;mini=true"
                    target="_blank" data-popup
                    rel="nofollow"></a><div
                    class="util-bar-btn util-bar-btn-email js-share-email-btn"
                    data-module-name="utility-bar-module-share"
                    data-module-section="email"
                    data-uotrack="UtilityBarEmailBtn"></div><div class="util-bar-flyout util-bar-flyout-share"><div class="util-bar-flyout-pane util-bar-flyout-pane-share scrollable-content"><div class="util-bar-flyout-heading util-bar-flyout-heading-share"><h6 class="util-bar-flyout-title util-bar-flyout-title-share">Share This Story!</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-share">Let friends in your social network know what you are reading about</p></div><div class="util-bar-flyout-nav util-bar-flyout-nav-share"><span class="util-bar-flyout-nav-btn-wrap"><span
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook active"
                                    data-share-method="facebook"
                                    data-uotrack="UtilityBarFlyoutFacebookBtn"
                                >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><span
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-email"
                                        data-share-method="email"
                                        data-uotrack="UtilityBarFlyoutEmailBtn"
                                    >Email</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter"
                                    data-share-method="twitter"
                                    data-popup-width="550"
                                    data-popup-height="450"
                                    data-uotrack="UtilityBarFlyoutTwitterLink"
                                    href="https://twitter.com/intent/tweet?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&amp;text=Packers%20waste%20no%20time%20getting%20first-round%20safety%20Darnell%20Savage%20on%20board&amp;via=PGpackersnews"
                                    target="_blank" data-popup
                                >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus"
                                    data-share-method="googleplus"
                                    data-popup-width="500"
                                    data-popup-height="500"
                                    data-uotrack="UtilityBarFlyoutGooglePlusLink"
                                    href="//plus.google.com/share?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/"
                                    target="_blank" data-popup
                                >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin"
                                    data-share-method="linkedin"
                                    data-popup-width="600"
                                    data-popup-height="455"
                                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                                    href="http://www.linkedin.com/shareArticle?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&amp;mini=true"
                                    target="_blank" data-popup
                                >LinkedIn</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                        href="//www.pinterest.com/pin/create/button/?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&media=https://www.gannett-cdn.com/presto/2019/04/26/PPAN/f834a202-f257-4528-875d-d784b0c16e99-USATSI_11252469.jpg?crop=5567,3131,x0,y0&width=3200&height=1680&fit=bounds&description=The Packers became the first team in the NFL to sign a first-round draft choice Thursday, inking safety Darnell Savage to a four-year deal."
                                        data-pin-do="buttonPin"
                                        data-pin-config="above"
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-pinterest"
                                        data-share-method="pinterest"
                                        data-popup-width="600"
                                        data-popup-height="455"
                                        data-uotrack="UtilityBarFlyoutPinterestLink"
                                        target="_blank" data-popup
                                        >Pinterest</a></span></div><div class="util-bar-share-summary"><img class="util-bar-share-summary-image" height="60" width="60" data-src="https://www.gannett-cdn.com/presto/2019/04/26/PPAN/f834a202-f257-4528-875d-d784b0c16e99-USATSI_11252469.jpg?crop=3712,3712,x1407,y0&width=60&height=60&fit=bounds" alt="" /><h4 class="util-bar-share-summary-title">Packers waste no time getting first-round safety Darnell Savage on board</h4><p class="util-bar-share-summary-description">The Packers became the first team in the NFL to sign a first-round draft choice Thursday, inking safety Darnell Savage to a four-year deal.</p></div><div class="util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
                                    class="util-bar-share-message-facebook"
                                    data-link="https://www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/"
                                    data-image="https://www.gannett-cdn.com/presto/2019/04/26/PPAN/f834a202-f257-4528-875d-d784b0c16e99-USATSI_11252469.jpg?crop=5567,3131,x0,y0&width=3200&height=1680&fit=bounds"
                                    data-title="Packers waste no time getting first-round safety Darnell Savage on board"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/images/indicators/facebook-loading.gif" alt="Loading&hellip;"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="share-email-container js-share-email-container"><div class="share-email-form-container js-share-email-form-container"><form action="/services/mail/v4/send/" method="post" class="share-email-form js-share-email-form"><input type="hidden" name="email_type" value="share_email" class="share-email-form-input "><input type="hidden" name="share_title" value="Packers waste no time getting first-round safety Darnell Savage on board" class="share-email-form-input"><input type="text" name="your_name" class="email-to optional share-email-form-input ui-text-input" placeholder="Your Name"><input type="text" name="from" class="email-to required share-email-form-input ui-text-input "
                       placeholder="Your Email"><input type="text" name="to" class="email-from required share-email-form-input ui-text-input "
                       placeholder="Your Friend's Email"><textarea class="email-message share-email-form-textarea js-share-email-form-textarea ui-textarea " name="message"
                          placeholder="Message (optional)">Packers waste no time getting first-round safety Darnell Savage on board &#13;&#13;The Packers became the first team in the NFL to sign a first-round draft choice Thursday, inking safety Darnell Savage to a four-year deal.  &#13;&#13;Check out this story on packersnews.com: https://www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/</textarea><script src="https://www.google.com/recaptcha/api.js" async defer></script><div id="recaptcha-share" data-key="6LcAqiIUAAAAAJfFpgRBPCU3IjPQm6roffmp1zCE"></div><div class="email-form-buttons share-email-form-buttons"><span class="ui-chunky-btn secondary icon cancel share-email-form-cancel-btn js-share-email-cancel-btn">Cancel</span><span class="ui-chunky-btn icon send share-email-form-send-btn js-share-email-send-btn">Send</span></div></form></div><div class="share-email-success-pane js-share-email-form-success-pane"><h4 class="share-email-success-pane-title">Sent!</h4><p class="share-email-success-pane-description">A link has been sent to your friend's email address.</p></div></div></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="util-bar-flyout-close-ribbon"></div></div></div><div class="util-bar-module util-bar-module-comments"><div
                        class="util-bar-btn util-bar-btn-comments"
                        data-uotrack="UtilityBarCommentsBtn"
                        data-module-name="utility-bar-module-comments"></div><div class="util-bar-flyout util-bar-flyout-comments"><div class="util-bar-flyout-heading util-bar-flyout-heading-comments hidden"><h6 class="util-bar-flyout-title util-bar-flyout-title-comments">Join the Conversation</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-comments">To find out more about Facebook commenting please read the <a href="http://static.packersnews.com/conversation-guidelines/">Conversation Guidelines and FAQs</a></p></div><div class="util-bar-comments-wrap"><div class="util-bar-scroll-wrap util-bar-scroll-wrap-comments"><div class="facebook-comments-plugin-wrap scrollable-content hidden"><div class="fb-comments" data-href="https://www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/" data-posts="20" data-width="400"></div></div><div class="coral-talk-comments-plugin-wrap scrollable-content hidden"><div class="coral-talk-header"><h2 class="coral-talk-title">Comments</h2><p>
                                            This conversation is moderated according to USA TODAY's
                                            <a class="coral-talk-header-link" href="//cm.packersnews.com/community" data-track-label="exit|commentscommunityrules">community rules</a>.
                                            Please read the rules before joining the discussion.
                                        </p></div><div class="coral-talk-embed-wrap"></div><iframe class="gup-embed hidden"></iframe></div></div></div><div class="util-bar-flyout-close-ribbon"></div></div></div></div><div class="util-bar-secondary-modules"><div class="util-bar-module util-bar-module-print"><div
                        class="util-bar-btn util-bar-btn-print"
                        data-uotrack="UtilityBarPrintBtn"
                        data-module-name="utility-bar-module-print"></div></div></div></div></div><section id="module-position-Rwd7ApjSXkM" class="storytopbar-bucket asset-nav-bar-module story-asset-nav-bar-module"></section><section id="module-position-Rwd7ApjWPfY" class="storytopbar-bucket story-headline-module story-story-headline-module"><h1 class="asset-headline speakable-headline" itemprop="headline">Packers waste no time getting first-round safety Darnell Savage on board</h1></section><section id="module-position-Rwd7ApiaMP0" class="storytopbar-bucket priority-asset-module story-priority-asset-module"></section><section id="module-position-Rwd7ApjF9WI" class="storytopbar-bucket story-byline-module story-story-byline-module"><div class="asset-metabar"><span class="asset-metabar-author asset-metabar-item" data-track-label="article|sports:nfl:packers|authorbyline"><a rel="author" href="http://www.packersnews.com/staff/10051412/tom-silverstein/">Tom Silverstein</a>, Packers News</span><span class="asset-metabar-time asset-metabar-item nobyline">
            Published 6:17 p.m. CT May 2, 2019
        </span></div></section><section id="module-position-Rwd7ApivEcA" class="storytopbar-bucket piano-module story-piano-module"></section><section id="module-position-Rwd7ApizPe4" class="storytopbar-bucket bounce-exchange-module story-bounce-exchange-module"></section><section id="module-position-Rwd7Apip57I" class="storytopbar-bucket google-survey-module story-google-survey-module"></section><div class="asset-double-wide double-wide p402_premium" role="main" itemprop="articleBody"><div id="module-position-Rwd7Av3xTWQ" class="story-asset gallery-asset"><div class="card-film inactive"></div><div class="sidebar-gallery-btn active"></div><div class="companion-story-gallery js-llc" data-name="compStoryGallery"><div class="gallery-sidebar-panel has-leaderboard"><span class="gallery-sidebar-close"></span><div class="gallery-sidebar-toolbox share-pane social-pane selected"><span class="util-bar-flyout-nav-btn-wrap"><span
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook gallery-util-bar-flyout-nav-btn"
            href="#"
            target="_blank"
            data-share-link="https://www.jsonline.com/picture-gallery/sports/nfl/packers/2019/04/29/here-all-eight-green-bay-packers-2019-draft-picks-action/3617077002/"
            data-share-title=""
            data-share-method="facebook"
            data-uotrack="UtilityBarFlyoutFacebookBtn"
        >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter gallery-util-bar-flyout-nav-btn"
            data-share-method="twitter"
            data-popup-width="550"
            data-popup-height="450"
            data-uotrack="UtilityBarFlyoutTwitterLink"
            href="https://twitter.com/intent/tweet?url=https://www.jsonline.com/picture-gallery/sports/nfl/packers/2019/04/29/here-all-eight-green-bay-packers-2019-draft-picks-action/3617077002/&amp;text=Packers%20waste%20no%20time%20getting%20first-round%20safety%20Darnell%20Savage%20on%20board&amp;via=PGpackersnews"
            target="_popup"
        >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus gallery-util-bar-flyout-nav-btn"
            data-share-method="googleplus"
            data-popup-width="500"
            data-popup-height="500"
            data-uotrack="UtilityBarFlyoutGooglePlusLink"
            href="//plus.google.com/share?url=https://www.jsonline.com/picture-gallery/sports/nfl/packers/2019/04/29/here-all-eight-green-bay-packers-2019-draft-picks-action/3617077002/"
            target="_popup"
        >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin gallery-util-bar-flyout-nav-btn"
            data-share-method="linkedin"
            data-popup-width="1000"
            data-popup-height="455"
            data-uotrack="UtilityBarFlyoutLinkedInLink"
            href="http://www.linkedin.com/shareArticle?url=https://www.jsonline.com/picture-gallery/sports/nfl/packers/2019/04/29/here-all-eight-green-bay-packers-2019-draft-picks-action/3617077002/&mini=true"
            target="_popup"
        >LinkedIn</a></span></div><div class="title gallery-sidebar-title selected">Here are all eight Green Bay Packers 2019 draft picks in action</div><div class="gallery-sidebar-fullscreen"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen">&nbsp;</span>Fullscreen</a></div><div class="caption"></div><div class="gallery-sidebar-flyout-section util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
            class="util-bar-share-message-facebook"
            data-link="https://www.jsonline.com/picture-gallery/sports/nfl/packers/2019/04/29/here-all-eight-green-bay-packers-2019-draft-picks-action/3617077002/"
            data-title="Packers waste no time getting first-round safety Darnell Savage on board"
            placeholder="Message (optional)"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/images/indicators/facebook-loading.gif"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="companion-galleries-partner-slot"></div></div><div class="companion-galleries embedded_story hasendslate galleries"
        data-gallery-id="3617077002"
        data-title="Here are all eight Green Bay Packers 2019 draft picks in action"
        data-seo-title=""
        data-ssts="sports/nfl/packers"
        data-cst="sports/football/nfl_packers"
        data-published-date="2019-04-29T18:14:24.206Z"
        
        
         data-gal-pageurl="https://www.jsonline.com/picture-gallery/sports/nfl/packers/2019/04/29/here-all-eight-green-bay-packers-2019-draft-picks-action/3617077002/"><div class="viewport gallery-viewport"><div class="slide gallery-viewport-slide horizontal active"  itemprop="primaryImageOfPage"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal gallery-photo-first" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Kirthmon F. Dozier, Detroit Free Press-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/235a02f3-e6f6-4215-bdc1-e414fc2b8104-USATSI_11300242_1.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/235a02f3-e6f6-4215-bdc1-e414fc2b8104-USATSI_11300242_1.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Michigan defenders Rashan Gary, left, and Josh Metellus tackle Nebraska running back Greg Bell during the first half at Michigan Stadium on Sept. 22, 2018 in Ann Arbor, MI. The Packers selected Gary with the 12th overall pick (first round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Michigan defenders Rashan Gary, left, and Josh Metellus tackle Nebraska running back Greg Bell during the first half at Michigan Stadium on Sept. 22, 2018 in Ann Arbor, MI. The Packers selected Gary with the 12th overall pick (first round).</span><meta itemprop="copyrightHolder" content="Kirthmon F. Dozier, Detroit Free Press-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Kirthmon F. Dozier, Detroit Free Press-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Winslow Townson-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/605301f7-6d95-41cb-9bfc-c41f82953421-USATSI_10435846.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/605301f7-6d95-41cb-9bfc-c41f82953421-USATSI_10435846.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Michigan Wolverines defensive lineman Rashan Gary (3) sacks Ohio State Buckeyes quarterback J.T. Barrett (16) during the first half at Michigan Stadium on Nov. 25, 2017 in Ann Arbor, MI. The Packers selected Gary with the 12th overall pick (first round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Michigan Wolverines defensive lineman Rashan Gary (3) sacks Ohio State Buckeyes quarterback J.T. Barrett (16) during the first half at Michigan Stadium on Nov. 25, 2017 in Ann Arbor, MI. The Packers selected Gary with the 12th overall pick (first round).</span><meta itemprop="copyrightHolder" content="Winslow Townson-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Winslow Townson-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide vertical"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo vertical" data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c2d90fa2-5151-4c21-9aae-b60f98435faf-USATSI_9594957.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c2d90fa2-5151-4c21-9aae-b60f98435faf-USATSI_9594957.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Penn State Nittany Lions quarterback Trace McSorley (9) is sacked by Maryland Terrapins defensive back Darnell Savage Jr. (26) during the second quarter at Beaver Stadium on Oct. 8, 2016 in University Park, PA. The Packers selected Savage with the 21st overall pick (first round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Penn State Nittany Lions quarterback Trace McSorley (9) is sacked by Maryland Terrapins defensive back Darnell Savage Jr. (26) during the second quarter at Beaver Stadium on Oct. 8, 2016 in University Park, PA. The Packers selected Savage with the 21st overall pick (first round).</span><meta itemprop="copyrightHolder" content="Matthew O'Haren-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Matthew O'Haren-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Jeff Hanisch-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/f1aa5949-6447-4860-83e5-ec2702e3e884-USATSI_10358903.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/f1aa5949-6447-4860-83e5-ec2702e3e884-USATSI_10358903.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Maryland Terrapins defensive back Darnell Savage Jr. (4) breaks up the pass intended for Wisconsin Badgers tight end Troy Fumagalli (81) during the second quarter at Camp Randall Stadium on Oct. 21, 2017 in Madison, WI. The Packers selected Savage with the 21st overall pick (first round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Maryland Terrapins defensive back Darnell Savage Jr. (4) breaks up the pass intended for Wisconsin Badgers tight end Troy Fumagalli (81) during the second quarter at Camp Randall Stadium on Oct. 21, 2017 in Madison, WI. The Packers selected Savage with the 21st overall pick (first round).</span><meta itemprop="copyrightHolder" content="Jeff Hanisch-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Jeff Hanisch-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Mitch Stringer-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c0b4cec0-5874-43da-b31b-810a51240b08-USATSI_10376039.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c0b4cec0-5874-43da-b31b-810a51240b08-USATSI_10376039.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Indiana Hoosiers wide receiver Whop Philyor (22) is tackled by Maryland Terrapins defensive back Darnell Savage (4) on Oct. 28, 2017 at Maryland Stadium in  College Park, MD. The Packers selected Savage with the 21st overall pick (first round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Indiana Hoosiers wide receiver Whop Philyor (22) is tackled by Maryland Terrapins defensive back Darnell Savage (4) on Oct. 28, 2017 at Maryland Stadium in  College Park, MD. The Packers selected Savage with the 21st overall pick (first round).</span><meta itemprop="copyrightHolder" content="Mitch Stringer-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Mitch Stringer-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="John David Mercer-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/be533f44-e9aa-4be7-ad96-e31e66cc62b2-USATSI_12039592.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/be533f44-e9aa-4be7-ad96-e31e66cc62b2-USATSI_12039592.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="South&#39;s centers Ross Pierschbacher of Alabama (71) and Elgton Jenkins of Mississippi State (74) run through blocking drills during the South squad Senior Bowl practice at Ladd-Peebles Stadium on Jan. 22, 2019 in Mobile, AL. The Packers selected Jenkins with the 44th overall pick (second round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">South's centers Ross Pierschbacher of Alabama (71) and Elgton Jenkins of Mississippi State (74) run through blocking drills during the South squad Senior Bowl practice at Ladd-Peebles Stadium on Jan. 22, 2019 in Mobile, AL. The Packers selected Jenkins with the 44th overall pick (second round).</span><meta itemprop="copyrightHolder" content="John David Mercer-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> John David Mercer-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Kim Klement-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/eb3d31ec-b632-4057-8bad-3b34e5f345b8-USATSI_11993269.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/eb3d31ec-b632-4057-8bad-3b34e5f345b8-USATSI_11993269.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Mississippi State Bulldogs offensive lineman Elgton Jenkins (74) blocks as Iowa Hawkeyes defensive end Chauncey Golston (57) rushes during the second half in the 2019 Outback Bowl at Raymond James Stadium on Jan. 1, 2019 in Tampa, FL. The Packers selected Jenkins with the 44th overall pick (second round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Mississippi State Bulldogs offensive lineman Elgton Jenkins (74) blocks as Iowa Hawkeyes defensive end Chauncey Golston (57) rushes during the second half in the 2019 Outback Bowl at Raymond James Stadium on Jan. 1, 2019 in Tampa, FL. The Packers selected Jenkins with the 44th overall pick (second round).</span><meta itemprop="copyrightHolder" content="Kim Klement-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Kim Klement-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Jeff Blake-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/4531939e-6efb-42de-b6d4-d08a74d11bfd-USATSI_11436752.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/4531939e-6efb-42de-b6d4-d08a74d11bfd-USATSI_11436752.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Texas A&amp;M Aggies tight end Jace Sternberger (81) breaks the tackle of South Carolina Gamecocks defensive back R.J. Roderick (10) in the second half  at Williams-Brice Stadium on Oct. 13, 2018 in Columbia, SC. The Packers selected Sternberger with the 75th overall pick (third round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Texas A&amp;M Aggies tight end Jace Sternberger (81) breaks the tackle of South Carolina Gamecocks defensive back R.J. Roderick (10) in the second half  at Williams-Brice Stadium on Oct. 13, 2018 in Columbia, SC. The Packers selected Sternberger with the 75th overall pick (third round).</span><meta itemprop="copyrightHolder" content="Jeff Blake-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Jeff Blake-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="John Glaser-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/a0e9eef3-b6f3-458e-a212-8419cd45d470-USATSI_11393026.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/a0e9eef3-b6f3-458e-a212-8419cd45d470-USATSI_11393026.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Texas A&amp;M Aggies tight end Jace Sternberger (81) runs to the end zone for a touchdown during the fourth quarter against the Kentucky Wildcats at Kyle Field on Oct. 6, 2018 in College Station, TX. The Packers selected Sternberger with the 75th overall pick (third round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Texas A&amp;M Aggies tight end Jace Sternberger (81) runs to the end zone for a touchdown during the fourth quarter against the Kentucky Wildcats at Kyle Field on Oct. 6, 2018 in College Station, TX. The Packers selected Sternberger with the 75th overall pick (third round).</span><meta itemprop="copyrightHolder" content="John Glaser-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> John Glaser-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Justin Ford-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/abb6f1cb-0fd8-42bc-b70c-0a6b73334069-USATSI_10423878.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/abb6f1cb-0fd8-42bc-b70c-0a6b73334069-USATSI_10423878.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Mississippi Rebels running back Jordan Wilkins (22) is tackled by Texas A&amp;M Aggies defensive lineman Kingsley Keke (88) during the second half  at Vaught-Hemingway Stadium on Nov. 18, 2017 in Oxford, MS. The Packers selected Keke with the 150th overall pick (fifth round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Mississippi Rebels running back Jordan Wilkins (22) is tackled by Texas A&amp;M Aggies defensive lineman Kingsley Keke (88) during the second half  at Vaught-Hemingway Stadium on Nov. 18, 2017 in Oxford, MS. The Packers selected Keke with the 150th overall pick (fifth round).</span><meta itemprop="copyrightHolder" content="Justin Ford-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Justin Ford-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Raj Mehta-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c6737f6f-0dbc-4614-9f3b-e8848a7abcf3-USATSI_11253524.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c6737f6f-0dbc-4614-9f3b-e8848a7abcf3-USATSI_11253524.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Miami Hurricanes wide receiver Lawrence Cager (18) makes a catch for a touchdown against Toledo Rockets cornerback Ka&#39;dar Hollman (13) during the third quarter at the Glass Bowl on Sept. 15, 2018 in Toledo, OH. The Packers selected Hollman with the 185th overall pick (sixth round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Miami Hurricanes wide receiver Lawrence Cager (18) makes a catch for a touchdown against Toledo Rockets cornerback Ka'dar Hollman (13) during the third quarter at the Glass Bowl on Sept. 15, 2018 in Toledo, OH. The Packers selected Hollman with the 185th overall pick (sixth round).</span><meta itemprop="copyrightHolder" content="Raj Mehta-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Raj Mehta-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="John David Mercer-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/373628b0-5237-4293-b385-a0e8335541f6-USATSI_12060630.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/373628b0-5237-4293-b385-a0e8335541f6-USATSI_12060630.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="North running back Dexter Williams of Notre Dame (2) carries the ball up the field against against the South during the first quarter of the NCAA&#39;s Senior Bowl at Ladd-Peebles Stadium on Jan 26, 2019 in Mobile, AL. The Packers selected Williams with the 194th overall pick (sixth round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">North running back Dexter Williams of Notre Dame (2) carries the ball up the field against against the South during the first quarter of the NCAA's Senior Bowl at Ladd-Peebles Stadium on Jan 26, 2019 in Mobile, AL. The Packers selected Williams with the 194th overall pick (sixth round).</span><meta itemprop="copyrightHolder" content="John David Mercer-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> John David Mercer-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide horizontal"  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo horizontal" data-mycapture-src="" data-mycapture-sm-src="" data-byline="Mark D. Smith-USA TODAY Sports"
                                
                                    data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/427f2531-d6e6-44aa-8941-0e2bbe26116a-USATSI_10406550.jpg?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/427f2531-d6e6-44aa-8941-0e2bbe26116a-USATSI_10406550.jpg?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Oklahoma Sooners running back Rodney Anderson (24) is tackled by TCU Horned Frogs linebacker Ty Summers (42) during the fourth quarter at Gaylord Family - Oklahoma Memorial Stadium on Nov. 11, 2017 in Norman, OK. The Packers selected Summers with the 226th overall pick (seventh round)." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="520" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Oklahoma Sooners running back Rodney Anderson (24) is tackled by TCU Horned Frogs linebacker Ty Summers (42) during the fourth quarter at Gaylord Family - Oklahoma Memorial Stadium on Nov. 11, 2017 in Norman, OK. The Packers selected Summers with the 226th overall pick (seventh round).</span><meta itemprop="copyrightHolder" content="Mark D. Smith-USA TODAY Sports" /><span class="credit gallery-viewport-credit"> Mark D. Smith-USA TODAY Sports</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide partner-slide-ad"><div class="gallery-photo-border partner-placement" data-ad-placement="poster_gallery" data-ad-size="[[300,250]]"></div></div><div class="slide gallery-viewport-slide endslate"><div class="gallery-photo-border"><div class="gallery-endslate"><!-- HTML for the endslate content card --><h3 class="gallery-endslate-header">Interested in this topic? You may also want to view these photo galleries:</h3><ul class="gallery-endslate-related"  data-media-url="https://www.gannett-cdn.com/media/"></ul><div class="gallery-endslate-actions"><div class="gallery-actions-replay">Replay</div></div></div></div></div></div><div class="gallery-thumbs thumbs" data-name="compGalleryThumbs"><div class="thumbswrapper"><ul class="thumbslist scrollable-content"><li class="thumb-item active"><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/235a02f3-e6f6-4215-bdc1-e414fc2b8104-USATSI_11300242_1.jpg?crop=2399,1799,x0,y83&amp;width=80&amp;height=60&amp;fit=bounds" alt="Michigan defenders Rashan Gary, left, and Josh Metellus tackle Nebraska running back Greg Bell during the first half at Michigan Stadium on Sept. 22, 2018 in Ann Arbor, MI. The Packers selected Gary with the 12th overall pick (first round)." width="80" height="60"><span class="thumb-count">1 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/605301f7-6d95-41cb-9bfc-c41f82953421-USATSI_10435846.jpg?crop=2072,1554,x136,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Michigan Wolverines defensive lineman Rashan Gary (3) sacks Ohio State Buckeyes quarterback J.T. Barrett (16) during the first half at Michigan Stadium on Nov. 25, 2017 in Ann Arbor, MI. The Packers selected Gary with the 12th overall pick (first round)." width="80" height="60"><span class="thumb-count">2 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c2d90fa2-5151-4c21-9aae-b60f98435faf-USATSI_9594957.jpg?crop=2893,2170,x0,y537&amp;width=80&amp;height=60&amp;fit=bounds" alt="Penn State Nittany Lions quarterback Trace McSorley (9) is sacked by Maryland Terrapins defensive back Darnell Savage Jr. (26) during the second quarter at Beaver Stadium on Oct. 8, 2016 in University Park, PA. The Packers selected Savage with the 21st overall pick (first round)." width="80" height="60"><span class="thumb-count">3 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/f1aa5949-6447-4860-83e5-ec2702e3e884-USATSI_10358903.jpg?crop=4329,3247,x107,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Maryland Terrapins defensive back Darnell Savage Jr. (4) breaks up the pass intended for Wisconsin Badgers tight end Troy Fumagalli (81) during the second quarter at Camp Randall Stadium on Oct. 21, 2017 in Madison, WI. The Packers selected Savage with the 21st overall pick (first round)." width="80" height="60"><span class="thumb-count">4 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c0b4cec0-5874-43da-b31b-810a51240b08-USATSI_10376039.jpg?crop=2593,1945,x324,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Indiana Hoosiers wide receiver Whop Philyor (22) is tackled by Maryland Terrapins defensive back Darnell Savage (4) on Oct. 28, 2017 at Maryland Stadium in  College Park, MD. The Packers selected Savage with the 21st overall pick (first round)." width="80" height="60"><span class="thumb-count">5 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/be533f44-e9aa-4be7-ad96-e31e66cc62b2-USATSI_12039592.jpg?crop=4016,3012,x105,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="South&#39;s centers Ross Pierschbacher of Alabama (71) and Elgton Jenkins of Mississippi State (74) run through blocking drills during the South squad Senior Bowl practice at Ladd-Peebles Stadium on Jan. 22, 2019 in Mobile, AL. The Packers selected Jenkins with the 44th overall pick (second round)." width="80" height="60"><span class="thumb-count">6 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/eb3d31ec-b632-4057-8bad-3b34e5f345b8-USATSI_11993269.jpg?crop=3096,2322,x0,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Mississippi State Bulldogs offensive lineman Elgton Jenkins (74) blocks as Iowa Hawkeyes defensive end Chauncey Golston (57) rushes during the second half in the 2019 Outback Bowl at Raymond James Stadium on Jan. 1, 2019 in Tampa, FL. The Packers selected Jenkins with the 44th overall pick (second round)." width="80" height="60"><span class="thumb-count">7 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/4531939e-6efb-42de-b6d4-d08a74d11bfd-USATSI_11436752.jpg?crop=2549,1912,x0,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Texas A&amp;M Aggies tight end Jace Sternberger (81) breaks the tackle of South Carolina Gamecocks defensive back R.J. Roderick (10) in the second half  at Williams-Brice Stadium on Oct. 13, 2018 in Columbia, SC. The Packers selected Sternberger with the 75th overall pick (third round)." width="80" height="60"><span class="thumb-count">8 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/a0e9eef3-b6f3-458e-a212-8419cd45d470-USATSI_11393026.jpg?crop=4263,3197,x492,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Texas A&amp;M Aggies tight end Jace Sternberger (81) runs to the end zone for a touchdown during the fourth quarter against the Kentucky Wildcats at Kyle Field on Oct. 6, 2018 in College Station, TX. The Packers selected Sternberger with the 75th overall pick (third round)." width="80" height="60"><span class="thumb-count">9 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/abb6f1cb-0fd8-42bc-b70c-0a6b73334069-USATSI_10423878.jpg?crop=2072,1554,x37,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Mississippi Rebels running back Jordan Wilkins (22) is tackled by Texas A&amp;M Aggies defensive lineman Kingsley Keke (88) during the second half  at Vaught-Hemingway Stadium on Nov. 18, 2017 in Oxford, MS. The Packers selected Keke with the 150th overall pick (fifth round)." width="80" height="60"><span class="thumb-count">10 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/c6737f6f-0dbc-4614-9f3b-e8848a7abcf3-USATSI_11253524.jpg?crop=3541,2656,x175,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Miami Hurricanes wide receiver Lawrence Cager (18) makes a catch for a touchdown against Toledo Rockets cornerback Ka&#39;dar Hollman (13) during the third quarter at the Glass Bowl on Sept. 15, 2018 in Toledo, OH. The Packers selected Hollman with the 185th overall pick (sixth round)." width="80" height="60"><span class="thumb-count">11 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/373628b0-5237-4293-b385-a0e8335541f6-USATSI_12060630.jpg?crop=2220,1665,x5,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="North running back Dexter Williams of Notre Dame (2) carries the ball up the field against against the South during the first quarter of the NCAA&#39;s Senior Bowl at Ladd-Peebles Stadium on Jan 26, 2019 in Mobile, AL. The Packers selected Williams with the 194th overall pick (sixth round)." width="80" height="60"><span class="thumb-count">12 of 13</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2019/04/29/PMJS/427f2531-d6e6-44aa-8941-0e2bbe26116a-USATSI_10406550.jpg?crop=1820,1365,x173,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Oklahoma Sooners running back Rodney Anderson (24) is tackled by TCU Horned Frogs linebacker Ty Summers (42) during the fourth quarter at Gaylord Family - Oklahoma Memorial Stadium on Nov. 11, 2017 in Norman, OK. The Packers selected Summers with the 226th overall pick (seventh round)." width="80" height="60"><span class="thumb-count">13 of 13</span></div></a></li></ul></div></div><div class="feature-btns"><div class="ticker feature-btns-control"></div><div class="autoplay feature-btns-control"><span class="playbtn feature-btns-label">Autoplay</span></div><div class="thumbnails feature-btns-control"><span class="thumbLabel feature-btns-label">Show Thumbnails</span></div><div class="captions feature-btns-control"><span class="captionLabel feature-btns-label">Show Captions</span></div></div><a class="slide-nav prev gallery-prev" rel="prev">Last Slide</a><a class="slide-nav next gallery-next" rel="next">Next Slide</a></div><div class="gallery-leaderboard-ad"><div class="partner-placement leaderboard-companion-ad" data-ad-placement="leaderboard_atf" data-ad-sizes="[[728,90]]"></div></div></div></div><div id="module-position-Rwd7Av29EVI" class="story-asset story-metadata-asset"></div><div id="module-position-Rwd7Av2C0f4" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-top"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&amp;text=Packers%20waste%20no%20time%20getting%20first-round%20safety%20Darnell%20Savage%20on%20board&amp;via=PGpackersnews"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments"></span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div><p class="speakable-p-1 p-text">GREEN BAY &ndash; The Green Bay Packers got some important work done early.</p><p class="speakable-p-2 p-text">They became the first team in the NFL to sign a first-round draft choice Thursday, inking safety Darnell Savage, the No. 21 pick overall, to a four-year contract with a fifth-year club option.</p><p class="p-text">ESPN reported the completion of the deal first.</p><p class="p-text">Terms were not available, but with the NFL&rsquo;s rookie wage scale, which attaches a salary-cap number to each slot in the draft, negotiations aren&rsquo;t very complicated. The two sides usually are working with a non-debatable percentage increase from the previous year, so the negotiations can go quickly.</p><div id="module-position-Rwd7Av3_WfI" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="wide single-photo"><img itemprop="url" src="https://www.gannett-cdn.com/presto/2019/04/26/PPAN/f834a202-f257-4528-875d-d784b0c16e99-USATSI_11252469.jpg?width=540&amp;height=&amp;fit=bounds&amp;auto=webp" alt="Sep 15, 2018; College Park, MD, USA; Maryland Terrapins defensive back Darnell Savage Jr. (4) returns an interception against Temple at Capital One Field at Maryland Stadium. Mandatory Credit: Art Pittman-USA TODAY Sports" width="540" data-mycapture-src=""
                    data-mycapture-sm-src="" /><meta itemprop="name" content="Ncaa Football Temple At Maryland" /><meta itemprop="height" content="405" /><meta itemprop="width" content="540" /><p>Sep 15, 2018; College Park, MD, USA; Maryland Terrapins defensive back Darnell Savage Jr. (4) returns an interception against Temple at Capital One Field at Maryland Stadium. Mandatory Credit: Art Pittman-USA TODAY Sports<meta itemprop="copyrightHolder" content="James A. Pittman, Art Pittman / USA TODAY Sports" />&nbsp;<span class="credit">(Photo: James A. Pittman, Art Pittman / USA TODAY Sports)</span></p></aside><div class="clearfix"></div></div><p class="p-text">Packers rookies report for orientation this weekend and several draft picks are expected to have their deals completed before they arrive. Any draft pick that doesn&rsquo;t have his deal done signs a waiver that would protect him financially if he were injured.</p><p class="p-text">The Packers made&nbsp;eight&nbsp;draft picks this year, including two in the first round. Rashan Gary, their first pick at No. 12, will eat up more rookie-cap space than any other pick, but his deal should be done well before training camp starts July 25.</p><p class="p-text"><span class="exclude-from-newsgate"><strong>DOUGHERTY</strong>: <a data-track-label="inline|intext|n/a" href="https://www.packersnews.com/story/sports/nfl/packers/dougherty/2019/04/27/dougherty-speedy-darnell-savage-key-success-packers-draft/3580063002/">Packers&#39; draft success depends on Darnell Savage</a></span></p><p class="p-text"><span class="exclude-from-newsgate"><strong>DRAFT BIO</strong>:&nbsp;<a data-track-label="inline|intext|n/a" href="https://www.packersnews.com/story/sports/nfl/packers/2019/04/25/packers-first-round-21-darnell-savage-jr-safety-maryland/3570666002/">Darnell Savage Jr.</a></span></p><p class="p-text">Typically, third-round picks take the longest because there is room for negotiations. First- and second-round picks get guaranteed salary in addition to a signing bonus, but third-rounders typically just get a signing bonus and there&rsquo;s flexibility to negotiate over the structure.</p><p class="p-text">The Packers have not had trouble getting their rookies signed before the start of training camp since the rookie wage scale was added in 2011.</p><div id="module-position-Rwd7Av3YzAA" class="story-asset oembed-asset"><div class="story-oembed-wrap "><div
            class="js-oembed story-oembed story-oembed- story-oembed-type-"
            data-oembed-type=""
            data-oembed-provider=""><style>
.oembed-frame {
 width: 100%;
 height: 100%;
 margin: 0;
 border: 0;
 }
</style><div class="oembed-frame"><style>h3.embed {text-align:left; font-weight: bold; padding: 0 0 0 10px !important; margin-bottom: 0px;}p.embed {text-align:left; font-weight: bold; padding: 10px 0 0 10px !important;}a.embed {text-align:left; font-weight: bold; padding: 10px 0 0 10px !important;}</style><h3 class="embed">Support PackersNews:</h3><p class="embed"><a href="https://offers.packersnews.com/digitaloffers?gps-source=CPHPPRIMARY&amp;utm_campaign=2018CYBER&amp;utm_medium=ONSITE&amp;utm_content=CPHPPRIMARY&amp;onSuccessRedirectURL=https%3A%2F%2Fwww.packersnews.com%2F&amp;utm_source=CPHPPRIMARY">

	
BECOME A SUBSCRIBER: Full access to articles, videos and columns
</a></p><p class="embed"><a href="https://www.facebook.com/packersnews/">

LIKE  US ON FACEBOOK: Get PackersNews in your feed
</a></p><p class="embed"><a href="https://www.instagram.com/packersnewsinsta/">
FOLLOW US ON INSTAGRAM: Check out Packers photos and videos</a></p><p class="embed"><a href="https://profile.jsonline.com/newsletters/Packers-Update/">
GET OUR NEWSLETTER: Daily roundup delivered to your inbox</a></p></div></div></div></div><p class="p-text p-text-last"id="article-body-p-last">&nbsp;</p><div id="module-position-Rwd7Av3ffY8" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-bottom"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&amp;text=Packers%20waste%20no%20time%20getting%20first-round%20safety%20Darnell%20Savage%20on%20board&amp;via=PGpackersnews"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=https%3A//www.packersnews.com/story/sports/nfl/packers/2019/05/02/green-bay-packers-waste-no-time-signing-draft-pick-darnell-savage/3656619002/&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments"></span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div></div><aside class="story-right-rail"><section id="module-position-Rwd7Av1pZ6E" class="storyrightrail-bucket poster-ad-asset-module story-poster-ad-asset-module"><div class="partner-placement partner-asset-right-ad" data-ad-placement="poster" data-ad-sizes="[[300,250],[300,600],[300,1050]]"></div></section><section id="module-position-Rwd7Av0i7SY" class="storyrightrail-bucket sponsor-button-ad-module story-sponsor-button-ad-module"><div class="partner-placement sponsor-button-ad" data-ad-placement="sponsor_button"  data-ad-sizes="[[300,50]]"></div></section><section id="module-position-Rwd7Av1hJsE" class="storyrightrail-bucket taboola-poster-asset-module story-taboola-poster-asset-module"><div id="taboola-abp-right-rail-thumbnails"></div></section><section id="module-position-Rwd7Av1Sye8" class="storyrightrail-bucket more-section-stories-module story-more-section-stories-module"><div class="story-ribbon" style=""><h6 class="story-ribbon-title">
    
        More Stories
    
</h6><div class="story-ribbon-content"><ul class="more-section-stories-list"><li class="more-section-stories-item first"><a class="more-section-stories-image-link" href="/story/sports/nfl/packers/2019/05/02/packers-morning-buzz-kingsley-keke-nfl-draft-steal/3631061002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/presto/2019/04/27/PPAN/87e58b54-eb54-488a-8cde-e2c0f9ab5055-USATSI_12159249.jpg?crop=3139,3139,x1,y184&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Packers Morning Buzz: Kingsley Keke a &#39;steal&#39; after strong Senior Bowl showing" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/nfl/packers/2019/05/02/packers-morning-buzz-kingsley-keke-nfl-draft-steal/3631061002/"    data-ht="moresportsstories">
                    Buzz: Packers DL Kingsley Keke a draft 'steal'</a></h6><div class="more-section-stories-meta">
                    May 2, 2019, 8:22 a.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/nfl/packers/2019/05/02/dexter-williams-turns-life-around-help-guardian-angel/3641226002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/presto/2018/09/30/PIND/eec2b3fa-bd3d-4ca2-a823-b045ed2dd2ba-USATSI_11346965.jpg?crop=2396,2396,x782,y0&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Packers’ Dexter Williams makes most of second chance with help from ‘guardian angel’" class="more-section-stories-thumb"/><div class="play-btn-m clst-thumb-play-btn-m"></div></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/nfl/packers/2019/05/02/dexter-williams-turns-life-around-help-guardian-angel/3641226002/"    data-ht="moresportsstories">
                    Dexter Williams gets support from ‘guardian angel’</a></h6><div class="more-section-stories-meta">
                    May 2, 2019, 7:34 a.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/nfl/packers/2019/05/01/green-bay-packers-pick-up-kenny-clarks-fifth-year-option/3638982002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/presto/2019/04/10/PPAN/fdae2170-e030-4b73-9772-aa3df7383f2d-Clark_041019_ABW017.jpg?crop=2177,2166,x389,y0&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Green Bay Packers pick up Kenny Clark&#39;s fifth-year option" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/nfl/packers/2019/05/01/green-bay-packers-pick-up-kenny-clarks-fifth-year-option/3638982002/"    data-ht="moresportsstories">
                    Packers pick up Kenny Clark's fifth-year option</a></h6><div class="more-section-stories-meta">
                    May 1, 2019, 5:35 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/nfl/packers/2019/05/01/analysis-packers-confident-one-major-addition-revitalize-offense/3627796002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/presto/2019/04/24/PPAN/b2095057-377a-4ce5-a8a5-1b57955ac3e3-GPG_Packers_Practice_042319_ABW695.jpg?crop=2249,2262,x0,y228&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Analysis: Packers confident one major addition will revitalize offense" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/nfl/packers/2019/05/01/analysis-packers-confident-one-major-addition-revitalize-offense/3627796002/"    data-ht="moresportsstories">
                    One major addition could revive Packers' offense</a></h6><div class="more-section-stories-meta">
                    May 1, 2019, 8:46 a.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/nfl/packers/2019/05/01/packers-morning-buzz-offensive-line-2020-draft-priority/3620482002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/presto/2019/04/30/PPAN/bc87ac69-150e-43aa-8ede-f871534d3e0f-Eichenberg.jpg?crop=1491,1463,x293,y0&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Packers Morning Buzz: Predicting Green Bay&#39;s first pick in 2020 draft" class="more-section-stories-thumb"/><div class="play-btn-m clst-thumb-play-btn-m"></div></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/nfl/packers/2019/05/01/packers-morning-buzz-offensive-line-2020-draft-priority/3620482002/"    data-ht="moresportsstories">
                    Buzz: Predicting Packers' first pick in 2020 draft</a></h6><div class="more-section-stories-meta">
                    May 1, 2019, 4:30 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/sports/nfl/packers/2019/04/30/packers-draft-behind-scenes-facts-each-green-bay-pick/3626416002/"   data-ht="moresportsstories"><img src="https://www.gannett-cdn.com/-mm-/2c0ea85f6982dcba5ebe1575410835689b404abe/c=286-0-2535-2249/local/-/media/2019/04/26/USATODAY/usatsports/6e49f28590364b72b83e6fce05e2489f.jpg?width=80&amp;height=80&amp;fit=crop" width="80" height="80" alt="Did you know? Behind-the-scenes facts about each Packers 2019 draft pick" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/sports/nfl/packers/2019/04/30/packers-draft-behind-scenes-facts-each-green-bay-pick/3626416002/"    data-ht="moresportsstories">
                    Behind-the-scenes facts about Packers draft picks</a></h6><div class="more-section-stories-meta">
                    April 30, 2019, 10:47 a.m.
                </div></li></ul></div></div></section><section id="module-position-Rwd7Av1PLRg" class="storyrightrail-bucket poster-ad-asset2-module story-poster-ad-asset2-module"><div class="partner-asset-right-ad-2"><div class="poster-scroll"><div class="partner-placement poster-scroll-ad" data-ad-placement="poster_scroll" data-ad-sizes="[[300,250],[300,600],[300,1050]]"></div></div></div></section></aside><section id="module-position-Rwd7Av1NdS4" class="storybottombar-bucket taboola-related-module story-taboola-related-module"><div class="more more-stories-wrap"><div class="more-stories-content"><div id="js-taboola-wrapper"><div id="taboola-grid-3x3"></div><div id="taboola-organic-grid-3x3"></div><div id="taboola-short-article-2x5"></div><div id="taboola-organic-short-article-2x5"></div><div id="taboola-grid-sports-3x3"></div><div id="taboola-organic-grid-sports-3x3"></div></div></div></div><div class="clearfix"></div></section><section id="module-position-Rwd7Av0tgbs" class="storybottombar-bucket leaderboard-ad-module story-leaderboard-ad-module"><div class="partner-placement leaderboard-btf-ad leaderboard-ad" data-ad-placement="leaderboard_btf" data-ad-sizes="[[728,90]]"></div></section><section id="module-position-Rwd7Av1z2XI" class="storymessaging-bucket cam-messaging-module story-cam-messaging-module"><div class="cm-wrapper"><div class="alert-bar cm-collapsed"><div class="cm-remaining-views"><span class="remaining-views-text"></span><div class="cm-open"><div class="cm-arrow"></div></div></div><div class="cm-offer"><div class="cm-line-1"></div><div class="cm-line-2"></div><div class="cm-cta"><a class="cm-cta-btn"></a><span class="cm-cta-txt"></span></div><div class="cm-market"><a class="cm-market-img" href="/"><img class="cm-market-img" src="https://www.gannett-cdn.com/gannett-web/properties/packersnews/logos-and-branding/logo-default-light.svg"></a></div></div></div></div></section><script>
window.simpleExclusion = window.simpleExclusion || [];
window.simpleTarget = window.simpleTarget || [];
Array.prototype.push.apply(window.simpleExclusion, []);
Array.prototype.push.apply(window.simpleTarget, []);
</script><!-- comscorekw=sports --><script type="json/pageinfo" class="pageinfo">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</script></article></div><div class="arrows overlay-arrows"><script type="text/template" id="overlay-arrow-wrap"><% if (disabled) { %><a class="overlay-content-arrows overlay-arrows-<%= dir %>-wrap <%= disabled %>" data-ht="articlearrow<%= dir %>"></a><% }else{ %><a class="overlay-content-arrows overlay-content-arrows-<%= dir %>-wrap <%= disabled %>" href="<%= links %>" data-ht="articlearrow<%= dir %>"><div class="overlay-arrow-<%= dir %> overlay-arrows-anchor"><div class="overlay-arrows-<%= dir %>-anchor-image"></div></div></a><% } %></script></div></div><div id="overlay-film" class="ui-film show"></div><div id="ad-staging"></div><div class="partner-popup"></div><!--[if lt IE 9]><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/jsb/main_legacy.min.js"></script><![endif]--><!--[if gt IE 8]><!--><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/packersnews/uscp-web-static-4509.26.0/jsb/main.min.js"></script><!--<![endif]--><script src="https://login.gcion.com/GANNETT-GUP/resources/kit/js/norequirejs.common.min.js" id="jskit"></script><script type="text/javascript">
        
        require(["gdp-usf/kit/js/user_factory_def", "gdp-usf/kit/js/feature_personalized_link_def", "gdp-usf/kit/js/client_helpers"],
            function(UserFactory, PersonalizedLinkFactory, ClientHelpers) {
                window.UserFactory = UserFactory;
                window.PersonalizedLinkFactory = PersonalizedLinkFactory;
                window.ClientHelpers = ClientHelpers;
            }
        );
        </script><div id="fb-root"></div><script src="https://www.gannett-cdn.com/appservices/gidgits-js/gidgits.min.js" id="gidgits-script"></script><script type="text/javascript">
        var mainAd = document.createElement('div');
        mainAd.id = 'main_ad';
        mainAd.style.cssText = 'height:1px; width:1px; overflow:auto;position: absolute;left: -999em;';
        document.body.appendChild(mainAd);
        var blockPosition = document.getElementById('main_ad');
        if(blockPosition && blockPosition.offsetHeight == 1) {
            window.adsEnabled = true;
        }
    </script><script>
/* Wrapper for Gannett, generated on 2018-11-08T16:48:57-05:00 */
(function() {
    var config = (window.site_vars && window.site_vars.ADS && window.site_vars.ADS.confiant) ? window.site_vars.ADS.confiant : {},
        h = (config.cdn) ? config.cdn :'clarium.global.ssl.fastly.net',
        src = (config.scriptUrl) ? config.scriptUrl : 'https://' + h + '/gpt/ust/wrap.js',
        propertyId = (config.propertyId) ? config.propertyId : 'r5TdgVvkbv-PeaJCKaQfCh5Xsto',
        mapping = (config.mapping) ? config.mapping : 'W3siaSI6MiwidCI6Int7b319Ont7d319eHt7aH19IiwicCI6MCwiRCI6MSwiciI6W119LHsiaSI6NiwidCI6Int7Y299fTp7e3d9fXh7e2h9fSIsInAiOjUwLCJEIjowLCJyIjpbeyJ0IjoiZXgiLCJzIjpudWxsLCJ2IjoiY28ifV19XQ==',
        activation = (config.activation) ? config.activation : '|||MjE1MjU5NDI4Nw==,|||MjE1NDYyNzI3Nw==,|||MjE1NDg2ODczOA==,|||MjE1NDkxMDUyMQ==,|||MjE1NDkzODgxOQ==,|||MjE1NDkzOTAxNQ==,|||MjE1NDk1MTMxNw==,|||MjE1NDk1ODk0Ng==,|||MjE1NTU3MDk3OQ==,|||MjMzOTQ5OTI1NA==,|||MjMzOTg3ODQ4Mw==,|||MjE5NzEzNDY3Mw==,|||MjM1ODA4NzI0Mw==,|||MjM1ODA3NzIxMQ==,|||MjM1ODA2NjY2MA==,|||MjM1ODA0NTU0MA==,|||MjM1Nzc3MTUwMA==,|||MjM1Nzc2Mzk5MQ==,|||MjM1Nzc1ODI0Ng==,|||MjM1Nzc1NTg0OQ==,|||MjM1Nzc1MDgyMQ==,|||MjM1Nzc0NjUxMA==,|||MjM1Nzc0MjkwMQ==,|||MjM1NzczOTAwMQ==,|||MjM1NzM2ODIzNQ==,|||MjM1NzM2MzQ5NQ==,|||MjM1NzM1NDMwMw==,|||MjM1NzM1MjQ0Ng==,|||MjE1MjUyNDE0OQ==,|||MjE1MzI2MjIyNw==,|||MjI4NDQwODIyNg==,|||MjE1MjUyMzkwMA==,|||MjE1MzI4NTI1OQ==,|||MjE2MTk2ODEzOA==,|||MjExMTg4ODU0OA==,|||MjExMTkzNTQyMg==,|||MjE1MjU0OTYyNw==,|||MjE1MzI4MzM0OA==,|||MjE1NDkwMzM1Nw==,|||MjExMTg5MzA4MQ==,|||MjExMTkzNzA0NQ==,|||MjE1MjU5MjYzMQ==,|||MjE1MjU5MzI4NQ==,|||MjE1MzE4ODcxNw==,|||MjE1MjUyOTY2NQ==,|||MjE1MzI4NDA2Mg==,|||MjE1MjU5NTcyMQ==,|||MjE1MjU0OTg3MA==,|||MjE1MzI2MDc2OQ==,|||MjE1MjUyMzk2Ng==,|||MjE1MzI4NTY5MQ==,|||MjI1Njk4NzMyNw==,|||MjE1MjUyODk3Mg==,|||MjE1MzI2MTcyMA==,|||MjE1MjU5NDc5MQ==,|||MjE1MjYxNjExMg==,|||MjE1MzI1OTU3NQ==,|||MjI2MDQyMjM2MQ==,|||MjI2MTM0OTAzOQ==,|||MjI5MzE3NzE5OQ==,|||MjI5MzYyMDIzNA==,|||MjE1NDY1NjU4NQ==,|||MjE1NDYwNTg5Ng==,|||MjE1MjU5MTg4Ng==,|co|ex|MQ==,|||MjQxOTcyMjY1MA==,|||MjQyMDI0ODczMQ==,|||MjM2ODI3Njk1Mg==,|||MjQzODM5ODUyNQ==,|||MjQyNTUzODUzMQ==,|||MjQyNTczODAwOQ==,|||MjM3OTE3ODI1MA==,|||MjM3OTY0NDEzNw==,|||MjE4MTI1MTk4Mg==,|||MjQxNTQyNTkyOQ==,|||MjQxNTQ3OTkwMQ==,|||MjQyNjgwNzQwOQ==,|||MjQyNjgzNjI4NA==,|||MjExMTg3MDM5Mg==,|||MjE1NjUzNzE2Ng==,|||MjQwNDc5MjcxMg==,|||MjQwNTc1MDc2NA==,|||MjI5MzI2NzU5Mg==,|||MjI5MzM1NTkyNg==,|||MjQxNTAxMDUzNg==,|||MjQyMTQ4NjIwMA==,|||MjQyMjM1ODMxNQ==,|||MjQyNjEzMjA3Mw==,|||MjQzOTAzMDg1NQ==,|||MjQyODA5MzYxOQ==,|||MjQ0NzMzMjAwNA==,|||MjQ0NzM0NDc2Mw==';

    window._clrm = window._clrm || {};
    window._clrm.gpt = {
        propertyId: propertyId,
        confiantCdn: h,
        sandbox: 0,
        mapping: mapping,
        activation: activation,
        callback: function(blockingType, blockingId, isBlocked, wrapperId, tagId, impressionData) {
            if (window.newrelic) {
                window.newrelic.addPageAction('advertisingConfiant', {
                    blockingType: blockingType,
                    blockingId: blockingId,
                    isBlocked: isBlocked,
                    wrapperId: wrapperId,
                    tagId: tagId
                });
            }

            if (config.refreshBlocked) {
                var slotId = impressionData && impressionData.dfp && impressionData.dfp.s;
                if (slotId) {
                    window.googletag = window.googletag || {};
                    window.googletag.cmd = window.googletag.cmd || [];
                    window.googletag.cmd.push(function () {
                        window.googletag.pubads().getSlots().forEach(function (slot) {
                            if (slot.getSlotElementId() === slotId && slot.__gannettSlot) {
                                slot.__gannettSlot.refresh();
                            }
                        })
                    });
                }
            }
        }
    };
    var e = document.createElement('script');
    e.async = true;
    e.src = src;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(e, s);
})();
</script></body></html>
