<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Green Bay Packers: Erratic special teams could get a boost</title><meta property=og:title content="'All hands on deck' approach could boost Packers' erratic special teams"/><link rel=amphtml href=https://amp.packersnews.com/amp/4145098001 /><meta property=article:author content="Tom Silverstein, Ryan Wood and Olivia Reiner"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.packersnews.com /><link rel=preconnect href=https://user.packersnews.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.packersnews.com /><link rel=dns-prefetch href=//e.infogram.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.packersnews.com/PPAN-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z3a4c5d90e.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z31af45492.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-dfd2910d.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-454f9438.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-581ff685.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-9a7e82f6.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-b3e4ce3e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-9b155356.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/ed7172fd-55b4-402e-b169-1cc5a460a62b/e9fb3660-da21-4fd6-a4de-0bdc1a82421f/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=6644145002" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="No one with the Green Bay Packers may be feeling more pressure heading into the playoffs than special teams coach Shawn Mennenga."/><meta property=og:description content="No one with the Green Bay Packers may be feeling more pressure heading into the playoffs than special teams coach Shawn Mennenga."/><meta property=fb:pages content=338437548341 /><meta property=fb:app_id content=249896938457153 /><link rel=canonical href=https://www.packersnews.com/story/sports/nfl/packers/2021/01/14/green-bay-packers-erratic-special-teams-could-get-boost/4145098001/ /><meta property=og:url content=https://www.packersnews.com/story/sports/nfl/packers/2021/01/14/green-bay-packers-erratic-special-teams-could-get-boost/4145098001/ /><meta property=og:site_name content="Packers News"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2020/08/24/PPAN/e91f4f07-e1cf-4cc7-a44b-282c50c7d219-packers25_14_hoffman.jpg?crop=4935,2776,x0,y0&width=3200&height=1801&format=pjpg&auto=webp"/><meta property=og:image:width content=3200 /><meta property=og:image:height content=1801 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2020/08/24/PPAN/e91f4f07-e1cf-4cc7-a44b-282c50c7d219-packers25_14_hoffman.jpg?crop=4935,2776,x0,y0&width=1600&height=800&format=pjpg&auto=webp"/><meta name=twitter:site content=@PGpackersnews /><meta name=twitter:creator content=@PGpackersnews /><meta name=twitter:title content="'All hands on deck' approach could boost Packers' erratic special teams"/><meta name=twitter:description content="No one with the Green Bay Packers may be feeling more pressure heading into the playoffs than special teams coach Shawn Mennenga."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol><symbol id=gnt_svg_video_play viewBox="0 0 84 84"><circle stroke=#0098FE stroke-width=4 fill=#303030 cx=40.5 cy=40.5 r=38 /><path fill=#FFF d="M56 40.23l-22.5 13.5v-27z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=${tc}|H1Nav|skipToMainContent aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Packers News" data-t-l=|H1Nav|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#303030 preserveAspectRatio="xMinYMid meet" viewBox="0 0 278.93 22.88"><path d="M17.25 8.24C17.25 3.86 14 .55 8.31.55H0v21.91h6.28v-6.55h1.99c5.67 0 8.98-3.29 8.98-7.67zm-9.96 2.65H6.28V5.55h1.06c2.37 0 3.45.84 3.45 2.69s-1.06 2.67-3.43 2.67l-.07-.02zM22.45.55l-8.17 21.91h6.37l1-3.15h8.29l1.04 3.15h6.53L29.34.55h-6.89zm.84 13.78l1.69-5.28c.35-1.07.6-2.17.76-3.29h.16c.16 1.12.41 2.22.76 3.29l1.69 5.28h-5.06zm19.22-2.8a5.42 5.42 0 015.76-5.98c1.71-.03 3.39.5 4.78 1.49V1.27A10.59 10.59 0 0047.81.11a10.99 10.99 0 00-11.74 11.41A10.9 10.9 0 0047.8 22.93c1.91.06 3.81-.33 5.54-1.16v-5.82a7.77 7.77 0 01-5.06 1.49 5.4 5.4 0 01-5.77-5.91zM75.7.55h-7.09l-6.85 9.86V.55h-6.22v21.91h6.22V12.08l6.69 10.42h7.69l-7.75-11.28L75.7.55zm7.29 13.23h6.91V8.8h-6.87V5.55h7.03v-5H76.73v21.91h13.61V17.5h-7.31l-.04-3.72zm27.09-5.84c0-5.28-3.98-7.37-8.61-7.37h-9.04v21.91h6.28v-7.43h.9l4.6 7.43h7.13l-5.7-8.51a6.51 6.51 0 004.48-6.04l-.04.01zm-9.6 2.37h-1.81V5.55h1.81c2.09 0 3.15.82 3.15 2.37s-1 2.39-3.11 2.39h-.04zm21.04-1.53c-1.81-.56-3.47-.94-3.47-2.31 0-.88.7-1.53 2.31-1.53 1.66.01 3.24.74 4.32 1.99l2.85-4.18a10.72 10.72 0 00-7.47-2.53c-4.82 0-8.23 2.79-8.23 6.93 0 3.78 2.81 5.44 5.98 6.41 2.37.72 3.78 1.16 3.78 2.69s-.98 1.99-2.59 1.99a6.95 6.95 0 01-5.06-2.73l-3.03 4.18a11.96 11.96 0 008.51 3.19c5.48 0 8.51-3.15 8.51-7.37s-2.77-5.62-6.41-6.73zm24.32.33c-.02 1.56.04 3.11.18 4.66h-.12a25.15 25.15 0 00-2.63-3.98L135.9.51h-5.64v21.91h5.98v-8.57c.02-1.56-.04-3.11-.18-4.66h.12a25.15 25.15 0 002.63 3.98l7.37 9.28h5.72V.55h-5.98l-.08 8.56zm15.7 4.67h6.91V8.8h-6.83V5.55h7.03v-5h-13.27v21.91h13.55V17.5h-7.31l-.08-3.72zM196.9.55l-2.59 8.98c-.53 1.73-.89 3.5-1.08 5.3h-.18c-.18-1.8-.53-3.57-1.06-5.3L189.24.55h-5.64l-2.65 8.98a27.91 27.91 0 00-1.06 5.28h-.18a27.96 27.96 0 00-1.08-5.28l-2.65-9h-6.37l6.97 21.91h5.98l2.69-8.92c.52-1.72.88-3.49 1.06-5.28h.18c.16 1.79.49 3.56 1 5.28l2.65 9h5.98L203.09.61 196.9.55zm16.25 8.23c-1.81-.56-3.47-.94-3.47-2.31 0-.88.7-1.53 2.31-1.53 1.66.01 3.24.74 4.32 1.99l2.85-4.18a10.72 10.72 0 00-7.47-2.53c-4.82 0-8.23 2.79-8.23 6.93 0 3.78 2.81 5.44 5.98 6.41 2.37.72 3.78 1.16 3.78 2.69s-.98 1.99-2.59 1.99a6.94 6.94 0 01-5.18-2.73l-3.03 4.18a11.96 11.96 0 008.51 3.19c5.48 0 8.51-3.15 8.51-7.37s-2.76-5.62-6.29-6.73zm9.16 9.96a1.99 1.99 0 100 3.98 1.99 1.99 0 000-3.98h-.04.04zm5.26-3.99a5.28 5.28 0 014.99-5.55l.41-.01a5.73 5.73 0 013.51 1.06V7.54a7.72 7.72 0 00-3.63-.78 8.1 8.1 0 000 16.2c1.3.02 2.58-.27 3.75-.84v-2.91a5.72 5.72 0 01-3.57 1.12 5.27 5.27 0 01-5.5-5.56l.04-.02zm17.93-8.09a8.1 8.1 0 108.25 8.1 7.96 7.96 0 00-7.86-8.07h-.34l-.05-.03zm0 13.69a5.27 5.27 0 01-5.29-5.27l.01-.33a5.3 5.3 0 1110.56 0 5.28 5.28 0 01-4.93 5.61l-.31.01-.04-.02zm27.57-13.69a5.72 5.72 0 00-5.38 2.97 5.15 5.15 0 00-5.06-2.97 5.31 5.31 0 00-4.76 2.43V7.1h-2.89v15.44h2.97v-8.82c0-2.91 1.49-4.6 3.98-4.6s3.53 1.59 3.53 4.5v8.88h2.97v-8.79c0-2.91 1.49-4.6 3.98-4.6s3.57 1.59 3.57 4.5v8.88h2.91v-9.42c0-4.06-2.13-6.39-5.78-6.39l-.04-.02z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.packersnews.com/specialoffer?gps-source=CPNBAR&itm_campaign=2021NEWYEAR&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" target=_blank rel=noopener data-t-l=|H1Nav|nanobar elementtiming=nav-submsg><div class=gnt_n_sm_a_pt>SUBSCRIBE NOW</div>$3 for 3 months. Save 90%.</a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.packersnews.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021NEWYEAR&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" target=_blank rel=noopener data-t-l=|H1Nav|headersubscribecallout elementtiming=nav-submsg><div class=gnt_n_sm_a_pt>SUBSCRIBE NOW</div>$3 for 3 months. Save 90%.</a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/fans/ data-t-l=|H1Nav|fans elementtiming=nav-item>Fans</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=http://www.greenbaypressgazette.com/ data-t-l=|H1Nav|green-bay-press-gazette>Green Bay Press-Gazette</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=http://www.jsonline.com/ data-t-l=|H1Nav|milwaukee-journal-sentinel>Milwaukee Journal Sentinel</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=${tc}|H1Nav|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=${tc}|H1Nav|search title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.packersnews.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021NEWYEAR&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" target=_blank rel=noopener data-t-l=|H1Nav|subscribe elementtiming=nav-subbt>Subscribe</a><div class=gnt_n_us_a_w data-g-r=nav_ce><a class="gnt_n_us_a gnt_n_mn_ce" href="https://login.packersnews.com/PPAN-GUP/authenticate?success-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&cancel-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" data-g-r=nav_ab data-g-tn=navus data-t-l=${tc}|H1Nav|account aria-label="Sign In" aria-haspopup=true aria-expanded=false><svg class=gnt_n_us_a_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></a></div></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-wi-greenbay-packersnews-C1014-high_impact-sports-football-nfl-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/sports/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/sports/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl><a class=gnt_ar_lbl_a data-t-l=|sectionLabel href=/columns/ >PACKERS</a></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>'All hands on deck' approach could boost Packers' erratic special teams</h1><div class=gnt_ar_by><a href=/staff/4804382002/tom-silverstein/ class="gnt_ar_by_a gnt_ar_by_a__si">Tom Silverstein</a> <a href=https://www.greenbaypressgazette.com/staff/4386950002/ryan-wood/ class=gnt_ar_by_a>Ryan Wood</a> <a href=https://www.jsonline.com/staff/4387003002/olivia-reiner/ class="gnt_ar_by_a gnt_ar_by_a__fi">Olivia Reiner</a><div class=gnt_ar_pb>Packers News</div></div><div class=gnt_ar_dt aria-label="Published 6:48 p.m. CT Jan. 13, 2021"></div><div class="gnt_ss gnt_ss__cm__tp" data-g-r=base_sc data-ss-u=https://www.packersnews.com/story/sports/nfl/packers/2021/01/14/green-bay-packers-erratic-special-teams-could-get-boost/4145098001/ data-ss-t="'All hands on deck' approach could boost Packers' erratic special teams" data-ss-d="No one with the Green Bay Packers may be feeling more pressure heading into the playoffs than special teams coach Shawn Mennenga."><a class=gnt_ss_cm href="https://cm.packersnews.com/comment/?storyUrl=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&marketName=packersnews&commentsopen=false" rel=nofollow data-t-l=|open|commentsopen>View Comments</a> <a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=249896938457153&href=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-top|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&text='All%20hands%20on%20deck'%20approach%20could%20boost%20Packers'%20erratic%20special%20teams&via=PGpackersnews" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-top|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject='All%20hands%20on%20deck'%20approach%20could%20boost%20Packers'%20erratic%20special%20teams%20-%20from%20Packers%20News&body='All%20hands%20on%20deck'%20approach%20could%20boost%20Packers'%20erratic%20special%20teams%0A%0ANo%20one%20with%20the%20Green%20Bay%20Packers%20may%20be%20feeling%20more%20pressure%20heading%20into%20the%20playoffs%20than%20special%20teams%20coach%20Shawn%20Mennenga.%0A%0ACheck%20out%20this%20story%20on%20packersnews.com%3A%20https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" data-t-l=${tc}|navbar-share-top|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-top|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class=gnt_ar_b><aside class="gnt_em gnt_em__fp gnt_em_vp__tp gnt_em__el" aria-label="Video - Who might start at Quarterback for the Rams"><div class=gnt_em_vp_w data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-hero aria-live=polite><button class="gnt_em_vp_a gnt_em_vp__tp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;wi-greenbay-packersnews-C1014&#34;,&#34;pn&#34;:&#34;Packers News&#34;,&#34;vidNum&#34;:1,&#34;docking&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;sports/football/nfl&#34;,&#34;byline&#34;:&#34;Bill Schulz&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;PPAN&#34;,&#34;createDate&#34;:&#34;2021-01-14T00:48:58Z&#34;,&#34;credit&#34;:&#34;Bill Schulz, Packers News&#34;,&#34;duration&#34;:221000,&#34;headline&#34;:&#34;Who might start at Quarterback for the Rams&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/ed7172fd-55b4-402e-b169-1cc5a460a62b/e9fb3660-da21-4fd6-a4de-0bdc1a82421f/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=6644145002&#34;,&#34;id&#34;:&#34;6644145002&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2021/01/12/PPAN/dc7207bc-fdc1-43e1-aef5-68d782ec2001-ed7172fd-55b4-402e-b169-1cc5a460a62b_thumbnail.png&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-01-14T00:48:58Z&#34;,&#34;keywords&#34;:&#34;Leroy Butler videos,Green Bay Packers&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/ed7172fd-55b4-402e-b169-1cc5a460a62b/e9fb3660-da21-4fd6-a4de-0bdc1a82421f/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;Packers News&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.packersnews.com/videos/sports/nfl/packers/2021/01/14/who-might-start-quarterback-rams/6644145002/&#34;},&#34;promoBrief&#34;:&#34;Both Jared Goff and John Wolford are both injured, LeRoy gives his opinion on who he thinks will start.&#34;,&#34;propertyName&#34;:&#34;WIGroup&#34;,&#34;publishDate&#34;:&#34;2021-01-14T00:48:58Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;sports&#34;,&#34;subsection&#34;:&#34;nfl&#34;,&#34;topic&#34;:&#34;packers&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;d4cd0ce8-201c-4fdf-9216-3ce1c09397cc&#34;,&#34;name&#34;:&#34;Leroy Butler videos&#34;},{&#34;id&#34;:&#34;2b76aec5-0d77-4545-9a2a-f864de5488eb&#34;,&#34;name&#34;:&#34;Green Bay Packers&#34;}],&#34;title&#34;:&#34;Who might start at Quarterback for the Rams&#34;,&#34;url&#34;:&#34;/videos/sports/nfl/packers/2021/01/14/who-might-start-quarterback-rams/6644145002/&#34;}" aria-label="Play video"><svg class=gnt_em_vp_svg><use xlink:href=#gnt_svg_video_play /></svg></button><div class=gnt_em_vp_c><button class=gnt_em_vp_db aria-label="Close docked video player" data-t-l=${tc}|tealplayer|playerClose><svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2021/01/12/PPAN/dc7207bc-fdc1-43e1-aef5-68d782ec2001-ed7172fd-55b4-402e-b169-1cc5a460a62b_thumbnail.png?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="Who might start at Quarterback for the Rams" muted playsinline elementtiming=ar-lead-video></video></div></div></div><div class=gnt_em_vt data-c-et="Who might start at Quarterback for the Rams"></div><div class="gnt_em_vb gnt_em_vb__te" aria-label="Both Jared Goff and John Wolford are both injured, LeRoy gives his opinion on who he thinks will start." data-c-credit="Bill Schulz, Packers News"></div></aside><p class=gnt_ar_b_p>GREEN BAY - No one with the Green Bay Packers may be feeling more pressure heading into the playoffs than special teams coach Shawn Mennenga.</p><p class=gnt_ar_b_p> A year after Mennenga was hailed for clearing up the mess he inherited from former special teams coach Ron Zook, his units have been taking on water the last nine weeks and are the team’s Achilles heel heading into the playoffs.</p><p class=gnt_ar_b_p>As fans of the Packers witnessed in 2014, special teams mistakes can cost you a trip to the Super Bowl and the test of how well coach Matt LaFleur’s team is equipped to make it to Tampa in February could rest with the performance of Mennenga’s units.</p><p class=gnt_ar_b_p>“I think the special teams, it either gets noticed when it's really good or really bad and unfortunately we've had a couple big plays that we've given up over the course of the season on special teams,” LaFleur said. “I think a lot of times when you get down to these types of games where you've got two evenly matched teams, a lot of times special teams is the answer.”</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:435px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2020/08/24/PPAN/e91f4f07-e1cf-4cc7-a44b-282c50c7d219-packers25_14_hoffman.jpg?width=660&height=435&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2020/08/24/PPAN/e91f4f07-e1cf-4cc7-a44b-282c50c7d219-packers25_14_hoffman.jpg?width=1320&height=870&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Packers special teams coordinator Shawn Mennenga has been taking some heat this season."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Packers special teams coordinator Shawn Mennenga has been taking some heat this season." data-c-credit="Mark Hoffman/Milwaukee Journal Sentinel"></div></figure><p class=gnt_ar_b_p>Of late, it has been the answer as to what unit has been the shakiest.</p><p class=gnt_ar_b_p>Over the course of the last nine games, the special teams units have:</p><ul class=gnt_ar_b_ul><li class=gnt_ar_b_ul_li>Lost a fumbled punt return at Chicago.</li><li class=gnt_ar_b_ul_li>Allowed a blocked field goal (called back by a phantom penalty) vs. Tennessee.</li><li class=gnt_ar_b_ul_li>Allowed a 71-yard kickoff return at Detroit,</li><li class=gnt_ar_b_ul_li>Allowed a 73-yard punt-return touchdown, a 46-yard kickoff return and had a missed extra point vs. Philadelphia.</li><li class=gnt_ar_b_ul_li>Missed an extra point vs. Chicago,</li><li class=gnt_ar_b_ul_li>Lost a fumbled kickoff at Indianapolis.</li><li class=gnt_ar_b_ul_li>Allowed a 91-yard kickoff return vs. Jacksonville.</li></ul><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>There have been other gaffes, such as a blocked punt, that have marred this season’s performance.</p><p class=gnt_ar_b_p>In addition, the return units have been awful. The punt-return unit has 21 total yards in the last nine games and opponents have had a longer kickoff than the Packers in eight straight.</p><p class=gnt_ar_b_p>The Packers are 3-5-1 in measuring average drive start after kickoffs over the last nine games. Not even the addition of veteran returner Tavon Austin (who coughed up the punt in the Bears game) has been able to help.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>The positive side of the ledger is that Mennenga has cured the special teams of the penalty bug it had under Zook and so there has been a lot less lost yardage. Kicker Mason Crosby has been perfect on field goals and punter JK Scott has bounced back from a midseason slump.</p><p class=gnt_ar_b_p>All of it resulted in a No. 29 spot in longtime football writer Rick Gosselin’s annual special teams rankings for the Talk of Fame Network. The rankings, which came out Wednesday, are strictly statistical based, measuring 22 kicking-game categories.</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>Interestingly, New Orleans ranked No. 5. The Saints' special teams are run by Darren Rizzi, who was prepared to take the Packers job two years ago but felt the front office messed around with him in negotiations and decided to take himself out of the running.</p><p class=gnt_ar_b_p>The playoffs are a new season and Mennenga has a chance to prove he can turn things around. Asked by a reporter about the recent big plays allowed, he said he can’t dwell on the past.</p><p class=gnt_ar_b_p>“I don’t want anything bad to happen, but it’s just like if you write a bad story, you’re going to learn from it and move on,” he responded. “We correct it on film, we try to emphasize it, and it’s been a different thing every time.</p><p class=gnt_ar_b_p>“I can’t predict the future. We tried to correct it and we’ll see how the game goes on and hopefully good things happen for us.”</p><p class=gnt_ar_b_p>To help Mennenga, LaFleur has apparently given the go-ahead to use some starting players on special teams. Typically, it’s all backups, many of whom are rookies, undrafted free agents or players who just don’t have much experience.</p><p class=gnt_ar_b_p>LaFleur referred to it as “all hands on deck,” so there’s a possibility more veterans will be used.</p><p class=gnt_ar_b_p>“Me, I’m out there, whatever they need me to do,” said safety Adrian Amos, one of the team’s surest tacklers who serves only on punt coverage. “I’ve played all of it, played all over different special teams. It’s a new season once you get into the playoffs.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>“(If it’s) what we have to do to win this game; whatever they ask of anyone, they should be ready to do.”</p><h3 class=gnt_ar_b_h2>Tonyan reflects on record</h3><p class=gnt_ar_b_p>After Robert Tonyan caught his ninth touchdown this season at Detroit last month, the record was first broached.</p><p class=gnt_ar_b_p>Tonyan was sitting in the back of the Packers' team bus with Aaron Rodgers and Davante Adams as the team pulled away from Ford Field. To that point, Tonyan knew he was having a special season. He'd already surpassed his mild expectations of simply establishing a role for himself in the Packers' offense.</p><p class=gnt_ar_b_p>But there was something else Tonyan was now within range of obtaining. Since 1983, Paul Coffman's 11 touchdown catches had stood as the most by a Packers tight end in team history.</p><p class=gnt_ar_b_p>"After the Detroit game," Tonyan said, "me, Tae and Aaron were talking in the back of the bus about the record, just because it popped up on social media. Obviously, JO (tight ends coach Justin Outten) was all about it because the tight end room, he loves the numbers in the tight end room and stats about us."</p><p class=gnt_ar_b_p>It took a few week (and his 10th touchdown in Week 15 against the Carolina Panthers), but Tonyan tied Coffman's record in the Packers' finale at Chicago. His 3-yard touchdown catch from Rodgers pulled the Packers even at 7 against the Bears.</p><p class=gnt_ar_b_p>He had history, but Tonyan was momentarily unaware.</p><p class=gnt_ar_b_p>"When I caught it," Tonyan said, "I totally forgot about it. I was running off the field, and I was on field goal. I spiked (the football), and Aaron Jones gave me the ball. I'm running off the field, and I forgot I was on field goal, and they're telling me to get on field goal. I just hand the ball to Davante, and he's like, I need one more to break the record.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-5 class="gnt_x_sl gnt_x_al"></div></aside><ul class=gnt_ar_b_ul><li class=gnt_ar_b_ul_li><strong>RELATED</strong>: <a href=/story/spoarts/nfl/packers/2021/01/13/green-bay-packers-oozing-confidence-despite-past-disappointments/6640066002/ target=_blank rel=noopener data-t-l=|inline|intext|n/a class=gnt_ar_b_a>Packers oozing with confidence despite past playoff pitfalls</a></li><li class=gnt_ar_b_ul_li><strong>DOUGHERTY</strong>: <a href=/story/sports/nfl/packers/dougherty/2021/01/12/green-bay-packers-must-keep-rams-aaron-donald-disrupting-offense/6626616002/ target=_blank rel=noopener data-t-l=|inline|intext|n/a class=gnt_ar_b_a>Packers must keep Aaron Donald from disrupting offense</a></li><li class=gnt_ar_b_ul_li><strong>RELATED</strong>: <a href=/story/sports/nfl/packers/2021/01/11/green-bay-packers-open-playoffs-against-banged-up-rams/6597796002/ target=_blank rel=noopener data-t-l=|inline|intext|n/a class=gnt_ar_b_a>What you need to know about the Rams</a></li><li class=gnt_ar_b_ul_li><strong>GREEN 19 PODCAST</strong>: <a href=/story/sports/nfl/packers/2021/01/11/green-bay-packers-podcast-breaking-down-packers-playoff-opener/6624787002/ target=_blank rel=noopener data-t-l=|inline|intext|n/a class=gnt_ar_b_a>Breaking down the Packers' playoff opener</a></li></ul><p class=gnt_ar_b_p>"And I'm like, 'Oh, I totally even forgot about that.' Like, once you go into game time –well, for me at least – once you go into game time, my mental is just so clear, and I'm just out there having such a good time, I'm really not even worrying about whatever is in the locker room, whatever is outside the field. Once I get on there, I kind of just black out everything else and just kind of enjoy just being out there and soak it all in and just be grateful to be a part of something great."</p><p class=gnt_ar_b_p>Even if Tonyan was unaware in the moment, he said tying the franchise record was special to him. It's the most tangible acknowledgment of his special season as being overlooked for the Pro Bowl despite 52 catches for 586 yards and the 11 touchdowns.</p><p class=gnt_ar_b_p>"It is an honor," Tonyan said. "I mean, when you see the G, all the Gs are out, you think of the history of the NFL, you think of basically where the NFL started, to be at the top of the list and sharing it with a great, it's really remarkable."</p><h3 class=gnt_ar_b_h2>Clark excited to see Donald</h3><p class=gnt_ar_b_p>Kenny Clark won't be on the field at the same time as Aaron Donald this week, but he isn't shying away from the matchup.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-6 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Clark, whose four-year, $70 million extension before this season made him the highest-paid nose guard in NFL history, said he's excited to see the Rams' six-time All-Pro and future Hall of Famer up close this week.</p><p class=gnt_ar_b_p>"I think anytime you've got a player like that on the other side of the ball," Clark said, "you always get excited. You get excited to have a chance to watch him play, and you get a chance to go out there and play your best game. Me and him are not playing against each other or anything like that, but definitely you get excited about being on the other side of the field and playing ball."</p><p class=gnt_ar_b_p>Clark, like everyone on the Packers, has heard all about Donald this week. He said the attention and praise given to one of the league's top players provided no extra motivation.</p><p class=gnt_ar_b_p>"You've got to give them their respect," Clark said. "I mean, he's a great player. He's a guy that they're going to key on, and everybody knows he's a great player. I don't get hyped or nothing because of that. It is what it is."</p><aside class="gnt_em gnt_em_ifg" data-g-r=lazy data-gl-method=loadInfogram data-v-id=5de5a3e9-0d1d-433b-823d-0e4afa3d2e0d aria-label="Embedded infographic - NFL playoffs schedule" data-t-l=${tc}|inlineOEmbeds|open|infogram><a class=gnt_em_ifg_ph href=https://infogram.com/5de5a3e9-0d1d-433b-823d-0e4afa3d2e0d aria-label="Infographic in fullscreen - NFL playoffs schedule" target=_blank rel="nofollow noopener"></a></aside><aside class="gnt_em gnt_em_hf gnt_em__lp" data-g-r=lazy data-gl-type=method data-gl-method=loadHb64 aria-label=PackersNews data-t-l=${tc}|inlineOEmbeds|open|hb64 data-gl-hb64="PGRpdiBhbGlnbj0ibGVmdCIgc3R5bGU9ImJvcmRlci10b3A6MnB4IHNvbGlkICMwRDcwM0Y7IGJvcmRlci1ib3R0b206MnB4IHNvbGlkICMwRDcwM0Y7IHBhZGRpbmc6MTBweDsiPgoJPHA+CgkJPHN0cm9uZz5PdXIgc3Vic2NyaWJlcnMgbWFrZSB0aGlzIGNvdmVyYWdlIHBvc3NpYmxlLiBDbGljayB0byBzdWJzY3JpYmUgdG8gUGFja2VycyBOZXdzIGF0IDxhIGhyZWY9Imh0dHBzOi8vY20ucGFja2Vyc25ld3MuY29tL3NwZWNpYWxvZmZlcj9ncHMtc291cmNlPUNQTkVXUyZhbXA7aXRtX21lZGl1bT1vbnNpdGUmYW1wO2l0bV9zb3VyY2U9bmV3cyZhbXA7aXRtX2NhbXBhaWduPU5FV1NST09NJmFtcDtpdG1fY29udGVudD1DUE5FV1MiPnBhY2tlcnNuZXdzLmNvbS9zdWJzY3JpYmUuPC9hPiBPciBjbGljayB0byBzdWJzY3JpYmUgdG88YSBocmVmPSJodHRwczovL29mZmVycy51c2F0b2RheW5ldHdvcmsuY29tL25ldHdvcmstcmVnaW9uYWwtd2lzY29uc2luICI+IG9uZSBvZiBvdXIgbG9jYWwgV2lzY29uc2luIG5ld3Mgc2l0ZXMsPC9hPiB3aGljaCBpbmNsdWRlcyBQYWNrZXJzTmV3cyBjb3ZlcmFnZS4gQmUgc3VyZSB0byBkb3dubG9hZCBvdXIgYXBwIG9uIDxhIGhyZWY9Imh0dHBzOi8vYXBwcy5hcHBsZS5jb20vdXMvYXBwL3BhY2tlcm5ld3MtY29tLXBhY2tlcnMteHRyYS9pZDkwODgzMzU3MyI+aVR1bmVzPC9hPiBvciA8YSBocmVmPSJodHRwczovL3BsYXkuZ29vZ2xlLmNvbS9zdG9yZS9hcHBzL2RldGFpbHM/aWQ9Y29tLmdhbm5ldHQuZG9sbHkuUGFja2VycyZhbXA7aGw9ZW4iPkdvb2dsZSBQbGF5LjwvYT4KPC9zdHJvbmc+PC9wPgoKPC9kaXY+Cgo8ZGl2IHN0eWxlPSJjbGVhcjogYm90aDsiPjwvZGl2PjwvZGl2Pg=="></aside></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.packersnews.com/story/sports/nfl/packers/2021/01/14/green-bay-packers-erratic-special-teams-could-get-boost/4145098001/ data-ss-t="'All hands on deck' approach could boost Packers' erratic special teams" data-ss-d="No one with the Green Bay Packers may be feeling more pressure heading into the playoffs than special teams coach Shawn Mennenga."><a class=gnt_ss_cm href="https://cm.packersnews.com/comment/?storyUrl=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&marketName=packersnews&commentsopen=false" rel=nofollow data-t-l=|open|commentsopen>View Comments</a> <a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=249896938457153&href=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-bottom|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&text='All%20hands%20on%20deck'%20approach%20could%20boost%20Packers'%20erratic%20special%20teams&via=PGpackersnews" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-bottom|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject='All%20hands%20on%20deck'%20approach%20could%20boost%20Packers'%20erratic%20special%20teams%20-%20from%20Packers%20News&body='All%20hands%20on%20deck'%20approach%20could%20boost%20Packers'%20erratic%20special%20teams%0A%0ANo%20one%20with%20the%20Green%20Bay%20Packers%20may%20be%20feeling%20more%20pressure%20heading%20into%20the%20playoffs%20than%20special%20teams%20coach%20Shawn%20Mennenga.%0A%0ACheck%20out%20this%20story%20on%20packersnews.com%3A%20https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" data-t-l=${tc}|navbar-share-bottom|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-bottom|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-wi-greenbay-packersnews-C1014-poster-sports-football-nfl-7 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=${tc}|rightRailTaboolaRecirc|click><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.packersnews.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&marketName=packersnews&cta=Right-Rail" class=gnt_m_fs_a data-t-l=${tc}survey_click_story aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-poster_scroll-sports-football-nfl-8 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/sports/ data-t-l=|modalclose|x aria-label=Close></a></div></main></div><aside class=gnt_pm onmousedown=event.stopPropagation() onmouseup=event.stopPropagation() data-u-sr="anon reg" aria-label="free articles left. - Happy news year. $3 for 3 months. Save 90%." data-g-r=base_ex><button class=gnt_pm_eb data-g-r=base_et aria-expanded=false aria-label="Special offer"></button><div class="gnt_pm_ms gnt_pm__de"></div><a class="gnt_pm_a gnt_pm__de" href="https://subscribe.packersnews.com/?return-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&cancel-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&success-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&itm_medium=ONSITE&gps-source=CPCAMBARD&itm_source=CPCAMBARD&itm_content=freearticlesleft&itm_campaign=2021NEWYEAR" aria-label="Subscribe Now" tabindex=0></a></aside><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-wi-greenbay-packersnews-C1014-leaderboard_btf-sports-football-nfl-9 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Packers News - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=|footer|about|careers>Careers</a> <a href=https://cm.packersnews.com/accessibility class=gnt_ft_a data-t-l=|footer|about|accessibility>Accessibility Support</a> <a href=/sitemap/ class=gnt_ft_a data-t-l=|footer|about|site-map>Site Map</a> <a href=https://cm.packersnews.com/ethical-conduct class=gnt_ft_a data-t-l=|footer|about|our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.packersnews.com/terms class=gnt_ft_a data-t-l=|footer|about|terms-of-service>Terms of Service</a> <a href=https://cm.packersnews.com/privacy class=gnt_ft_a data-t-l=|footer|about|privacy-policy>Privacy Policy</a> <a href=https://cm.packersnews.com/privacy-policy/ class=gnt_ft_a data-t-l=|footer|about|california-privacy-rights>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=${tc}|footer|about|cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.packersnews.com/contact-us class=gnt_ft_a data-t-l=|footer|support|contact-us>Contact Us</a> <a href=https://localiq.com/markets/Wisconsin/ class=gnt_ft_a data-t-l=|footer|support|advertise>Advertise Your Business</a> <a href=https://cm.packersnews.com/advertising-terms-conditions class=gnt_ft_a data-t-l=|footer|support|advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://help.packersnews.com/ class=gnt_ft_a data-t-l=|footer|support|help-center>Help Center</a> <a href=https://account.packersnews.com/ class=gnt_ft_a data-t-l=|footer|support|my-account>My Account</a> <a href=https://cm.hawkcentral.com/site-feedback/ class=gnt_ft_a data-t-l=|footer|support|feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.packersnews.com/ class=gnt_ft_a data-t-l=|footer|stay-connected|subscribe-today>Subscribe Today</a> <a href=https://profile.packersnews.com/newsletters/manage class=gnt_ft_a data-t-l=|footer|stay-connected|newsletters>Newsletters</a> <a href=https://www.facebook.com/packersnews class=gnt_ft_a data-t-l=|footer|stay-connected|facebook>Facebook</a> <a href=https://twitter.com/PGPackersNews class=gnt_ft_a data-t-l=|footer|stay-connected|twitter>Twitter</a> <a href=http://static.packersnews.com/rss/ class=gnt_ft_a data-t-l=|footer|stay-connected|rss-feeds>RSS Feeds</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.packersnews.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3b9875847.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z31af45492.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}|H1Nav|search| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=navus><div class=gnt_n_us_dd data-g-r=nav_dd><div class=gnt_n_us_dd_u><a class=gnt_n_us_dd_a href=https://account.packersnews.com/ data-t-l="|H1Nav|account|manage account">Manage Account</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://user.packersnews.com/user/enewspaper data-t-l=|H1Nav|account|e-edition>E-Edition</a> <a class=gnt_n_us_dd_a href=https://profile.packersnews.com/newsletters/manage/ data-t-l=|H1Nav|account|newsletters>Newsletters</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.packersnews.com/pay data-t-l="|H1Nav|account|pay bill">Pay Bill</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.packersnews.com/delivery-issue data-t-l="|H1Nav|account|report delivery issues">Report Delivery Issues</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.packersnews.com/delivery-temporary-stop data-t-l="|H1Nav|account|pause delivery">Pause Delivery</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://cm.packersnews.com/subscriberguide data-t-l="|H1NavTree|account|subscriber guide">Subscriber Guide</a> <a class=gnt_n_us_dd_a href=https://help.packersnews.com data-t-l="|H1Nav|account|help center">Help Center</a> <a class="gnt_n_us_dd_a gnt_n_us_dd_a__li" data-u-sr="reg sub" href="https://user.packersnews.com/PPAN-GUP/user/logout/?return-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" data-t-l="|H1Nav|account|sign out">Sign Out</a></div><div class=gnt_n_us_dd_ac data-u-sr="anon reg"><div class=gnt_n_us_dd_lbl data-u-sr=anon>Have an existing account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_ba__hl" data-u-sr=anon rel=nofollow href="https://login.packersnews.com/PPAN-GUP/authenticate?success-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F&cancel-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2021%2F01%2F14%2Fgreen-bay-packers-erratic-special-teams-could-get-boost%2F4145098001%2F" data-t-l="|H1Nav|account|sign in">Sign In</a><div class=gnt_n_us_dd_lbl>Already have a subscription?</div><a class=gnt_n_us_dd_ba rel=nofollow href=https://cm.packersnews.com/account-activation/ data-t-l="|H1Nav|account|activate account">Activate account</a><div class=gnt_n_us_dd_lbl data-u-sr=anon>Don't have an account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_a__li" data-u-sr=anon rel=nofollow href="https://login.packersnews.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux" data-t-l="|H1Nav|account|create account">Create account</a></div></div>|styles|.gnt_n_us_a_w{position:relative}.gnt_n_us_dd{display:none;position:absolute;top:28px;right:25px;padding:14px 0 14px 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_us_dd{display:flex}.gnt_n_us_dd_u{display:flex;flex-direction:column;min-width:165px;padding-right:15px}.gnt_n_us_dd_a{margin:3px auto 4px 3px;padding:0 2px;color:#fff;font:700 14px/18px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;white-space:nowrap}.gnt_n_us_dd_a:hover{color:#e0e0e0}.gnt_n_us_dd_ac{padding:0 15px 0 19px;border-left:1px solid #626262}.gnt_n_us_dd_lbl{margin:5px 0 0;color:#fff;font:700 12px/16px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_us_dd_ba{display:block;width:192px;margin:3px 0 19px;padding:9px 1px 8px;border:3px solid #1665cf;outline-offset:-1px;color:#fff;font:700 14px/17px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_n_us_dd_ba__hl{padding:12px 4px 11px!important;border:0!important;background:var(--gnt-bc,#1665cf)}.gnt_n_us_dd_ba:hover{padding:8px 0 7px;border-width:4px;--gnt-bc:#0A32A0}.gnt_n_us_dd_a__li{margin-bottom:6px}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3v3Tz7fzU5siVWhpYN1YJuJvfz70.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"'All hands on deck' approach could boost Packers' erratic special teams","description":"No one with the Green Bay Packers may be feeling more pressure heading into the playoffs than special teams coach Shawn Mennenga.","url":"https://www.packersnews.com/story/sports/nfl/packers/2021/01/14/green-bay-packers-erratic-special-teams-could-get-boost/4145098001/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.packersnews.com/story/sports/nfl/packers/2021/01/14/green-bay-packers-erratic-special-teams-could-get-boost/4145098001/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2020/08/24/PPAN/e91f4f07-e1cf-4cc7-a44b-282c50c7d219-packers25_14_hoffman.jpg?crop=3250,3250,x740,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/08/24/PPAN/e91f4f07-e1cf-4cc7-a44b-282c50c7d219-packers25_14_hoffman.jpg?crop=4935,2776,x0,y0&width=1600&height=800&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-01-14T00:48:59Z","dateCreated":"2021-01-14T00:48:59Z","dateModified":"2021-01-14T00:48:59Z","articleSection":"sports","publisher":{"@type":"Organization","name":"Packers News","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/packersnews/images/site-nav-logo@2x.png"}},"author":["Tom Silverstein","Ryan Wood","Olivia Reiner"],"keywords":["access:metered","ssts:sports:nfl:packers","type:story","tag:Green Bay Packers","tag:National Sports","tag:Passivity","tag:Overall Negative","tag:sport","tag:American football","tag:NFL"],"isAccessibleForFree":false,"isPartOf":{"@type":["CreativeWork","Product"],"name":"Packers News - Unlimited Digital Access","productID":"packersnews.com:standard"},"metadata":"{\"id\":\"4145098001\",\"siteCode\":\"PPAN\",\"contentSourceCode\":\"PPAN\",\"ssts\":\"sports:nfl:packers\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"VideoObject","name":"Who might start at Quarterback for the Rams","description":"Both Jared Goff and John Wolford are both injured, LeRoy gives his opinion on who he thinks will start. Bill Schulz, Packers News","thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/01/12/PPAN/dc7207bc-fdc1-43e1-aef5-68d782ec2001-ed7172fd-55b4-402e-b169-1cc5a460a62b_thumbnail.png?width=1280&height=720&fit=crop&format=pjpg&auto=webp","uploadDate":"2021-01-14T00:48:58Z"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/08/24/PPAN/e91f4f07-e1cf-4cc7-a44b-282c50c7d219-packers25_14_hoffman.jpg","caption":"Packers special teams coordinator Shawn Mennenga has been taking some heat this season.","copyrightHolder":"Mark Hoffman/Milwaukee Journal Sentinel"}]</script></body></html>