<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Green Bay Packers' history with two first-round picks in NFL draft</title><meta property=og:title content="The Green Bay Packers have two first-round picks in the 2022 NFL draft. It's happened before, and here's how it worked out"/><link rel=amphtml href=https://amp.packersnews.com/amp/7412482001 /><meta property=article:author content="Mike Hart"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.packersnews.com /><link rel=preconnect href=https://user.packersnews.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//c2shb.pubgw.yahoo.com /><link rel=preconnect href=https://c2shb.pubgw.yahoo.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//grid.bidswitch.net /><link rel=preconnect href=https://grid.bidswitch.net /><link rel=dns-prefetch href=//ads.yieldmo.com /><link rel=preconnect href=https://ads.yieldmo.com /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=dns-prefetch href=//prebid-server.rubiconproject.com /><link rel=preconnect href=https://prebid-server.rubiconproject.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.packersnews.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.packersnews.com/PPAN-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z3e98867c1.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z31ec2eabf.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-a6bac614.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-4cfe2242.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-7c1087cd.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-9e946b2b.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-04455b51.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-40451b24.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/d805efa1-97b0-4d7d-873e-1bb36e8ef10a/e4fcaaf8-40f2-4268-9b66-364cd826a6cd/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=7443697001" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="The Green Bay Packers have had two first round draft picks several times and not all of them panned out."/><meta property=og:description content="The Green Bay Packers have had two first round draft picks several times and not all of them panned out."/><meta property=fb:pages content=338437548341 /><meta property=fb:app_id content=249896938457153 /><link rel=canonical href=https://www.packersnews.com/story/sports/nfl/packers/2022/04/25/green-bay-packers-history-two-first-round-picks-nfl-draft/7412482001/ /><meta property=og:url content=https://www.packersnews.com/story/sports/nfl/packers/2022/04/25/green-bay-packers-history-two-first-round-picks-nfl-draft/7412482001/ /><meta property=og:site_name content="Packers News"/><meta property=og:image content="https://www.gannett-cdn.com/-mm-/27a3397ea6c2e64f62eab68dbb9e27ab9e079ee9/c=0-1051-3246-2885/local/-/media/2019/02/08/WIGroup/PackersNews/636852497966962992-uscp-72cf5y259814ypbkinx-original.jpg?width=3200&height=1809&fit=crop&format=pjpg&auto=webp"/><meta property=og:image:width content=3200 /><meta property=og:image:height content=1809 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/-mm-/27a3397ea6c2e64f62eab68dbb9e27ab9e079ee9/c=0-1051-3246-2885/local/-/media/2019/02/08/WIGroup/PackersNews/636852497966962992-uscp-72cf5y259814ypbkinx-original.jpg?width=1600&height=800&fit=crop&format=pjpg&auto=webp"/><meta name=twitter:site content=@PGpackersnews /><meta name=twitter:creator content=@PGpackersnews /><meta name=twitter:title content="The Green Bay Packers have two first-round picks in the 2022 NFL draft. It's happened before, and here's how it worked out"/><meta name=twitter:description content="The Green Bay Packers have had two first round draft picks several times and not all of them panned out."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol><symbol id=gnt_svg_camera viewBox="0 0 24 24"><path d="M7 12.8a5 5 0 1 0 10 0 5 5 0 0 0-10 0zm9.33-6.02H20c1.1 0 2 .92 2 2.06v8.6c0 1.13-.9 2.06-2 2.06H4c-1.1 0-2-.93-2-2.07V8.84c0-1.14.9-2.06 2-2.06l3.67-.01c0-1.15.9-2.27 2-2.27h4.66c1.1 0 2 1.12 2 2.28zM12 16.8a4 4 0 1 1 0-8 4 4 0 0 1 0 8z"/></symbol><symbol id=gnt_svg_expand viewBox="0 0 24 24"><path d="M5 14v3.586l3.3-3.3L9.714 15.7l-3.3 3.3H10v2H3v-7zm16 0v7h-7v-2h3.586l-3.3-3.3 1.414-1.414 3.3 3.3V14zM10 3v2H6.414l3.3 3.3L8.3 9.714 5 6.414V10H3V3zm11 0v7h-2V6.414l-3.3 3.3L14.286 8.3l3.3-3.3H14V3z"/></symbol><symbol id=gnt_svg_sharelink viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#fff)><path d="M13.8625 8.5525c.3162.1924.615.424.8878.6972 1.8488 1.8486 1.849 4.857 0 6.7057l-3.6575 3.6578c-1.8488 1.849-4.8573 1.849-6.706 0-1.849-1.8488-1.849-4.8572 0-6.706l2.5346-2.5347c-.1966 1.1006-.0742 2.247.3688 3.2892l-1.0747 1.0745c-.8404.8404-.8404 2.2078 0 3.0482.8403.8404 2.2077.8404 3.0481 0l3.658-3.6578c.8404-.8403.8404-2.2077 0-3.0481a2.1379 2.1379 0 00-1.0172-.5676zm-.9551-4.1655c1.8487-1.8492 4.857-1.8492 6.7059 0 1.849 1.8486 1.849 4.8571 0 6.7057l-2.5346 2.535c.1964-1.1006.074-2.2468-.3688-3.289l1.0746-1.0748c.8404-.8404.8404-2.2078 0-3.0481-.8402-.8404-2.2078-.8404-3.0482 0l-3.6577 3.6577c-.8404.8402-.8404 2.2078 0 3.0482a2.136 2.136 0 001.0172.5676l-1.9582 1.9583a4.7251 4.7251 0 01-.888-.6972c-1.849-1.8485-1.849-4.8571 0-6.7057z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Packers News" data-t-l=:n|v|c|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#303030 preserveAspectRatio="xMinYMid meet" viewBox="0 0 278.93 22.88"><path d="M17.25 8.24C17.25 3.86 14 .55 8.31.55H0v21.91h6.28v-6.55h1.99c5.67 0 8.98-3.29 8.98-7.67zm-9.96 2.65H6.28V5.55h1.06c2.37 0 3.45.84 3.45 2.69s-1.06 2.67-3.43 2.67l-.07-.02zM22.45.55l-8.17 21.91h6.37l1-3.15h8.29l1.04 3.15h6.53L29.34.55h-6.89zm.84 13.78l1.69-5.28c.35-1.07.6-2.17.76-3.29h.16c.16 1.12.41 2.22.76 3.29l1.69 5.28h-5.06zm19.22-2.8a5.42 5.42 0 015.76-5.98c1.71-.03 3.39.5 4.78 1.49V1.27A10.59 10.59 0 0047.81.11a10.99 10.99 0 00-11.74 11.41A10.9 10.9 0 0047.8 22.93c1.91.06 3.81-.33 5.54-1.16v-5.82a7.77 7.77 0 01-5.06 1.49 5.4 5.4 0 01-5.77-5.91zM75.7.55h-7.09l-6.85 9.86V.55h-6.22v21.91h6.22V12.08l6.69 10.42h7.69l-7.75-11.28L75.7.55zm7.29 13.23h6.91V8.8h-6.87V5.55h7.03v-5H76.73v21.91h13.61V17.5h-7.31l-.04-3.72zm27.09-5.84c0-5.28-3.98-7.37-8.61-7.37h-9.04v21.91h6.28v-7.43h.9l4.6 7.43h7.13l-5.7-8.51a6.51 6.51 0 004.48-6.04l-.04.01zm-9.6 2.37h-1.81V5.55h1.81c2.09 0 3.15.82 3.15 2.37s-1 2.39-3.11 2.39h-.04zm21.04-1.53c-1.81-.56-3.47-.94-3.47-2.31 0-.88.7-1.53 2.31-1.53 1.66.01 3.24.74 4.32 1.99l2.85-4.18a10.72 10.72 0 00-7.47-2.53c-4.82 0-8.23 2.79-8.23 6.93 0 3.78 2.81 5.44 5.98 6.41 2.37.72 3.78 1.16 3.78 2.69s-.98 1.99-2.59 1.99a6.95 6.95 0 01-5.06-2.73l-3.03 4.18a11.96 11.96 0 008.51 3.19c5.48 0 8.51-3.15 8.51-7.37s-2.77-5.62-6.41-6.73zm24.32.33c-.02 1.56.04 3.11.18 4.66h-.12a25.15 25.15 0 00-2.63-3.98L135.9.51h-5.64v21.91h5.98v-8.57c.02-1.56-.04-3.11-.18-4.66h.12a25.15 25.15 0 002.63 3.98l7.37 9.28h5.72V.55h-5.98l-.08 8.56zm15.7 4.67h6.91V8.8h-6.83V5.55h7.03v-5h-13.27v21.91h13.55V17.5h-7.31l-.08-3.72zM196.9.55l-2.59 8.98c-.53 1.73-.89 3.5-1.08 5.3h-.18c-.18-1.8-.53-3.57-1.06-5.3L189.24.55h-5.64l-2.65 8.98a27.91 27.91 0 00-1.06 5.28h-.18a27.96 27.96 0 00-1.08-5.28l-2.65-9h-6.37l6.97 21.91h5.98l2.69-8.92c.52-1.72.88-3.49 1.06-5.28h.18c.16 1.79.49 3.56 1 5.28l2.65 9h5.98L203.09.61 196.9.55zm16.25 8.23c-1.81-.56-3.47-.94-3.47-2.31 0-.88.7-1.53 2.31-1.53 1.66.01 3.24.74 4.32 1.99l2.85-4.18a10.72 10.72 0 00-7.47-2.53c-4.82 0-8.23 2.79-8.23 6.93 0 3.78 2.81 5.44 5.98 6.41 2.37.72 3.78 1.16 3.78 2.69s-.98 1.99-2.59 1.99a6.94 6.94 0 01-5.18-2.73l-3.03 4.18a11.96 11.96 0 008.51 3.19c5.48 0 8.51-3.15 8.51-7.37s-2.76-5.62-6.29-6.73zm9.16 9.96a1.99 1.99 0 100 3.98 1.99 1.99 0 000-3.98h-.04.04zm5.26-3.99a5.28 5.28 0 014.99-5.55l.41-.01a5.73 5.73 0 013.51 1.06V7.54a7.72 7.72 0 00-3.63-.78 8.1 8.1 0 000 16.2c1.3.02 2.58-.27 3.75-.84v-2.91a5.72 5.72 0 01-3.57 1.12 5.27 5.27 0 01-5.5-5.56l.04-.02zm17.93-8.09a8.1 8.1 0 108.25 8.1 7.96 7.96 0 00-7.86-8.07h-.34l-.05-.03zm0 13.69a5.27 5.27 0 01-5.29-5.27l.01-.33a5.3 5.3 0 1110.56 0 5.28 5.28 0 01-4.93 5.61l-.31.01-.04-.02zm27.57-13.69a5.72 5.72 0 00-5.38 2.97 5.15 5.15 0 00-5.06-2.97 5.31 5.31 0 00-4.76 2.43V7.1h-2.89v15.44h2.97v-8.82c0-2.91 1.49-4.6 3.98-4.6s3.53 1.59 3.53 4.5v8.88h2.97v-8.79c0-2.91 1.49-4.6 3.98-4.6s3.57 1.59 3.57 4.5v8.88h2.91v-9.42c0-4.06-2.13-6.39-5.78-6.39l-.04-.02z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.packersnews.com/nanobar?gps-source=CPTILELEFT&itm_campaign=PACKERSNEWS&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}99¢ for the first month" elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.packersnews.com/masthead?gps-source=CPMASTHEAD&itm_campaign=PACKERSNEWS&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|${m}99¢ for the first month" elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/fans/ data-t-l=:n|v|c|fans elementtiming=nav-item>Fans</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=http://www.greenbaypressgazette.com/ data-t-l=:n|v|c|green-bay-press-gazette>Green Bay Press-Gazette</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=http://www.jsonline.com/ data-t-l=:n|v|c|milwaukee-journal-sentinel>Milwaukee Journal Sentinel</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatodaysportsplus.com/ data-t-l=:n|v|c|usa-today-sports-plus>USA TODAY Sports+</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Green Bay" title="Weather in Green Bay" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb aria-label=Subscribe href="https://subscribe.packersnews.com/navsub?gps-source=CPTOPNAVBAR&itm_campaign=PACKERSNEWS&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt></a><div class=gnt_n_us_a_w data-g-r=nav_ce><a class="gnt_n_us_a gnt_n_mn_ce" href="https://login.packersnews.com/PPAN-GUP/authenticate?success-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F&cancel-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-g-r=nav_ab data-g-tn=navus data-t-l=":m|a|g|sign in / salutation" aria-label="Sign In" aria-haspopup=true aria-expanded=false><svg class=gnt_n_us_a_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></a></div><gnt-upn></gnt-upn></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-wi-greenbay-packersnews-C1014-high_impact-sports-football-nfl-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/sports/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/sports/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl><a class=gnt_ar_lbl_a data-t-l=":section label|v|c|packers" href=/columns/ >PACKERS</a></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>The Green Bay Packers have two first-round picks in the 2022 NFL draft. It's happened before, and here's how it worked out</h1><div class=gnt_ar_by><a href=https://www.jsonline.com/staff/2646896001/mike-hart/ data-t-l=":byline with photo|o|c|text" class="gnt_ar_by_a gnt_ar_by_a__fi"><img class=gnt_ar_by_i src="https://www.gannett-cdn.com/presto/2019/12/11/PMJS/b27452d5-9e47-4d89-876f-126bf91f4b50-MJS_Mike_Hart_-_Employee.jpg?crop=286,286,x104,y28&width=48&height=48&format=pjpg&auto=webp" srcset="https://www.gannett-cdn.com/presto/2019/12/11/PMJS/b27452d5-9e47-4d89-876f-126bf91f4b50-MJS_Mike_Hart_-_Employee.jpg?crop=286,286,x104,y28&width=96&height=96&format=pjpg&auto=webp 2x" decoding=async loading=eager alt="" data-t-l=":byline with photo|o|c|photo"/> Mike Hart</a><div class=gnt_ar_pb>Packers News</div></div><div class=gnt_ar_dt aria-label="Published 3:11 p.m. CT April 25, 2022"></div><div class="gnt_ss gnt_ss__cm__tp" data-g-r=base_sc data-ss-u=https://www.packersnews.com/story/sports/nfl/packers/2022/04/25/green-bay-packers-history-two-first-round-picks-nfl-draft/7412482001/ data-ss-t="The Green Bay Packers have two first-round picks in the 2022 NFL draft. It's happened before, and here's how it worked out" data-ss-d="The Green Bay Packers have had two first round draft picks several times and not all of them panned out."><a class="gnt_ss_cm gnt_ss_cm__a" href="https://cm.packersnews.com/comment/?storyUrl=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F&marketName=packersnews&commentsopen=false" rel=nofollow data-t-l=":coral comments|comment|c|view comments">View Comments</a><div class=gnt_ss_cm_w data-g-r=nav_ce onmousedown=event.stopPropagation() onmouseup=event.stopPropagation() data-g-ctl=":coral comments|comment|close|register to comment"><button class=gnt_ss_cm data-g-r="base_tload nav_ab" data-g-tn=tooltipcm_top aria-label="View comments" aria-expanded=false>View Comments</button></div><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=249896938457153&href=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F&text=The%20Green%20Bay%20Packers%20have%20two%20first-round%20picks%20in%20the%202022%20NFL%20draft.%20It's%20happened%20before%2C%20and%20here's%20how%20it%20worked%20out&via=PGpackersnews" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=The%20Green%20Bay%20Packers%20have%20two%20first-round%20picks%20in%20the%202022%20NFL%20draft.%20It's%20happened%20before%2C%20and%20here's%20how%20it%20worked%20out%20-%20from%20Packers%20News&body=The%20Green%20Bay%20Packers%20have%20two%20first-round%20picks%20in%20the%202022%20NFL%20draft.%20It's%20happened%20before%2C%20and%20here's%20how%20it%20worked%20out%0A%0AThe%20Green%20Bay%20Packers%20have%20had%20two%20first%20round%20draft%20picks%20several%20times%20and%20not%20all%20of%20them%20panned%20out.%0A%0ACheck%20out%20this%20story%20on%20packersnews.com%3A%20https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp" aria-label="Video - Little rugby player helps lift up his upset teammate with heartfelt pep talk"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;wi-greenbay-packersnews-C1014&#34;,&#34;pn&#34;:&#34;Packers News&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;news&#34;,&#34;byline&#34;:&#34;Damien Henderson&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;TMX&#34;,&#34;createDate&#34;:&#34;2022-04-25T18:52:51Z&#34;,&#34;credit&#34;:&#34;Damien Henderson, TMX Video&#34;,&#34;duration&#34;:32000,&#34;headline&#34;:&#34;Little rugby player helps lift up his upset teammate with heartfelt pep talk&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/d805efa1-97b0-4d7d-873e-1bb36e8ef10a/e4fcaaf8-40f2-4268-9b66-364cd826a6cd/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=7443697001&#34;,&#34;id&#34;:&#34;7443697001&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2022/04/25/USAT/0e7527c8-0861-4abe-a6f5-aec10f9d9ecc-pep_bug.png&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2022-04-25T18:52:51Z&#34;,&#34;keywords&#34;:&#34;Rugby,United Kingdom,Sports,Video Syndication - OTT Platforms,Video Syndication - USAT&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/d805efa1-97b0-4d7d-873e-1bb36e8ef10a/e4fcaaf8-40f2-4268-9b66-364cd826a6cd/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;TMX Video&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/news/2022/04/25/young-british-rugby-player-gives-his-upset-teammate-uplifting-pep-talk/7443697001/&#34;},&#34;promoBrief&#34;:&#34;A little boy on a rugby team in the United Kingdom saw his teammate upset and crying, so he offered him encouragement to get him back into the game.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2022-04-25T18:52:51Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;news&#34;,&#34;subsection&#34;:&#34;&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;92806fa1-2d7e-479f-baf2-977b4937fb0b&#34;,&#34;name&#34;:&#34;Rugby&#34;},{&#34;id&#34;:&#34;409db8ef-b67f-4e6e-b4eb-39ae410d1a4d&#34;,&#34;name&#34;:&#34;United Kingdom&#34;},{&#34;id&#34;:&#34;5db560e4-56d0-49e5-a654-1dbd85f01c90&#34;,&#34;name&#34;:&#34;Sports&#34;},{&#34;id&#34;:&#34;16fe9f9b-4247-4e2e-a73c-9fac5b14d01b&#34;,&#34;name&#34;:&#34;Video Syndication - OTT Platforms&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;}],&#34;title&#34;:&#34;Young British rugby player gives his upset teammate uplifting pep talk&#34;,&#34;url&#34;:&#34;/videos/news/2022/04/25/young-british-rugby-player-gives-his-upset-teammate-uplifting-pep-talk/7443697001/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player"><svg class=gnt_em_vp_db_svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2022/04/25/USAT/0e7527c8-0861-4abe-a6f5-aec10f9d9ecc-pep_bug.png?width=660&height=371&fit=crop&format=pjpg&auto=webp" headline="Little rugby player helps lift up his upset teammate with heartfelt pep talk" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><a class="gnt_em gnt_em__fp gnt_em_gl gnt_em__el" href=/picture-gallery/sports/nfl/packers/2022/04/25/photos-green-bay-packers-first-round-draft-picks-2000-2021/7442898001/ data-t-l=":l|l|c|view gallery:inline promo" aria-label="View Gallery - Here are the Green Bay Packers' first-round draft picks from 2000-2021" data-g-r=nav_mo data-g-tn=pgcss data-g-mtn=pg7442898001 data-g-moh=hpgm aria-haspopup=dialog aria-expanded=false onmousedown=event.stopPropagation() onmouseup=event.stopPropagation() data-c-id=7442898001><img class=gnt_em_gl_i src="https://www.gannett-cdn.com/presto/2021/12/26/PPAN/1bfb3421-1805-46e9-9fcc-33a36af9e4d0-packers26_12.jpg?crop=2886,1624,x0,y0&width=660&height=372&format=pjpg&auto=webp" elementtiming=ar-lead-image srcset="https://www.gannett-cdn.com/presto/2021/12/26/PPAN/1bfb3421-1805-46e9-9fcc-33a36af9e4d0-packers26_12.jpg?crop=2886,1624,x0,y0&width=1320&height=744&format=pjpg&auto=webp 2x" decoding=async alt="" width=660 height=372 /><div class=gnt_em_gl_i_nt></div><div class=gnt_em_gl_vg data-c-tc=22><svg class=gnt_em_gl_vg_svg__ca><use xlink:href=#gnt_svg_camera /></svg><svg class=gnt_em_gl_vg_svg><use xlink:href=#gnt_svg_expand /></svg></div><div class="gnt_em_t gnt_em_t__hb" data-c-et="Here are the Green Bay Packers' first-round draft picks from 2000-2021" aria-label="A look at each of the Green Bay Packers' first-round selections in the NFL draft going back to 2000."></div></a><p class=gnt_ar_b_p>Twice as nice?</p><p class=gnt_ar_b_p>Not all the time.</p><p class=gnt_ar_b_p>The Green Bay Packers have had two first-round draft picks several times, and not all of them panned out.</p><p class=gnt_ar_b_p>Let's review those picks since the dawn of the glory days.</p><p class=gnt_ar_b_p><strong class=gnt_ar_b_al>More:</strong><a href=/story/sports/nfl/packers/2022/04/25/who-green-bay-packers-took-22-28-past-nfl-draft-first-round-selections/7405043001/ target=_blank rel=noopener data-t-l=":b|e|spike click:5|${u}" class=gnt_ar_b_a>How have the Packers done picking at 22 and 28 in first round of the NFL draft? Here's a look</a></p><p class=gnt_ar_b_p><strong class=gnt_ar_b_al>More:</strong><a href=/story/sports/nfl/packers/2022/04/25/10-best-first-round-picks-packers-history-and-10-worst/7414312001/ target=_blank rel=noopener data-t-l=":b|e|spike click:6|${u}" class=gnt_ar_b_a>The 10 best first-round picks in Packers history (and the 10 worst)</a></p><h2 class=gnt_ar_b_h2>2019 Rashan Gary (12) and Darnell Savage Jr. (21)</h2><p class=gnt_ar_b_p>Gary, a linebacker from Michigan, is a rising NFL star. He blossomed last season with a career-high 9.5 sacks and 81 pressures, good for third in the league among edge rushers.</p><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:314px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/11/15/PPAN/0149e783-3b84-4a7a-9c70-aafe139f9208-packers15_17.jpg?width=300&height=314&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/11/15/PPAN/0149e783-3b84-4a7a-9c70-aafe139f9208-packers15_17.jpg?width=600&height=628&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Green Bay Packers outside linebacker Rashan Gary (52) sacks Seattle Seahawks quarterback Russell Wilson (3) during the first quarter of their game Sunday, November 14, 2021 at Lambeau Field in Green Bay, Wis. The Green Bay Packers beat the Seattle Seahawks 17-0."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Green Bay Packers outside linebacker Rashan Gary (52) sacks Seattle Seahawks quarterback Russell Wilson (3) during the first quarter of their game Sunday, November 14, 2021 at Lambeau Field in Green Bay, Wis. The Green Bay Packers beat the Seattle Seahawks 17-0." data-c-credit="MARK HOFFMAN/MILWAUKEE JOURNAL SENTINEL"></div></figure><p class=gnt_ar_b_p>Savage, a safety from Maryland, has flashed signs of potential stardom. He was named to the PFWA All-Rookie team honors in 2019 after starting all 14 games he appeared in and recording 61 tackles (41 solo), a tackle for a loss, a team-high two forced fumbles, two interceptions (tied for No. 2 on the team), seven passes defensed, a quarterback hit and two QB pressures. He intercepted two passes thrown by Mitchell Trubisky in a 41-25 victory over the Chicago Bears on "Sunday Night Football" in Week 12 in 2020. His six interceptions were the most by a Packers safety in their first two seasons since Tom Flynn (10) in 1984-'85. He had two interceptions last season.</p><h2 class=gnt_ar_b_h2>2009 B.J. Raji (ninth) and Clay Matthews (26th)</h2><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:404px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/02/15/PPAN/f1311943-f73f-45d8-92e6-97ad46588f05-MJS_packers07_spt_lynn_1Packers_packers07_2.JPG?width=660&height=404&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/02/15/PPAN/f1311943-f73f-45d8-92e6-97ad46588f05-MJS_packers07_spt_lynn_1Packers_packers07_2.JPG?width=1320&height=808&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Green Bay Packers nose tackle B.J. Raji (90) waits for the Pittsburgh Steelers to come to the line in the second half of Super Bowl XLV in Arlington, Texas on Sunday, Feb. 6, 2011."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Green Bay Packers nose tackle B.J. Raji (90) waits for the Pittsburgh Steelers to come to the line in the second half of Super Bowl XLV in Arlington, Texas on Sunday, Feb. 6, 2011." data-c-credit="Tom Lynn/Milwaukee Journal Sentinel"></div></figure><p class=gnt_ar_b_p>Raji, a defensive tackle from Boston College, quickly became the defensive anchor. The Packers began using Raji as an additional fullback in their goal line offense during the 2011 postseason. On January 23, 2011, in the fourth quarter of the NFC championship game at Soldier Field in Chicago, he intercepted a pass from Bears backup quarterback Caleb Hanie and returned it 18 yards to the end zone. The 337-pound Raji performed a memorable wiggle dance after the touchdown. The play broke William Perry's NFL record for the heaviest player to score a postseason touchdown. In 2016, Raji <a href=/story/sports/nfl/packers/insidersblog/2016/03/14/packers-bj-raji-retiring-football/81770768/ target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>announced his retirement</a> after seven seasons with the Packers.</p><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:400px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/-mm-/61eb5950ec8c8fbb14d7f0cc7fd94ae4dc2e9d18/c=0-0-2802-3736/local/-/media/2019/02/08/WIGroup/PackersNews/636852497966962992-uscp-72cf5y259814ypbkinx-original.jpg?width=300&height=400&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/-mm-/61eb5950ec8c8fbb14d7f0cc7fd94ae4dc2e9d18/c=0-0-2802-3736/local/-/media/2019/02/08/WIGroup/PackersNews/636852497966962992-uscp-72cf5y259814ypbkinx-original.jpg?width=600&height=800&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Linebacker Clay Matthews, who was drafted in the fisrt round in 2009, celebrated plenty of sacks with the Green Bay Packers."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Linebacker Clay Matthews, who was drafted in the fisrt round in 2009, celebrated plenty of sacks with the Green Bay Packers." data-c-credit="Dan Powers/USA TODAY NETWORK-Wis"></div></figure><p class=gnt_ar_b_p>Matthews, a linebacker from USC, quickly became a fan favorite because of his long locks and pass-rushing ability. Matthews recorded 10 sacks while playing outside linebacker in his rookie season. He topped that total in 2010 with 13.5 sacks, helping the Packers to their <a href=/in-depth/sports/nfl/packers/2021/02/19/super-bowl-xlv-oral-history-packers-learn-treasure-title/6781089002/ target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>Super Bowl XLV victory against the Pittsburgh Steelers</a>.</p><p class=gnt_ar_b_p>Matthews had at least six sacks in the first nine seasons he played. He played both inside and outside linebacker during the 2014 and 2015 seasons, and he became the Packers' all-time sacks leader when he sacked the Bears' quarterback Mike Glennon on Sept. 28, 2017. Matthews became an unrestricted free agent after the 2018 season and eventually signed with the Los Angeles Rams.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-2 class="gnt_x_sl gnt_x_al"></div></aside><h2 class=gnt_ar_b_h2>1993 Wayne Simmons (15th) and George Teague (29th)</h2><p class=gnt_ar_b_p>A linebacker from Clemson, Simmons was a key cog on Green Bay's 1996 Super Bowl team because of his ability to shut down opposing tight ends. But he fell out of favor fast. Simmons was traded to the Kansas City Chiefs during the 1997 season.</p><p class=gnt_ar_b_p>Teague, who was a safety from Alabama, made a splash as a rookie, starting the last 12 games of the season. In the playoffs against the Detroit Lions, he had the longest interception return for a touchdown in postseason history (101 yards). But he was hampered by a thyroid condition and was traded to Atlanta after the 1995 season.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-3 class="gnt_x_sl gnt_x_al"></div></aside><h2 class=gnt_ar_b_h2>1990 Tony Bennett (18th) and Darrell Thompson (19th)</h2><p class=gnt_ar_b_p>Bennett was a linebacker from Mississippi. He played four seasons with the Packers, recording a career-best 13.5 sacks in 1992. He was fourth on the Packers' all-time sacks list when he left for the Colts in free agency in 1993.</p><p class=gnt_ar_b_p>Thompson, a running back from Minnesota, was not known for his speed. He gained 1,640 yards rushing, 330 yards receiving, and scored eight touchdowns in five seasons.</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><h2 class=gnt_ar_b_h2>1980 Bruce Clark (fourth) and George Cumby (26th)</h2><p class=gnt_ar_b_p>Clark, a defensive tackle from Penn State, refused to play for the Packers and instead joined the Toronto Argonauts of the CFL. He spent two seasons there and ended up playing for the New Orleans Saints and Kansas City Chiefs.</p><aside class="gnt_em gnt_em_fo__bet-best" aria-label="Scores and odds from Tipico" data-g-r=lazy data-gl-type=comment><!--@pre<iframe class=gnt_em_fo_if src="/tangfrag/sports/gaming/bet-best?prm-embedded&prm-teamid=659&prm-gnteamid=17&prm-league=NFL#fhp-assetid=7412482001" loading=lazy sandbox="allow-scripts allow-popups allow-popups-to-escape-sandbox allow-forms" title="Scores and odds from Tipico"></iframe>--></aside><p class=gnt_ar_b_p>Cumby, who was a linebacker from Oklahoma, made second team all-pro in 1982. It was all downhill for Cumby in 1985.  When the Chicago Bears put rookie defensive tackle William "The Refrigerator" Perry in the offensive lineup during a "Monday Night Football" game against Green Bay, Perry twice flattened Cumby on lead blocks for Walter Payton. Later that season, Cumby was beaten on a short pass route by Perry that the "Fridge" carried into the end zone. Cumby was cut by the Packers the following preseason.</p><h2 class=gnt_ar_b_h2>1978 James Lofton (sixth) and John Anderson (26th)</h2><p class=gnt_ar_b_p>Lofton, a receiver out of Stanford, played in seven Pro Bowls in nine years with the Packers and left as the team's all-time leading receiver with 9,656 yards (since broken by Donald Driver). Things went south for Lofton in Green Bay when in 1986 he was charged with sexual assault after an incident in a Milwaukee bar. Though he was later acquitted, the Packers suspended Lofton with one game left in the season. They then traded him to the Los Angeles Raiders for a third-round draft pick in 1987 and a conditional fourth-round pick in 1988. Lofton went on to play for the Buffalo Bills, Los Angeles Rams and Philadelphia Eagles, and he was inducted into the Pro Football Hall of Fame in 2003.</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:373px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/-mm-/1d1fba38aaae9086e0541a2b25f5e0ea0585fc62/c=0-919-1694-1875/local/-/media/WIGroup/promo/2014/09/30/1412097586000-2636.jpg?width=660&height=373&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/-mm-/1d1fba38aaae9086e0541a2b25f5e0ea0585fc62/c=0-919-1694-1875/local/-/media/WIGroup/promo/2014/09/30/1412097586000-2636.jpg?width=1320&height=746&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Green Bay Packers receiver James Lofton (80) is congratulated by receiver John Jefferson after scoring a touchdown in the Packers' 41-16 victory over the St. Louis Cardinals in an NFC first-round playoff game at Lambeau Field on Jan. 8, 1983. That was the last game blacked out on local television."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Green Bay Packers receiver James Lofton (80) is congratulated by receiver John Jefferson after scoring a touchdown in the Packers' 41-16 victory over the St. Louis Cardinals in an NFC first-round playoff game at Lambeau Field on Jan. 8, 1983. That was the last game blacked out on local television." data-c-credit="File/Press-Gazette Media"></div></figure><p class=gnt_ar_b_p>Anderson, a Waukesha native who was a linebacker from Michigan, was selected as the Packers' most valuable defensive player three consecutive years. At the end of his career with the Packers, he was the team's all-time leader in tackles and was tied with Ray Nitschke for the Packers' career record in interceptions by a linebacker. Anderson was named a second-team player on the NFL 1980s All-Decade Team. He retired after 12 seasons with the Packers.</p><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:400px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/-mm-/ad57ea3bef4c7bfe4f5a2255a618b991a0849fa6/c=0-985-3150-5184/local/-/media/2015/09/22/WIGroup/PackersNews/635785309095574475--JP24380.jpg?width=300&height=400&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/-mm-/ad57ea3bef4c7bfe4f5a2255a618b991a0849fa6/c=0-985-3150-5184/local/-/media/2015/09/22/WIGroup/PackersNews/635785309095574475--JP24380.jpg?width=600&height=800&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Former Green Bay Packers linebacker John Anderson (1978-89) is introduced at halftime during alumni night events at the game against the Seattle Seahawks at Lambeau FIeld on Sunday, Sept. 20, 2015."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Former Green Bay Packers linebacker John Anderson (1978-89) is introduced at halftime during alumni night events at the game against the Seattle Seahawks at Lambeau FIeld on Sunday, Sept. 20, 2015." data-c-credit="Dan Powers/Gannett Wisconsin Media/@powrpics"></div></figure><h2 class=gnt_ar_b_h2>1977 Mike Butler (ninth) and Ezra Johnson (28th)</h2><p class=gnt_ar_b_p>Butler, who played defensive end at Kansas, had a seven-year career in Green Bay from 1977-'82 and 1985. He left the Packers after the 1982 season to play for the Tampa Bay Bandits of the USFL. After the USFL folded, he returned to Green Bay. But he injured his neck in the weight room and was released in 1986.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Johnson, a defensive end from Morris Brown, quickly became a star. Johnson earned a spot in the 1979 Pro Bowl after unofficially finishing second, to Detroit Lions Al "Bubba" Baker, with 20.5 sacks in 1978. He is also known for being fined $1,000 by coach Bart Starr for eating a hot dog on the sidelines during the fourth quarter of a 38-0 preseason loss to the Denver Broncos on Aug. 30, 1980 at Lambeau Field.</p><h2 class=gnt_ar_b_h2>1972 Willie Buchanon (seventh) and Jerry Tagge (11th)</h2><p class=gnt_ar_b_p>Buchanon, a cornerback from Arizona State, was the NFL’s defensive Rookie of the Year in 1972 and a Pro Bowl selection in 1974 and 1978. On Sept. 24, 1978, he intercepted four passes against the Chargers, running one back for a touchdown. That tied him for the still-standing NFL record for most interceptions in a game, first set by Sammy Baugh in 1943. The next week, his old Aztecs coach, Don Coryell, became head coach of the Chargers and subsequently traded for Buchanon.</p><p class=gnt_ar_b_p>Tagge, who went to high school at Green Bay West, was a star quarterback at Nebraska. He was also a big-time bust in the NFL. He managed three touchdown passes in 17 games and lasted three years with the Packers. He was cut by Bart Starr during the 1975 preseason.</p><h2 class=gnt_ar_b_h2>1970 Mike McCoy (second) and Rich McGeorge (16th)</h2><p class=gnt_ar_b_p>The Packers traded up with the Bears to grab McCoy, a defensive tackle from Notre Dame. That draft featured Terry Bradshaw (first) and a guy named Al Cowlings (fifth). </p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-5 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>McCoy led the Packers in sacks in 1973 and 1976. Bart Starr moved him to offensive guard in the 1977 preseason. That lasted two weeks and McCoy was dealt to Oakland. </p><p class=gnt_ar_b_p>McGeorge, a tight end from Elon, was the first tight end selected in the 1970 NFL Draft. He was picked ahead of Raymond Chester, Rich Caster and Stu Voigt. He played for the Packers until he retired following the 1978 season. </p><h2 class=gnt_ar_b_h2>1968: Fred Carr (fifth) and Bill Lueck (26th)</h2><p class=gnt_ar_b_p>Vince Lombardi thought Carr, a linebacker from UTEP, was the best player in the draft. Carr's professional career spanned 10 seasons, all with the Packers. He made the Pro Bowl three times.</p><p class=gnt_ar_b_p>Lueck, who played collegiately at Arizona, took over at right guard after Jerry Kramer retired following the 1968 season. The Packers traded Lueck to the Philadelphia Eagles in 1975. He played in eight games before injuring his knee. He retired before the 1976 season.</p><h2 class=gnt_ar_b_h2>1967: Bob Hyland (ninth) and Don Horn (25th)</h2><p class=gnt_ar_b_p>Hyland, a center from Boston College, played just three seasons with the Packers before he was traded to the Bears. His claim to fame at Lambeau Field took place while he was with the New York Giants in 1971. After an interception, Hyland barreled into Packers coach Dan Devine. The play resulted in Devine suffering a broken left leg.</p><p class=gnt_ar_b_p>As a side note, Hyland ran as the Republican candidate for mayor of White Plains, New York in 2011. He did not win.</p><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:400px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/-mm-/6212fb1a27c19cb5bfbe2f18cc57dceed523ca03/c=36-0-1233-1596/local/-/media/2017/04/05/PackersNews/B9327043765Z.1_20170405232044_000_GV7HV0U9G.1-0.jpg?width=300&height=400&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/-mm-/6212fb1a27c19cb5bfbe2f18cc57dceed523ca03/c=36-0-1233-1596/local/-/media/2017/04/05/PackersNews/B9327043765Z.1_20170405232044_000_GV7HV0U9G.1-0.jpg?width=600&height=800&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Bob Hyland was the Packers’ first-round pick in the 1967 NFL Draft."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Bob Hyland was the Packers’ first-round pick in the 1967 NFL Draft." data-c-credit="Packer Plus Files"></div></figure><p class=gnt_ar_b_p>Horn, a quarterback from San Diego State, had his moments during his brief time with the Packers. In the 1968 season finale at Wrigley Field, the Bears had to beat the Packers (5-7-1) to win the NFC Central Division. Bart Starr was injured and could not play. Backup Zeke Bratkowski got hurt in the first quarter. In stepped Horn. He threw two touchdown passes to put the Packers up, 28-10, in the third quarter. They held on to win, 28-27.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-6 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>He put on another show in the 1969 finale at Lambeau Field against the St. Louis Cardinals. In 4-degree wind chill, he completed 22 of 31 passes for 410 yards and five touchdowns as the Packers rolled to a 45-28 victory. </p><p class=gnt_ar_b_p>Horn was traded to the Denver Broncos following the 1970 season. The deal allowed the Packers to draft star running back John Brockington.</p><h2 class=gnt_ar_b_h2>1966: Jim Grabowski (ninth) and Gale Gillingham (13th)</h2><p class=gnt_ar_b_p>Grabowski, a fullback from Illinois, was the heir apparent to Jim Taylor. Unfortunately, he hurt his knee in 1967 and was plagued by injuries afterward. New Packers coach Dan Devine cut him before the 1971 season. He played that season with the Bears and then retired.</p><p class=gnt_ar_b_p>Gillingham, a guard from Minnesota, took over for the injured Fuzzy Thurston in the lineup at the end of his rookie season. He was a five-time Pro Bowler and was selected as the inaugural winner of the Forrest Gregg Award for the NFL Offensive Lineman of the Year following the 1970 season. He was the NFC choice as the NFLPA/Coca-Cola Offensive Lineman of the Year for 1971. He retired a few months after the 1976 season and was inducted into the Green Bay Packers Hall of Fame in 1982. In a curious move, Devine moved him to defensive tackle five days before the 1972 season began. He suffered a season-ending knee injury in the second game of the year. He returned to the offensive line, but had surgery on the knee again following the 1973 season. He was one of the first players in the NFL to use weight training to stay in playing shape during the offseason.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-native-article_link-sports-football-nfl-7 class="gnt_x_sl gnt_x_al"></div></aside><h2 class=gnt_ar_b_h2>1965: Donny Anderson (seventh) and Larry Elkins (10th)</h2><p class=gnt_ar_b_p>Anderson, a running back from Texas Tech, was the projected successor of Paul Hornung. During his second carry in the fourth quarter of the first Super Bowl, Anderson's knee knocked out Chiefs defensive back Fred "The Hammer" Williamson, who talked a lot of trash before the game. He played a key role on the winning drive in the Ice Bowl. Anderson rushed 18 times for 35 yards and caught four passes for 44 yards in the game. He was also a punter and originated the concept of hang time.</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:374px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/-mm-/acde59dd652c6edc31f8a72a53a38e8716187b7a/c=0-54-950-591/local/-/media/2017/08/24/WIGroup/PackersNews/636391722447381497-1WIAPP-APPLETON-POST-CRA0767.jpg?width=660&height=374&fit=crop&format=pjpg&auto=webp" decoding=async alt="Donny Anderson (44) of the Green Bay Packers dashes into the end zone on a 2 yard run in the third period of Super Bowl II in Miami, January 14, 1968.  On the ground under Anderson is (42) Oakland's linebacker Bill Laskey.  Other Packers players are (64) Jerry Kramer and (81) Marv Fleming.  Green Bay won 33-14. (AP Photo)"/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Donny Anderson (44) of the Green Bay Packers dashes into the end zone on a 2 yard run in the third period of Super Bowl II in Miami, January 14, 1968.  On the ground under Anderson is (42) Oakland's linebacker Bill Laskey.  Other Packers players are (64) Jerry Kramer and (81) Marv Fleming.  Green Bay won 33-14. (AP Photo)" data-c-credit=AP></div></figure><p class=gnt_ar_b_p>Elkins, a receiver out of Baylor, never played for the Packers. He opted to play for the Houston Oilers of the AFL. But his career never got off the ground due to injuries.</p><h2 class=gnt_ar_b_h2>1957: Paul Hornung (first) and Ron Kramer (fourth)</h2><p class=gnt_ar_b_p>Hornung, nicknamed "The Golden Boy," was a running back from Notre Dame. He was the first Heisman Trophy winner to be selected as the first overall selection in the NFL Draft, play pro football, win the NFL most valuable player award, and be inducted into both the professional and college football halls of fame. Packers coach Vince Lombardi said Hornung was "the greatest player I ever coached." The Pro Football Hall of Famer was notorious for sneaking out the night before games to carouse with Max McGee.</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:373px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/-mm-/ad3f8e9918676de1ede06ca2f660938c03cf3684/c=0-220-2078-1394/local/-/media/2014/12/14/WIGroup/PackersNews/635541685561470238-gwnbk-6cceo40pypy12rgug760-original.jpg?width=660&height=373&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/-mm-/ad3f8e9918676de1ede06ca2f660938c03cf3684/c=0-220-2078-1394/local/-/media/2014/12/14/WIGroup/PackersNews/635541685561470238-gwnbk-6cceo40pypy12rgug760-original.jpg?width=1320&height=746&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Green Bay Packers halfback Paul Hornung (5) follows guard Fuzzy Thurston (63) upfield against the Cleveland Browns during the NFL championship game at Lambeau Field on Jan. 2, 1966. It was Hornung's last great game with the Packers. He had 18 carries for 105 yards and a touchdown. The Packers won, 23-12."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Green Bay Packers halfback Paul Hornung (5) follows guard Fuzzy Thurston (63) upfield against the Cleveland Browns during the NFL championship game at Lambeau Field on Jan. 2, 1966. It was Hornung's last great game with the Packers. He had 18 carries for 105 yards and a touchdown. The Packers won, 23-12." data-c-credit="Press-Gazette Archives"></div></figure><p class=gnt_ar_b_p>Kramer, a tight end from Michigan, was a key player on Lombardi's first NFL championship teams in 1961 and 1962. Kramer was selected as a first-team All-NFL player in 1962.</p><aside class="gnt_em gnt_em_hf gnt_em__lp" data-g-r=lazy data-gl-type=method data-gl-method=loadHb64 aria-label=PackersNews data-t-cel=hb64 data-gl-hb64=PHN0eWxlPgoubWpzLWJpbyBpbWcgewogIGZsb2F0OiBsZWZ0OwogIGRpc3BsYXk6IGJsb2NrOwogIHdpZHRoOiA2MHB4OwogIG1hcmdpbi1yaWdodDogMiU7Cn0KICAgIGNvbG9yOiAjNDM0MzQzOwogICAgZmxvYXQ6IGxlZnQ7CiAgICB3aWR0aDogMTAwJTsKICAgIGZvbnQtc3R5bGU6IGl0YWxpYzsKICAgIHRleHQtYWxpZ246IGxlZnQ7CiAgICBmb250LXNpemU6IDg1JTsKfQo8L3N0eWxlPgo8ZGl2IGFsaWduPSJsZWZ0IiBzdHlsZT0iYm9yZGVyLXRvcDogNHB4IHNvbGlkICMwRDcwM0Y7IHBhZGRpbmc6IDRweDsgcGFkZGluZy1ib3R0b206IDRweDsgMXB4IHNvbGlkICMwMDliZmY7Ij4KPGRpdiBjbGFzcz0ibWpzLWJpbyI+CjxpbWcgc3JjPSJodHRwczovL3d3dy5nYW5uZXR0LWNkbi5jb20vcHJlc3RvLzIwMjEvMDIvMDkvUEdSQi9jMDFhZDI3YS00YWFhLTRjMDEtOWU0OC0yZjZkMTJlODMzZjEtTWljcm9zb2Z0VGVhbXMtaW1hZ2UucG5nIj4KPGRpdiBjbGFzcz0ibWpzLWJpby10ZXh0Ij48c3Ryb25nPk91ciBzdWJzY3JpYmVycyBtYWtlIHRoaXMgY292ZXJhZ2UgcG9zc2libGUuIENsaWNrIHRvIHN1YnNjcmliZSB0byBQYWNrZXJzIE5ld3MgYXQgPGEgaHJlZj0iaHR0cHM6Ly9jbS5wYWNrZXJzbmV3cy5jb20vc3BlY2lhbG9mZmVyP2dwcy1zb3VyY2U9Q1BORVdTJmFtcDtpdG1fbWVkaXVtPW9uc2l0ZSZhbXA7aXRtX3NvdXJjZT1uZXdzJmFtcDtpdG1fY2FtcGFpZ249TkVXU1JPT00mYW1wO2l0bV9jb250ZW50PUNQTkVXUyI+cGFja2Vyc25ld3MuY29tL3N1YnNjcmliZS48L2E+IE9yIGNsaWNrIHRvIHN1YnNjcmliZSB0bzxhIGhyZWY9Imh0dHBzOi8vb2ZmZXJzLnVzYXRvZGF5bmV0d29yay5jb20vbmV0d29yay1yZWdpb25hbC13aXNjb25zaW4gIj4gb25lIG9mIG91ciBsb2NhbCBXaXNjb25zaW4gbmV3cyBzaXRlcyw8L2E+IHdoaWNoIGluY2x1ZGVzIFBhY2tlcnNOZXdzIGNvdmVyYWdlLiBCZSBzdXJlIHRvIGRvd25sb2FkIG91ciBhcHAgb24gPGEgaHJlZj0iaHR0cHM6Ly9hcHBzLmFwcGxlLmNvbS91cy9hcHAvcGFja2VybmV3cy1jb20tcGFja2Vycy14dHJhL2lkOTA4ODMzNTczIj5pVHVuZXM8L2E+IG9yIDxhIGhyZWY9Imh0dHBzOi8vcGxheS5nb29nbGUuY29tL3N0b3JlL2FwcHMvZGV0YWlscz9pZD1jb20uZ2FubmV0dC5kb2xseS5QYWNrZXJzJmFtcDtobD1lbiI+R29vZ2xlIFBsYXkuPC9hPgo8L3N0cm9uZz48L3A+Cgo8L2Rpdj4KCjxkaXYgc3R5bGU9ImNsZWFyOiBib3RoOyI+PC9kaXY+CjwvZGl2PjwvZGl2PjwvZGl2Pgo8ZGl2IGFsaWduPSJsZWZ0IiBzdHlsZT0iYm9yZGVyLXRvcDo0cHggc29saWQgIzBENzAzRjsgcGFkZGluZzogNHB4OyBib3R0b206IDFweCBzb2xpZCAjMEQ3MDNGOyI+PC9kaXY+PC9kaXY+></aside><div class=gnt_ar_uns></div></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.packersnews.com/story/sports/nfl/packers/2022/04/25/green-bay-packers-history-two-first-round-picks-nfl-draft/7412482001/ data-ss-t="The Green Bay Packers have two first-round picks in the 2022 NFL draft. It's happened before, and here's how it worked out" data-ss-d="The Green Bay Packers have had two first round draft picks several times and not all of them panned out."><a class="gnt_ss_cm gnt_ss_cm__a" href="https://cm.packersnews.com/comment/?storyUrl=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F&marketName=packersnews&commentsopen=false" rel=nofollow data-t-l=":coral comments|comment|c|view comments">View Comments</a><div class=gnt_ss_cm_w data-g-r=nav_ce onmousedown=event.stopPropagation() onmouseup=event.stopPropagation() data-g-ctl=":coral comments|comment|close|register to comment"><button class=gnt_ss_cm data-g-r="base_tload nav_ab" data-g-tn=tooltipcm_bottom aria-label="View comments" aria-expanded=false>View Comments</button></div><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=249896938457153&href=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F&text=The%20Green%20Bay%20Packers%20have%20two%20first-round%20picks%20in%20the%202022%20NFL%20draft.%20It's%20happened%20before%2C%20and%20here's%20how%20it%20worked%20out&via=PGpackersnews" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=The%20Green%20Bay%20Packers%20have%20two%20first-round%20picks%20in%20the%202022%20NFL%20draft.%20It's%20happened%20before%2C%20and%20here's%20how%20it%20worked%20out%20-%20from%20Packers%20News&body=The%20Green%20Bay%20Packers%20have%20two%20first-round%20picks%20in%20the%202022%20NFL%20draft.%20It's%20happened%20before%2C%20and%20here's%20how%20it%20worked%20out%0A%0AThe%20Green%20Bay%20Packers%20have%20had%20two%20first%20round%20draft%20picks%20several%20times%20and%20not%20all%20of%20them%20panned%20out.%0A%0ACheck%20out%20this%20story%20on%20packersnews.com%3A%20https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><div class=gnt_rr_xpst><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-wi-greenbay-packersnews-C1014-poster-sports-football-nfl-8 class="gnt_x_sl gnt_x_p"></div></aside></div><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.packersnews.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F&marketName=packersnews&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|We're always working..." aria-label="We're always working to improve your experience. Let us know what you think."></a></div><div class=gnt_rr_xst><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-poster_scroll-sports-football-nfl-9 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-wi-greenbay-packersnews-C1014-poster_scroll-sports-football-nfl-10 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/sports/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><aside class=gnt_pm onmousedown=event.stopPropagation() onmouseup=event.stopPropagation() data-g-r=base_ex><button class=gnt_pm_eb data-g-r=base_et aria-expanded=false aria-label="Special offer"></button><div class="gnt_pm_ms gnt_pm__de"></div><a class="gnt_pm_a gnt_pm__de" href=# tabindex=0></a></aside><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-wi-greenbay-packersnews-C1014-leaderboard_btf-sports-football-nfl-11 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Packers News - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.packersnews.com/accessibility class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility Support</a> <a href=/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://cm.packersnews.com/ethical-conduct class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.packersnews.com/terms class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.packersnews.com/privacy class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.packersnews.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-rights>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bt" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.packersnews.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://localiq.com/markets/Wisconsin/ class=gnt_ft_a data-t-l=:f|v|c|support:advertise>Advertise Your Business</a> <a href=https://cm.packersnews.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://help.packersnews.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://account.packersnews.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href=https://cm.hawkcentral.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.packersnews.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.packersnews.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=https://www.facebook.com/packersnews class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=https://twitter.com/PGPackersNews class=gnt_ft_a data-t-l=:f|v|c|stay-connected:twitter>Twitter</a> <a href=http://static.packersnews.com/rss/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:rss-feeds>RSS Feeds</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2022 www.packersnews.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z31f5d0a1a.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z31ec2eabf.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" inputmode=search mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;touch-action:manipulation;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=navus><div class=gnt_n_us_dd data-g-r=nav_dd><div class=gnt_n_us_dd_u><a class=gnt_n_us_dd_a href=https://account.packersnews.com/ data-t-l=":m|a|c|manage account">Manage Account</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://user.packersnews.com/user/enewspaper data-t-l=:m|a|c|e-edition>E-Edition</a> <a class=gnt_n_us_dd_a href=https://profile.packersnews.com/newsletters/manage/ data-t-l=:m|a|c|newsletters>Newsletters</a> <a class=gnt_n_us_dd_a data-u-sr="reg sub" href=https://profile.packersnews.com/newsletters/preferences/ data-t-l=":m|a|c|email preferences">Email Preferences</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.packersnews.com/pay data-t-l=":m|a|c|pay bill">Pay Bill</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.packersnews.com/delivery-issue data-t-l=":m|a|c|report delivery issues">Report Delivery Issues</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.packersnews.com/delivery-temporary-stop data-t-l=":m|a|c|pause delivery">Pause Delivery</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://cm.packersnews.com/subscriberguide data-t-l=":m|a|c|subscriber guide">Subscriber Guide</a> <a class=gnt_n_us_dd_a href=https://help.packersnews.com data-t-l=":m|a|c|help center">Help Center</a> <a class="gnt_n_us_dd_a gnt_n_us_dd_a__li" data-u-sr="reg sub" href="https://user.packersnews.com/PPAN-GUP/user/logout/?return-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-t-l=":m|a|c|sign out">Sign Out</a></div><div class=gnt_n_us_dd_ac data-u-sr="anon reg"><div class=gnt_n_us_dd_lbl data-u-sr=anon>Have an existing account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_ba__hl" data-u-sr=anon rel=nofollow href="https://login.packersnews.com/PPAN-GUP/authenticate?success-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F&cancel-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-t-l=":m|a|c|sign in">Sign In</a><div class=gnt_n_us_dd_lbl>Already have a print subscription?</div><a class=gnt_n_us_dd_ba rel=nofollow href=https://cm.packersnews.com/account-activation/ data-t-l=":m|a|c|activate account">Activate account</a><div class=gnt_n_us_dd_lbl data-u-sr=anon>Don't have an account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_a__li" data-u-sr=anon rel=nofollow href="https://login.packersnews.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux" data-t-l=":m|a|c|create account">Create account</a></div></div>|styles|.gnt_n_us_a_w{position:relative}.gnt_n_us_dd{display:none;position:absolute;top:28px;right:25px;padding:14px 0 14px 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_us_dd{display:flex}.gnt_n_us_dd_u{display:flex;flex-direction:column;min-width:165px;padding-right:15px}.gnt_n_us_dd_a{margin:3px auto 4px 3px;padding:0 2px;color:#fff;font:700 14px/18px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;white-space:nowrap}.gnt_n_us_dd_a:hover{color:#e0e0e0}.gnt_n_us_dd_ac{padding:0 15px 0 19px;border-left:1px solid #626262}.gnt_n_us_dd_lbl{margin:5px 0 0;color:#fff;font:700 12px/16px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_us_dd_ba{display:block;width:192px;margin:3px 0 19px;padding:9px 1px 8px;border:3px solid #1665cf;outline-offset:-1px;color:#fff;font:700 14px/17px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_n_us_dd_ba__hl{padding:12px 4px 11px!important;border:0!important;background:var(--gnt-bc,#1665cf)}.gnt_n_us_dd_ba:hover{padding:8px 0 7px;border-width:4px;--gnt-bc:#0A32A0}.gnt_n_us_dd_a__li{margin-bottom:6px}</script><script type="gnt/tmpl" data-tmpl-key=tooltipcm_top><div class=gnt_ss_ct data-g-r=nav_dd><div class=gnt_ss_ct_hl>Create an account to view comments</div><div class=gnt_ss_ct_ds>See what people in your community are saying with a free account.</div><a class=gnt_ss_ct_bt tabindex=0 rel=nofollow href="https://login.packersnews.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux&itm_medium=coralcomments&itm_source=registertocomment&itm_term=registration&success-url=https%3A%2F%2Fcm.packersnews.com%2Fcomment%2F%3FstoryUrl%3Dhttps%253A%252F%252Fwww.packersnews.com%252Fstory%252Fsports%252Fnfl%252Fpackers%252F2022%252F04%252F25%252Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%252F7412482001%252F%26marketName%3Dpackersnews%26commentsopen%3Dfalse&cancel-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-t-l=":coral comments|comment|register|click">Create Account</a> <a class=gnt_ss_ct_a tabindex=0 rel=nofollow href=https://cm.packersnews.com/whats-included-register data-t-l=":coral comments|comment|whats included|register to comment">What's included?</a><button class=gnt_ss_ct_cb data-g-r=nav_cl aria-label="Close Disclaimer" aria-expanded=true></button></div>|styles|.gnt_ss_ct{display:none}[data-g-s=nav_ao] .gnt_ss_ct{isolation:isolate;transform:translate3d(0,0,0);box-sizing:border-box;display:flex;flex-flow:row wrap;position:absolute;bottom:41px;left:3px;width:325px;min-height:86px;padding:10px 48px 14px 13px;background:#0a852b;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;user-select:none;cursor:default}.gnt_ss_ct::after{content:'';position:absolute;bottom:-10px;left:12px;width:0;height:0;border-top:12px solid #0a852b;border-right:12px solid transparent;border-left:12px solid transparent}.gnt_ss_ct_hl{content:attr(data-c-th);color:#fff;font:700 14px/16px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-user-select:none}.gnt_ss_ct_ds{content:attr(data-c-td);color:#fff;margin:2px 0 6px;font:12px/14px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-user-select:none}.gnt_ss_ct_bt{contain:layout size;isolation:isolate;width:114px;height:24px;border-radius:2px;background:#fff;color:#1665cf;font:700 12px/24px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_ss_ct_bt:hover{color:#0a32a0}.gnt_ss_ct_a{align-self:center;margin-left:10px;padding-top:1px;color:#fff;font:10px/13px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-underline-offset:1px}.gnt_ss_ct_a:hover{color:#e0e0e0}.gnt_ss_ct_cb{contain:layout size;position:absolute;top:8px;right:7px;margin:0;padding:11px;border:0;background:0 0;-webkit-font-smoothing:initial;-moz-osx-font-smoothing:initial;touch-action:manipulation;cursor:pointer}.gnt_ss_ct_cb::after,.gnt_ss_ct_cb::before{content:'';position:absolute;top:10px;left:4px;transform:rotate(45deg);width:14px;height:2px;background:var(--gnt-tphc,#fff)}.gnt_ss_ct_cb::after{transform:rotate(-45deg)}.gnt_ss_ct_cb:hover{--gnt-tphc:#E0E0E0}</script><script type="gnt/tmpl" data-tmpl-key=pg7442898001><div class=gnt_em_mo_oy id=gnt_em_mo_oy role=dialog aria-modal=true aria-live=assertive aria-busy=true aria-roledescription=gallery><div class=gnt_em_mo data-g-r=nav_dd><button class=gnt_em_mo_xb data-g-r=nav_cl aria-label="Close Gallery"></button><div class=gnt_em_mo_ic><div class=gnt_em_mo_em></div><div class=gnt_em_mo_img_f><img class=gnt_em_mo_img alt="" usemap=#gnt_em_mo_mp /></div><map name=gnt_em_mo_mp class=gnt_em_mo_mp><area class="gnt_em_mo_mp_ar gnt_em_mo_mp_ar__pv" hidden coords="0 0 330 495" alt="" title="View Previous Image" tabindex=-1 aria-disabled=true /><area class="gnt_em_mo_mp_ar gnt_em_mo_mp_ar__nx" hidden coords="330 0 660 495" alt="" title="View Next Image" tabindex=-1 aria-disabled=true /></map><div class=gnt_em_mo_cn data-c-gc=22>1</div><button class="gnt_em_mo_pb gnt_em_mo_pb__pv" disabled aria-disabled=true aria-label="Previous image in gallery" aria-controls=gnt_em_mo_oy aria-keyshortcuts=ArrowLeft></button><button class="gnt_em_mo_pb gnt_em_mo_pb__nx" disabled aria-disabled=true aria-label="Next image in gallery" aria-controls=gnt_em_mo_oy aria-keyshortcuts=ArrowRight></button></div><div class=gnt_em_mo_tc><div class="gnt_ss gnt_em_mo_ss" data-g-r=base_sc data-ss-u=https://www.packersnews.com/picture-gallery/sports/nfl/packers/2022/04/25/photos-green-bay-packers-first-round-draft-picks-2000-2021/7442898001/ data-ss-t="Here are the Green Bay Packers' first-round draft picks from 2000-2021" data-ss-d="A look at each of the Green Bay Packers' first-round selections in the NFL draft going back to 2000."><a class="gnt_ss_a gnt_em_mo_ss_a" href="https://www.facebook.com/dialog/share?display=popup&app_id=249896938457153&href=https%3A%2F%2Fwww.packersnews.com%2Fpicture-gallery%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fphotos-green-bay-packers-first-round-draft-picks-2000-2021%2F7442898001%2F" data-g-r=base_si data-ss-a=f data-t-l=":social share (gallery)|v|c|facebook" aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class="gnt_ss_a gnt_em_mo_ss_a" href="http://twitter.com/share?url=https%3A%2F%2Fwww.packersnews.com%2Fpicture-gallery%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fphotos-green-bay-packers-first-round-draft-picks-2000-2021%2F7442898001%2F&text=Here%20are%20the%20Green%20Bay%20Packers'%20first-round%20draft%20picks%20from%202000-2021&via=PGpackersnews" data-g-r=base_si data-ss-a=t data-t-l=":social share (gallery)|v|c|twitter" aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class="gnt_ss_a gnt_em_mo_ss_a" href="mailto:?subject=Here%20are%20the%20Green%20Bay%20Packers'%20first-round%20draft%20picks%20from%202000-2021%20-%20from%20Packers%20News&body=Here%20are%20the%20Green%20Bay%20Packers'%20first-round%20draft%20picks%20from%202000-2021%0A%0AA%20look%20at%20each%20of%20the%20Green%20Bay%20Packers'%20first-round%20selections%20in%20the%20NFL%20draft%20going%20back%20to%202000.%0A%0ACheck%20out%20this%20story%20on%20packersnews.com%3A%20https%3A%2F%2Fwww.packersnews.com%2Fpicture-gallery%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fphotos-green-bay-packers-first-round-draft-picks-2000-2021%2F7442898001%2F" data-t-l=":social share (gallery)|v|c|email" aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><a class="gnt_ss_a gnt_em_mo_ss_a" href=https://www.packersnews.com/picture-gallery/sports/nfl/packers/2022/04/25/photos-green-bay-packers-first-round-draft-picks-2000-2021/7442898001/ target=_blank rel=noopener data-t-l=":social share (gallery)|v|c|sharelink" aria-label="Standalone gallery page"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_sharelink /></svg></a><button class="gnt_ss_a gnt_ss_a__sa gnt_em_mo_ss_a" data-g-r=base_si data-ss-a=s data-t-l=":social share (gallery)|v|c|shareapi" aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class=gnt_em_mo_cc><div class="gnt_em_mo_cap gnt_em_mo_cc__swd"></div><div class="gnt_em_mo_crd gnt_em_mo_cc__swd"></div></div></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pglbl gnt_x__lg"><div id=ad-slot-7103-wi-greenbay-packersnews-C1014-leaderboard_gallery_companion-sports-football-nfl-1 class="gnt_x_lb gnt_x_lb__lg"></div></aside><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pglbl gnt_x__pg"><div id=ad-slot-7103-wi-greenbay-packersnews-C1014-poster_gallery_companion-sports-football-nfl-1 class=gnt_x_pg></div></aside></div></div></script><script type="gnt/tmpl" data-tmpl-key=pgcss>|styles|.gnt_em_mo_oy{overscroll-behavior:contain;overflow:auto;contain:strict;display:flex;flex-wrap:wrap;position:fixed;z-index:2147483647;top:0;left:0;width:100%;height:100%;background:#000;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;pointer-events:auto}.gnt_em_mo_xb{position:absolute;z-index:1;top:20px;right:20px;width:44px;height:44px;margin:0;border:4px solid #fff;border-radius:50%;background:#303030;touch-action:manipulation;cursor:pointer}.gnt_em_mo_xb::before{content:'';position:absolute;top:17px;left:10px;transform:rotate(45deg);width:16px;height:2px;background:#fff}.gnt_em_mo_xb::after{content:'';position:absolute;top:17px;left:10px;transform:rotate(-45deg);width:16px;height:2px;background:#fff}.gnt_em_mo_xb:hover{background:#000}.gnt_em_mo{contain:layout;display:flex;justify-content:center;position:relative;width:980px;height:676px;margin:auto;padding:30px 10px 20px 14px;background:#000;color:#fff}.gnt_em_mo_ic{contain:layout size;display:flex;flex-flow:wrap;align-content:start;width:660px}.gnt_em_mo_em{contain:strict;display:none}.gnt_em_mo_em[data-c-et]{display:flex;flex-flow:column;justify-content:center;width:500px;height:495px;margin:0 80px -495px;font:700 20px/26px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-align:center}.gnt_em_mo_em::before{content:attr(data-c-et)}.gnt_em_mo_em::after{content:attr(data-c-eb);margin:20px 0;font-weight:400;font-size:16px;line-height:20px}.gnt_em_mo_img_f{will-change:contents;contain:strict;transform:translate3d(0,0,0);width:660px;height:495px;margin:0 0 20px}.gnt_em_mo_img{contain:content;visibility:visible!important;opacity:0;display:block;object-fit:contain;width:660px;height:495px}.gnt_em_mo_img[srcset]{opacity:1}.gnt_em_mo_mp{touch-action:manipulation}.gnt_em_mo_mp_ar:not([hidden]){touch-action:manipulation;cursor:pointer}.gnt_em_mo_cn{will-change:contents;contain:strict;transform:translate3d(0,0,0);width:120px;margin:0 16px 0 154px;font:700 16px/36px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-rendering:optimizeLegibility;text-align:right;pointer-events:none}.gnt_em_mo_cn::after{content:' OF ' attr(data-c-gc);color:#c2c2c2}.gnt_em_mo_pb{will-change:background;contain:strict;transform:translate3d(0,0,0);width:36px;height:36px;margin:0 2px;padding:0;border:0;background:#1665cf;touch-action:manipulation;cursor:pointer}.gnt_em_mo_pb::before{content:'';display:inline-flex;height:4px;width:4px;margin:7px 0 7px 7px;padding:2.5px;border-right:2px solid #fff;border-bottom:2px solid #fff;transform:rotate(135deg)}.gnt_em_mo_pb__nx::before{margin-left:-4px;transform:rotate(-45deg)}.gnt_em_mo_pb:hover{background:#0a32a0}.gnt_em_mo_pb:disabled{background:#404040;cursor:default}.gnt_em_mo_tc{contain:layout size;display:flex;flex-flow:column;width:300px;margin:49px 0 0 20px}.gnt_em_mo_ss{contain:layout size;transform:translate3d(0,0,0);width:225px;height:30px;margin:-52px 0 22px -8px}.gnt_em_mo_ss_a{--gnt-sfc:#FFF;margin:0 11px 0 5px;padding:3px;font-size:24px}.gnt_em_mo_ss_a:hover{--gnt-sfc:#E0E0E0}.gnt_em_mo_cc{will-change:contents;contain:strict;transform:translate3d(0,0,0);width:300px;height:356px;-webkit-user-select:text;user-select:text}.gnt_em_mo_cap{margin:0 0 16px;font:16px/20px 'Georgia Pro',Georgia,'Droid Serif',serif;text-rendering:optimizeLegibility}.gnt_em_mo_crd{font:italic 12px/14px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-rendering:optimizeLegibility}.gnt_em_mo_cc__swd:empty{display:none}.gnt_em_mo_cap_a{color:#fff;text-decoration:underline;text-decoration-color:#0098fe;text-decoration-thickness:2px;text-underline-offset:2px}.gnt_em_mo_cap_a:hover{color:#c2c2c2}.gnt_x__lg{display:none}.gnt_x__pg{contain:layout size;position:absolute;bottom:20px;right:10px;width:300px;height:268px;margin:0}.gnt_x_pg{contain:strict;overflow:hidden;transform:translate3d(0,0,0);width:300px;height:250px;background:#262626}.gnt_x__pglbl::before{color:#fff}@media (min-width:1200px){.gnt_em_mo_oy{background:rgba(0,0,0,.8)}.gnt_em_mo_xb{right:-20px}.gnt_em_mo{width:1020px;padding:30px 60px 34px}.gnt_em_mo_tc{margin:49px 0 0 60px}.gnt_x_lb__lg{background:#262626}.gnt_x__lg{contain:layout size;display:block;position:absolute;left:26px;bottom:34px;width:728px;height:108px;margin:0}.gnt_x__pg{bottom:34px;right:60px}}@media (min-height:780px){.gnt_em_mo_xb{top:-20px}}</script><script type="gnt/tmpl" data-tmpl-key=tooltipcm_bottom><div class=gnt_ss_ct data-g-r=nav_dd><div class=gnt_ss_ct_hl>Create an account to view comments</div><div class=gnt_ss_ct_ds>See what people in your community are saying with a free account.</div><a class=gnt_ss_ct_bt tabindex=0 rel=nofollow href="https://login.packersnews.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux&itm_medium=coralcomments&itm_source=registertocomment&itm_term=registration&success-url=https%3A%2F%2Fcm.packersnews.com%2Fcomment%2F%3FstoryUrl%3Dhttps%253A%252F%252Fwww.packersnews.com%252Fstory%252Fsports%252Fnfl%252Fpackers%252F2022%252F04%252F25%252Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%252F7412482001%252F%26marketName%3Dpackersnews%26commentsopen%3Dfalse&cancel-url=https%3A%2F%2Fwww.packersnews.com%2Fstory%2Fsports%2Fnfl%2Fpackers%2F2022%2F04%2F25%2Fgreen-bay-packers-history-two-first-round-picks-nfl-draft%2F7412482001%2F" data-t-l=":coral comments|comment|register|click">Create Account</a> <a class=gnt_ss_ct_a tabindex=0 rel=nofollow href=https://cm.packersnews.com/whats-included-register data-t-l=":coral comments|comment|whats included|register to comment">What's included?</a><button class=gnt_ss_ct_cb data-g-r=nav_cl aria-label="Close Disclaimer" aria-expanded=true></button></div>|styles|.gnt_ss_ct{display:none}[data-g-s=nav_ao] .gnt_ss_ct{isolation:isolate;transform:translate3d(0,0,0);box-sizing:border-box;display:flex;flex-flow:row wrap;position:absolute;bottom:41px;left:3px;width:325px;min-height:86px;padding:10px 48px 14px 13px;background:#0a852b;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;user-select:none;cursor:default}.gnt_ss_ct::after{content:'';position:absolute;bottom:-10px;left:12px;width:0;height:0;border-top:12px solid #0a852b;border-right:12px solid transparent;border-left:12px solid transparent}.gnt_ss_ct_hl{content:attr(data-c-th);color:#fff;font:700 14px/16px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-user-select:none}.gnt_ss_ct_ds{content:attr(data-c-td);color:#fff;margin:2px 0 6px;font:12px/14px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-user-select:none}.gnt_ss_ct_bt{contain:layout size;isolation:isolate;width:114px;height:24px;border-radius:2px;background:#fff;color:#1665cf;font:700 12px/24px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_ss_ct_bt:hover{color:#0a32a0}.gnt_ss_ct_a{align-self:center;margin-left:10px;padding-top:1px;color:#fff;font:10px/13px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-underline-offset:1px}.gnt_ss_ct_a:hover{color:#e0e0e0}.gnt_ss_ct_cb{contain:layout size;position:absolute;top:8px;right:7px;margin:0;padding:11px;border:0;background:0 0;-webkit-font-smoothing:initial;-moz-osx-font-smoothing:initial;touch-action:manipulation;cursor:pointer}.gnt_ss_ct_cb::after,.gnt_ss_ct_cb::before{content:'';position:absolute;top:10px;left:4px;transform:rotate(45deg);width:14px;height:2px;background:var(--gnt-tphc,#fff)}.gnt_ss_ct_cb::after{transform:rotate(-45deg)}.gnt_ss_ct_cb:hover{--gnt-tphc:#E0E0E0}</script><script async src=/tangstatic/js/pg-q1a2z330dc051c.min.js></script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z392HBuVYpQ7m8VVBq9DIx1u6uMco.min.json /><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/tangsvc/pg/7442898001/ /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>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</script><noscript><iframe src="https://www.google-analytics.com/collect?cd1=custom&cd28=PPAN&cd49=tangent&cd171=1&cid=1&ea=pageview&ec=content&el=noscript&t=event&tid=UA-166840762-67&v=1" height=0 width=0 loading=eager sandbox=allow-same-origin style=display:none;visibility:hidden></iframe></noscript></body></html>